1. Are you ready for the Galaxy S20? Here is everything we know so far!

Anyone know how to unbrick an Admire?

Discussion in 'Android Devices' started by jerryag, Aug 17, 2012.

  1. jerryag

    jerryag Well-Known Member
    Thread Starter

    So, today my Admire randomly started screwing up. My camera button wouldn't work nor my home screen button. The phone constantly kept rebooting after 5-10 minutes of being booted. I figured it was something to do with the ROM so I tried Factory Data Rest a few times to no prevail, it presisted to reboot and the buttons wouldn't work. By then I was frustrated and rebooted into CWM to attempt at re-doing everything completely again, my home key and camera keys are fail. I had successfully deleted /system and /data before... well they stopped working entirely again. Now I can't reboot into Download mode due to Camera button not working. And can't flash anything new due to the home button not working. I really have ran out of ideas on what I can do...

    Any suggestions? Any one? D:
     



    1. Download the Forums for Android™ app!


      Download

       
  2. KageBeast

    KageBeast Android Expert

    Sounds like you gotta get a replacement since you you can't even go into Download mode so your phone might as well be hard bricked
     
  3. jerryag

    jerryag Well-Known Member
    Thread Starter

    I can get into Recovery. I can issue SOME ADB commands to the device. I'm not sure how screwed up it is. Seems to have started on it's own and me tinkering with it only made things worse. I'm curious if there are ways other than ODIN and CWM I can try to get a stock ROM tossed back on this thing D:
     
  4. Diego1593

    Diego1593 Android Enthusiast

    open it and hit the camera button to get in odin or return the phone to metropcs but brick the device and tell them you left it overnight charging and it didn't turn on thats if yo got insurance
     
  5. jerryag

    jerryag Well-Known Member
    Thread Starter

    Camera button isn't doing it. I had it to work once and was flashing back with Odin and dropped the phone battery popped out and well since I haven't been able get it back in Download mode D: I just hope there is some other way, I don't have insurance. It's metropcs lol
     
  6. Diego1593

    Diego1593 Android Enthusiast

    Every admire from metro has a 1 year insurancr xD they don't tell you when you buy it cause they want to make you buy a new phone
     
  7. KageBeast

    KageBeast Android Expert

    There is no other way to revert back to stock. CWM and Odin are the only way. You can keep trying to get the camera button working. I'd you can get it in download mode just once you'll be good to go
     
  8. Shabbypenguin

    Shabbypenguin Extreme Android User

    youve got adb access then youve got a way back.

    you can either dd the partitions onto your device using adb and bam your good
    or
    adb reboot download
    from there you can do the typical odin restore

    yea its that easy
     
  9. jerryag

    jerryag Well-Known Member
    Thread Starter

    I've tried reboot download. Seems with the buggy camera and home button thats not working now either. However, what do you mean by dd the partitions. At this point there isn't anything I can do to make it much worse so I'll try whatever.
     
  10. Shabbypenguin

    Shabbypenguin Extreme Android User

    adb shell reboot download might work better for ya. if you wanna dd the partitions back to stock you will need to have access to adb and have the files on the phone (you can adb push them) if you get them copied over i can assist you with the commands. however i am about to go to bed, my apologies i can be on tomorrow in the irc to assist but here is teh basic jist of the commands

    adb shell if=/sdcard/boot.img of=/dev/bml9
    adb shell if=/sdcard/system.rfs of=/dev/stl12

    of course this assumes you download the odin tar extract the files and grab those two and copy them to your sdcard with those file names. that should use dd (a low level copy program) to copy system.rfs onto the system partition, as well as the boot.img (kernel) to the proper spot.

    if you dont feel comfortable doing this yourself ill be on as soon as i wake up tomorrow :/
     
  11. jerryag

    jerryag Well-Known Member
    Thread Starter

    Sadly ADB Push/Pull commands aren't found. I can browse through the phones files using Droid Explorer when in Recovery mode, would that be helpful?
     
  12. jerryag

    jerryag Well-Known Member
    Thread Starter

    Also, I have those 2 files on my SDCard. I just wish those buttons didn't mess up. It's happened before but they always started working again with a Factory Data Reset. :\
     
  13. Shabbypenguin

    Shabbypenguin Extreme Android User

    dont see why adb push wouldnt work if you had adb shell access, if the hardware is going bad this is nothing more than just putting a bandaid on a infected cut. you will need to get it fixed/swapped but getting it back to stock at least gets ya a working phone for now.
     
  14. jerryag

    jerryag Well-Known Member
    Thread Starter

    I can do Reboot Download, but it doesn't boot into download mode. I can get to CWM but I can't click anything with home key and camera button acts more like a power button. This has happened a few times since I've had my admire but it's always went away. This time everything just seems screwed. I can't ADB Push/Pull it says command not found type thing in the shell. something like /system/bin/sh push: not found something like that. Same with pull and su. Format commands wont work either. Seems I'm limited D: I've switched services over to crappy phone for now so I can still get calls and such hopefully I can fix this one.
     
  15. Shabbypenguin

    Shabbypenguin Extreme Android User

    ah ok yea by you deleting /system you removed /system/bin/sh which is what adb shell uses.. ergo you have adb access but not adb shell. so unless you can navigate cwm there is nothing you can do :/

    cwm operates at a lower level than system and a factory reset wouldnt affect it. the fact your buttons dont work here is more of an indicator that things are busted...
     
  16. jerryag

    jerryag Well-Known Member
    Thread Starter

    But for some reason I can still do some ADB stuff, why is that? D:
    When I removed /system the first time it worked at getting my buttons restored. But, during ODIN Flashing my phone was on the edge of the desk and it kinda got knocked off a bit and battery popped out and it came unplugged then stopped working :\
    Droid Explorer allows me to view files on the phone still. There is no way something can be drug from there and wrote to the phone?

    I can also mkdir and probably make a file anyway I can manually add in the code for push and such back?
     
  17. Shabbypenguin

    Shabbypenguin Extreme Android User

    adb is a binary running in the recovery mode, however adb shell connects to basically the phones terminal mode, which without sh (the shell) it wont work. so you can do some basic adb commands cuz adb is there but not the shell. if you would like to try try pushing over sh to /system/bin/sh using the droid commander thingy.. if it works then awesome :)
     
  18. jerryag

    jerryag Well-Known Member
    Thread Starter

    Lets say I can get sh over. What would I then do?
     
  19. Shabbypenguin

    Shabbypenguin Extreme Android User

    same commands i gave ya yesterday :)
     
  20. jerryag

    jerryag Well-Known Member
    Thread Starter

    I tried those. The terminal just showed they went through but idk if they worked entirely. o.o

    I think it's dead :( Thanks for your help though.
     
  21. Slickinator

    Slickinator Android Enthusiast

    Smash it on the floor and run it over a few times, then take it to the store and say you dropped it. Or put it on eBay as "Slightly used" or "Mint condition" lol
     
  22. HotRoderX

    HotRoderX Android Enthusiast

    This might just be me but almost sounds like a hardware issue. Randomly you start having the phone act up. Then buttons stop working out of the blue. Guess its possible that it was the ROM fried but that seems like a long shot.

    One thing that comes to mind could have been a power surge or dip. I am not talking about like lighting but some times the power company has a surge on there end. The other thing is a power dip that is really horrible for all electronic devices. Suddenly the power in the house drops and things stop getting the power they need. When that happens a surge protector will not save you only a battery back up.

    That's just my opinion thought sounds more like a hardware issue. Special when you said the buttons worked on and off.

    Restarting the phone would or should have fixed the buttons if it was software. I do not understand how software would allow the buttons to work some times but not all the times. The software on the phone does not change if its going to work its going to work.
    Its either working or its corrupted there is no real middle ground.
     
  23. Shabbypenguin

    Shabbypenguin Extreme Android User

    did you have adb shell working? if so then you may be able to fix it.. im not allowed to tell you to join the irc and get live help (within reasonable hours of course.. its amazing on how so many people think i should be around at 3am to help them fix their phone...) or to tell you to download software which would allow me remote access to assist you :/

    androidforums wants the answer posted on teh forums to help other people solve it if need be.
     
  24. jerryag

    jerryag Well-Known Member
    Thread Starter

    Inbox me the IRC network so I can connect up.
     
  25. nuttmeg

    nuttmeg Extreme Android User

    download the new samsung update and run it, and it will return you to stock but you will have to get the phone in download mode.
     

Samsung Admire Forum

The Samsung Admire release date was September 2011. Features and Specs include a 3.5" inch screen, 3MP camera, GB RAM, processor, and 1600mAh battery.

September 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...