1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root anyone used z4root on evo

Discussion in 'Android Devices' started by CRAZYISH, Feb 22, 2011.

  1. CRAZYISH

    CRAZYISH Member
    Thread Starter

    has anyone used the z4root on the htc evo and whats the pros and cons
     

    Advertisement

  2. akazabam

    akazabam Android Expert

    You can use z4root to get soft root, meaning it will root your ROM only. All you'll be able to do is run apps that require root. It will not unlock nand (change S-ON to S-OFF). If all you want to do is run root-only apps, such as wifi tether, it might work fine. That being said, you'd need to run it every time you reboot. It doesn't keep root permanent unless you already have S-OFF. I've heard reports that it sometimes fails to get root like this, as well. I would recommend you go with a full root method, such as unrevoked. You do not need to take advantage of S-OFF if you don't want to. If you want to stick with the stock ROM, that's fine. That being said, unrevoked has an option to leave S-ON, but you'll still get a custom recovery, so you might as well go with S-OFF. It's easy to undo if you need to. The process isn't difficult.
     
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i haven't used it. i used the rooting for dummies guide which uses unrevoked 3.3. but i have heard that for some people it only gave them partial root and that z4root was able to completely root their phone.
     
  4. akazabam

    akazabam Android Expert

    Right, that is a different issue. Sometimes unrevoked bombs out half way through, changing S-ON to S-OFF, but leaving the user without recovery, and a non-rooted ROM. If that is the case, recovery can be flashed manually, and z4root can root the stock ROM, as nand is unlocked at that point.
     
  5. jericko

    jericko Android Enthusiast

    I use it allot to give me access to run Wifi Tether. I do not want to root my phone but just use that one app, so it works perfect for me.
     
  6. CRAZYISH

    CRAZYISH Member
    Thread Starter

    thanx guys i just tried unrevoked, everythin goes smooth until the end then it says failed so not sure why . might go the z4root way just for the tether
     
  7. akazabam

    akazabam Android Expert

    How far did it get? What was the exact error message? If it got far enough along, parts of it may already be done, and you're not going to want to use z4root until you know for sure. Turn the phone off, then turn it back on while pressing volume down to get to hboot. Do you see S-ON or S-OFF? While in hboot, select recovery. The phone should reboot into recovery. What exactly do you see when that happens. Boot up normally, and check if you have the Superuser app in your app drawer. Whether you do or don't, install the terminal emulator from the market. Type "su" without quotes, then enter. If the prompt changes from $ to #, your ROM is rooted. If it gives you a permissions error, your ROM isn't rooted.
     
  8. CRAZYISH

    CRAZYISH Member
    Thread Starter

    ill try that now
     
  9. CRAZYISH

    CRAZYISH Member
    Thread Starter

    did the select recovery all i see is a phone with a tri-angle with a !
     
  10. CRAZYISH

    CRAZYISH Member
    Thread Starter

    when i did the unevo it said failed is ur version too new something like that

    build num 3.70.651.1
    software # 3.70.651.1
     
  11. akazabam

    akazabam Android Expert

    Okay, I expected that, but what about S-OFF and the terminal emulator test?
     
  12. CRAZYISH

    CRAZYISH Member
    Thread Starter

    its on s off then i tried the market and i see the $
     
  13. CRAZYISH

    CRAZYISH Member
    Thread Starter

    hey akazabam thanx for ur help but maybe i should just leave it be for now and do more research . thanx everyone for the help
     
  14. akazabam

    akazabam Android Expert

    Well, you're saying you have S-OFF, now, right? If so, flash Clockwork 2.6.0.1 from here. Follow the instructions in that thread to do so. Once that is done, use the z4root permanent root option to root your ROM.

    EDIT: Oh, and even if this does work for you, yes, you should most definitely go do some more research. Knowing what you did to your phone is just as important as actually doing it.
     
    CRAZYISH likes this.
  15. techiediva

    techiediva Lurker

    I have been using z4 root for temporary root because I was a little nervous about doing the permanent root. It has been working fine and I was even able to uninstall some of the sprint bloatware with help from titanium backup app. My only problem is that I would like to now update my phone to 3.70 for the full version of swipe and a few other things but when I try to update my phone, it fails. I have tried the OTA and the manual version.

    With the manual version, it goes through recovery just fine and when i choose applysdcard:update.zip it extracts and starts but then ends with this error message:

    Installing update…
    assert failed: file_getprop(“/system/build.prop”
    , “ro.build.fingerprint”) == “sprint/htc_superso
    nic/supersonic/supersonic:2.2/FRF91/272076:user/
    release-keys” || file_getprop(“/system/bui
    ld.prop”, “ro.build.fingerprint”) == “sprint/htc
    _supersonic/supersonic/supersonic:2.2/FRF91/2948
    84:user/release-keys”
    E:Error in /sdcard/update.zip
    (Status 7)
    Installation aborted.

    Any advice would be greatly appreciated! I'm on the verge of replacing the EVO and passing this off on my husband.
     
  16. Xtremedays

    Xtremedays Android Expert

     
Loading...
Tags:

Share This Page

Loading...