1. Download our Official Android App: Forums for Android!

Support APN question...

Discussion in 'Android Devices' started by nu2moding, Aug 30, 2011.

  1. nu2moding

    nu2moding Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    190
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    190
    20
    58
    the other day i flashed froyoman for the ideos and had everything except internet. checked the APN settings and they were blank.
    saw Tokenpoke's post here:http://androidforums.com/m835-all-things-root/402371-ideos-roms-m835.html and I thought this might work!
    flashed the froyo version of metroff as per here:
    [07.18.2011] MetrOFF v1.2 | MetroPCS One-Flash-Fix [MMS] - xda-developers and ended up with no UIM, emergency calls only.
    after much searching i figured why not flash (thru fastboot)the nandroid i made of my mom's stock, unrooted m835?
    got the no UIM thingy crap off got mms and everything else EXCEPT internet:thinking:
    i got ti backup, root explorer(paid) and Ti is what got the mms to work(uninstalled phone apk, etc n reinstalled with my earliest non screwed-up backup)
    now im stuck with no web, n everytime i input apn settings it doesn't save for crap. BUT while inputting the apn settings the data icon lit up:D
    but died as soon as i tried to save or exit.:(
    anyhow back to the topic of this post...
    CAN i PUT THE METRO PCS APN SETTINGS INTO THE PHONE USING ADB? and if so, how?
     

    Advertisement

  2. nu2moding

    nu2moding Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    190
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    190
    20
    58
    these are the exact settings i need, which came off my mom's m835 AND in the data/data/com.android.providers.telephony/databases/telephony.db/carriers
    name:MEtroPCS
    APN: #777
    proxy: proxy.metropcs.net
    port: 3128
    username: yourphonenumber@aaaj.mymetropcs.com
    password: 699160
    mmsc: http://mms.metropcs.net:3128/mmsc
    mcc: 311
    mnc: 660
    type: PAP or CHAP
    apn type : *(astrix)


    oh and my build.prop says
    "#begin volatile config
    #end volatile config"
    then switches between eclair and froyo after the #
    this aint right, is it?
     
  3. starxpilot

    starxpilot Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    536
    Joined:
    Jul 24, 2011

    Jul 24, 2011
    536
    61
    98
    Loss Prevention Agent
    Garland
    What the hell, the actual BUILD number changes?!

    That's not a problem with the settings I believe, that's a problem with the actual ROM/Android OS...
     
  4. nu2moding

    nu2moding Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    190
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    190
    20
    58
    and how would one fix this? cuz aparently when i flashed metroff the phone was described as gsm in various apps, but now i think the ahaa moment came when i thought about why no uim etc.. popped up n i lost my signal after i flashed that metroff crap.
    im guessing the gsm support stayed somehow n even migrated between roms. is that even possible?
    im back to the stock metro software, but STILL no uim card, emergency service...
     
  5. starxpilot

    starxpilot Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    536
    Joined:
    Jul 24, 2011

    Jul 24, 2011
    536
    61
    98
    Loss Prevention Agent
    Garland
    I'm not quite sure how to fix this, I was about to say to ask Totenpoke, but where in that thread did he post this info? I only see this.
    I see a link in there but I'm very fishy about it since the guy only has like 4 posts...plus no one really has tested it and came back with results.

    There is no update for this phone, or downgrade, messing with the APN exceeds this user's knowledge so...I'm not quite sure how to fix this one. Sorry, only thing I can suggest is going to Metro XD
     
  6. nu2moding

    nu2moding Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    58
    Posts:
    190
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    190
    20
    58
    haha- metro guy around here told me that my knowledge exceeds his with regards to android-
    i got goLauncher home n the goto lock screen(kinda like evo's lock screen-pretty cool!!) a matrix live wallpaper
    n all metro apps gone except browser, file explorer n app store n when he saw that, he was like WHOA! that's cool!! then basically did a wipe:rolleyes: n nothing else.
    *288 didnt help, although i DID get the, i guess dealer programming menu n programed the fon which didnt do anything, either:mad:
    *UPDATE*
    got my svc back BUT still no msg/data on the stock rom- deleted sim toolkit which somehow popped up on my fon...
     
  7. starxpilot

    starxpilot Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    536
    Joined:
    Jul 24, 2011

    Jul 24, 2011
    536
    61
    98
    Loss Prevention Agent
    Garland
    WOW. That's really something. They even admit that we know more about the Android than they do.

    *Cough* Maybe its time they changed their "Authorized Dealer Reps" with instead of stereotypical high school/college kids with people like us from Android forums...who actually KNOW things about the phones! Only one *no racism intended* Chink in my area knew enough to encourage me to Root and Boot. But what about those classy ones? They don't even know what Froyo stands for!
    -End rant-

    Sounds like you really did a number on the phone, I really don't see a way out of this one besides starting from pure scratch with a new one. Sorry, this exceeds my brains. [​IMG]
     
  8. aolisshite

    aolisshite Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 16, 2011

    Sep 16, 2011
    1
    0
    5
    I did pretty much the same thing just with dif roms. I got mine fixed by:

    1. Use CWM Recovery 3.0.0.5 to make a back up of my girls m835 and transferred the file to my phone CWM backup folder.

    2. Boot into CWM and restored her rom on my phone. (Which was funny cause the txt between us are all labeled as from "me" to "me".)

    3. Then I downloaded and installed ultrajack 6.2.2 replacing CWM on my phone.

    4. Put MetrOff Froyo 1.2 on my phone and installed it with ultrajack by selecting "install zip from sdc" then selecting the Froyo zip.

    5. Rebooted and the network connection worked again. I also reinstalled CWM just cause I like it.

    Hope this works for you as it did me.
     
Tags:

Share This Page

Loading...