1. Are you ready for the Galaxy S20? Here is everything we know so far!

App for Enterprise 802.1x WiFi Connectivity

Discussion in 'Android Lounge' started by caintgetrite, Dec 10, 2009.

  1. caintgetrite

    caintgetrite Newbie
    Thread Starter

    If someone could develop an app that could resolve this problem, it would be like Christmas morning for me.

    After much Google searching on this issue, it appears that Enterprise 802.1x connectivity is not fully supported on the Android platform yet.

    Getting Wi Fi at college - Android Community Forums
    HowardForums: Your Mobile Phone Community & Resource - LG Eve, WPA-Enterprise / 802.1x?
    Issue 1386 - android - Feature req: support WPA2-Enterprise with EAP extensions - Project Hosting on Google Code

    So, if an app could be developed that would allow Android users to login in to Enterprise 802.1x WiFi networks (complete with username and password input) I'm sure I am not the only one who would be very happy. Right now I can see the secure WiFi SSID at my workplace, but cannot connect, because the Droid only sees the WiFi as WEP, and only prompts for a WEP hex key, which does NOT work.

    Pretty bad when coworkers with iPhones and Blackberrys can log on just fine, but I can't. Suddenly my shiny new Droid appears like it should be the one banished to the island of misfit toys :(

    1. Download the Forums for Android™ app!


  2. dima1109

    dima1109 Newbie

    I can connect to a WPA-Enterprise network just fine on the Droid with my AD credentials.
  3. caintgetrite

    caintgetrite Newbie
    Thread Starter

    Interesting. So when the secured network pops up in your available WiFi networks, what is the sub title description of the network? Does it say "Secured with WEP" under the SSID? And does it prompt you for a username and a password, or just a hex code password? Because that is my current experience, and those of many others quoted in the links that I had posted. I am curious to know what the difference is.
  4. dima1109

    dima1109 Newbie

    To be honest, I do not exactly remember what the setup screen was like. I know on the network I use, there is a root certificate that needed to be installed on Windows, Mac, iPhone, etc. However, I was able to connect without using a certificate on Android (I wasn't able to install the certificate manually, and the IT department doesn't support Android). When I clicked on the network, I simply selected "802.1x Enterprise" in the Security field, left all other fields blank (Certificate, etc), then entered my Active Directory ID and password in the Identity and Wireless Password fields, and it worked well ever since. I suppose you can see the fields that I saw by clicking on Add WiFi Network on the bottom of the wireless network list in WiFi Settings and selecting 802.1x Enterprise in the Security field.

    I am currently connected to the network, and here is what I get in the pop-up window when I click on the network name in list in the WiFi Settings menu:

    Status: Connected
    Speed: 54 Mbps
    Signal Strength: Fair
    Security: Enterprise (802.1x)
    IP Address: **.**.**.*** (can't post the IP address here for obvious reasons :) )
  5. caintgetrite

    caintgetrite Newbie
    Thread Starter


    Well I tried doing what you posted (manually setting up WiFi using "Add WiFi Network") and it didn't work. More to the point, it didn't see any network being available. I could not "forget" the network that appeared automatically under "available" networks, and I couldn't get anything beyond "mycompanyname-secured-network" and underneath it saying "Secured with WEP" when everyone in our office knows it's not using plain old WEP as security.

    I'm extremely glad that yours happened to work out that way, but by scouring the web, there are many many threads from people experiencing exactly what I am experiencing, with no resolution in sight besides having to root their phone and hack around to get it to work.

    So if anyone does hear of an app that can actually resolve this issue, I would be very glad to hear about it. This Enterprise WiFi thing is driving me nuts.
  6. mixwell

    mixwell Member

    anyone ever solve this issue?
  7. mixwell

    mixwell Member

    so, I don't know what happened, but when I came into work today, my WIFI connected. Very strange. but apparently Android 2.1 now has 802.1x enterprise access. I'm so confused!!!!
  8. OddRain42

    OddRain42 Lurker

    Hello all,

    I have released an application on the Android Market (WiFi Config Editor) that allows you to edit the WiFi settings as are stored in the internal WPA_Supplicant WITHOUT the need to Root the device.

    A number of people have found this to solve their WiFi networking issues.

    Let me know if you have any issues with it.

    caintgetrite likes this.
  9. caintgetrite

    caintgetrite Newbie
    Thread Starter


    First of all, thank you for your time and effort to try to help users solve this problem. I am sure that it is greatly appreciated by many.

    Unfortunately, it's the same old thing for me. I bought the Pro version of the app to get to the Enterprise settings and set everything exactly to specifications from our I.T. department. Having done so, I now get two SSID's showing up in my Droid Wi-Fi networks. The one that I had adjusted in WiFi Config Editor Pro displays in the Wi-Fi networks area as "Not in range" with all of the proper security settings. The Droid automatically keeps trying to connect to the same secured network as "Secured with WEP" even though the secured network is not using WEP. (see captured Droid image to illustrate)


    So I'm at a loss. After a half-hour of trying to figure it out, the I.T. guys once again told me the same thing that they said to me when I first was trying to figure this out.

    "Get an iPhone. It just works."

    Wish I knew why (after update 2.1 and now 2.2) the Android OS can't. Again, not the end of the world, but it is pretty frustrating.
  10. caintgetrite

    caintgetrite Newbie
    Thread Starter

    You've got mail! (Actually Private Message) with the file you requested. Thanks for being willing to help! Look forward to whatever you find out.
  11. OddRain42

    OddRain42 Lurker

    Seeing two access points in the list is not uncommon, in fact it happens for myself on my work network. Can you email me an example .mobileconfig file your IT department uses to get an iPhone on the network? From that I should be able to tell you what you need to set the settings at to get your android phone on your network.

    I'll do what I can to help get the issue solved for you.
  12. incrediblefun

    incrediblefun Lurker


    I am having the exact same issue as caintgetrite (post #9). I also purchased the pro version to get the enterprise settings. Although I am mostly happy with my phone, there a few things that do not work and make me crazy. Not being able to connect to the 802.1x wifi at work (I work at a university) is one of them.

    I would be happy to send you a copy of our .mobileconfig file if that would help. In fact, I would be more than happy to do anything to help troubleshoot and solve this problem. Would make a lot of Android toting students happy as well.

    Thanks for your attention to this matter.
  13. incrediblefun

    incrediblefun Lurker

    Someone figured out how to make it work on our network. Pro version was not necessary. Basically set up a new wifi network, enter ssid, choose 802.1x enterprise security and then enter credentials (identity and password). Go into wifi config, and uncheck wpa_eap in the Key Management section. Back out and go back to wireless, it should just connect. This did the trick for us.

    Hope this helps others.
  14. incrediblefun

    incrediblefun Lurker

    Special Thanks to Oddrain for his wifi config app.
  15. caintgetrite

    caintgetrite Newbie
    Thread Starter

    incrediblefun: I tried your suggested method. It didn't work for me. I'm glad it worked for you.

    It's been a little over a week now and I haven't heard anything from OddRain about my .mobileconfig file that I made available to him.
  16. Aozame

    Aozame Lurker

    At first try this didn't work for me - but I went back into the wifi config application and unchecked wpa_eap credentials again and everything worked perfectly. Finally!
  17. caintgetrite

    caintgetrite Newbie
    Thread Starter

    I'm wondering if I try to replicate incrediblefun's and Aozame's Configuration settings in the application if I might have better success? Can you guys see a red flag here, or can you report different settings than I have that I can try?

    In my config, in addition to the SSID for our office, I have the following:

    Hidden SSID (checked)

    Key Management: IEEE8021X Checked, all others off

    Authorization Protocols: All three unchecked

    Group Ciphers: All four checked

    Pairwise Ciphers: "None" is unchecked; TKIP and CCMP: both checked

    Security Protocols: WPA and RSN both checked

    Enterprise Configuration:
    EAP = PEAP
    Phase2= auth=PAP
    Identity = (my full email address)
    Anonymous Identity = blank
    Password = (my office password)
    Client Certificate = blank
    CA Certificate = blank
    Private Key = blank

    WPA PreShared Key = blank
    WEP Keys = blank

    What do you guys have? The same? I'd really like to try and figure this out. Thanks in advance.
  18. Jason6787

    Jason6787 Lurker

    Any luck with this yet? I too am on a WEP 802.1x wireless network and would like to get my Droid X to connect - tried the stuff above, to no avail.
  19. caintgetrite

    caintgetrite Newbie
    Thread Starter

    Sorry to say, no. I have yet to hear back from the developer (OddRain) or from Aozame or incrediblefun in response to my question about settings used in my previous post. Still just twisting in the wind right now :(
  20. Jason6787

    Jason6787 Lurker

    Here's something I noticed going thru the Security logs on the RADIUS servers - it looks like the account name being passed from the Android device is coming in with quotes, and throwing it off, generating a user not found error...

    i.e. instead of passing username, it passes "username", and Windows RADIUS tries to resolve the username then as DOMAIN\"username" and fails...
  21. Jason6787

    Jason6787 Lurker

    Got it!

    I downloaded WiFi Advanced Configuration Editor by Marcus905, and modified the settings with that tool (username/password set), and then backed out completely, and went to my Wireless network settings and disabled/enabled the radio, and poof! I got connected. Woo hoo

    Droid X running 2.2
  22. nat4android

    nat4android Lurker


    I got it work on my new Android 2.1 phone. yes, I was able to connect to 802.1x wifi.

    Fix #

    1) Download Wifi Advanced Configurtion App and its free.

    2) Add a new wifi-network as per your employer instructions. Now, you will see two "XXX" SSID one showing as "secure with WEP" and other as "not in range"

    3) Open the App and uncheck the WPA_EAP setting in Key Management for the wi-fi network you created.

    4) Your wireless should have already connected now.

    I hope this solves all your issues.
    Arcturus Zer0 likes this.
  23. ankurchandra

    ankurchandra Lurker

    Hello Incrediblefun,
    Thank you so much for this valuable piece of advice. What you suggested worked like a charm for me. Was struggling with getting wi-fi for quite a few hours and finally downloaded Advanced Wi-fi Configuration tool but it was still not working. As soon as I implemented what you said (i.e. uncheck wpa_eap in the key management section), it just worked immediately.
    Thank you so much.
  24. ghinson

    ghinson Lurker

    The information on Post#23 worked for me also, running Droidx on 2.2. I needed 802.1x Enterprise option, but after the 2.2 upgrade the options changed to 802.1x EAP. Anyways I selected the 802.1x EAP and configured everything else with respect to corporate configuration, then used the wifi app mentioned previously to edit the Key management and it worked. Thank you, nat4android
Similar Threads - App Enterprise 802
  1. Brïïzy
  2. Robert Richards01
  3. frozen_sun
  4. 374378234
  5. Constelie
  6. Soilcsi
  7. ZepTepi
  8. MyPoorAndy
  9. OmTec Web
  10. OmTec Web

Share This Page