1. Download our Official Android App: Forums for Android!

Support "App not installed" and SD Card issue...

Discussion in 'Android Devices' started by VibesGrt, Jan 15, 2014.

  1. VibesGrt

    VibesGrt Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Jan 14, 2014

    Jan 14, 2014
    4
    0
    25
    Male
    India
    Hello,

    I am new to the android system (and to this forum as well).

    I actually have a complex problem.

    First the background....I bought my Samsung Galaxy S Duos in May'13, and the dealer gave me apk files og some common apps like facebook, temple run etc. in my sd card (SD card actually belonged to my dad's phone (Nokia 6300 Classic), which he bought around 3-4 yrs back).

    All those apps installed properly at that time.

    Now, the problem starts....
    (Actually it aint the actual problem, but i guess it may connect)
    In November, my phone's battery started dying at a very fast rate.... As in, i would charge it completely at night, it would only be around 15% in the morning. So, I took it to the service centre, and they tested it and ultimately, changed the motherboard. Now, the battery problem was solved.


    After some time, i tried to install Temple run (which the dealer had given me), it didn't install..It would say "Application not installed"..I tried it with other apps, same problem. However, it installed perfectly before the motherboard changed.
    I ignored it at that point, and instead downloaded it from PlayStore.
    (I have "Unknown Sources" checked in the security settings)

    Now, few days back I tried to install another app from those dealer gave me....
    The same problem persisted. Tried to google it,
    They had following suggestions (None of them worked)
    1: Unknown Sources: Told you, i have it checked.
    2: Memory insufficient: Of 1-1.5 Gb internal memory, hardly 400 mb was occupied...
    (However, i noticed, it installed apps from PlayStore nd Samsung Apps.)

    Then, few days back, I downloaded "TrackRacing Online" from Samsung Apps, using Kies, over USB. So, it downloaded the apk file on my phone (internal memory). I moved to my SD Card... (There was no particular reason to it...i just did) And when I tried to install it, it said "Installing..." for around 2 minutes, and then said the usual "Application not installed". So, I restarted the phone and tried again....It gave a "Parse Error". And so did, the Temple run (which i downloaded from PlayStore...I had copied its apk file to my SD Card too)... However, the other apps given by the dealer were still showing "Application not installed".

    Then my phone (particularly the SD card) started behaving unusually. It would not display any images in the SD card. So, I decided to delete the apk file of the trackracing app. But when i went to MyFiles->extSDCard... The phone hanged... So, i again restarted the phone... Unmounted the sd card straight away.. Put it in my dad's phone (Nokia 6300 Classic) There, it was able to browse the memory card. I deleted the apk file... took out the memory card and put it the Galaxy duos, it showed the same apk file, although, its size as 0 bytes. So, I again transferred the sd card to my dad's phone, and connected it to pc via usb. I tried to format it, but it said format failed. Then, it hanged on my pc as well, so i unplugged the usb, and reconnected...thinking instead of formatting i'll just deleted the data. Now much to my surprise, It showed, data usage 0 bytes, used 0 bytes and free 0bytes. On googling it, there were mostly those who have partitioned it. And i dont really remember having it partitioned. So, highly frustrated by now, i just put thought to put the sd card back on the duos, and let it stay there.... But I had yet another surprise waiting for me.....The phone would mount the sd card, saying "Blank SD Card"....


    Now, that you've read my problem,
    I would first like to have a solution for the sd card.....
    And then for the "Application not installed" one......

    **Please note, my phone's unrooted and i dont really want to root it...so plz suggest other than that....
    **One more thing, please dont get too technical, I am just a newbie ;)


    Thank you... :) :)
     

    Advertisement

  2. Rukbat

    Rukbat Android Expert
    Rank:
    None
    Points:
    843
    Posts:
    10,392
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    10,392
    2,894
    843
    Male
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    Boot to recovery (volume+/Home/Power). Format the external SD card. See if that fixes it. If not there's something wrong with the phone, but it's not possible to diagnose it online, you'll have to bring it to a repair shop.
     
  3. VibesGrt

    VibesGrt Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Jan 14, 2014

    Jan 14, 2014
    4
    0
    25
    Male
    India
    Hey Rukbat,
    How do i format the ext SD Card in recovery mode??? couldn't find such option....

    However, there was one "Reset data/factory reset"....
    But I think it will delete data from internal memory....


    one more thing, I tried formatting it the normal way (using option directly, in settings)...couldnt...
    Since, you suggested problem may be with the phone, i put in the Nokia 6300...
    I tried using USB, failed....
    I manually deleted all the files(couldnt delete 1 file, namely DDISCOVERY.dsp (or something similar)..) (via USB).. nd when i put it in the phone(Nokia 6300) after deleting...all the data was there!!!!

    So, maybe the problem is with the phone, but i dont feel that sd card is perfectly fine either....
     

Share This Page

Loading...