1. Download our Official Android App: Forums for Android!

Support App turning on wifi automatically?

Discussion in 'Android Devices' started by Hoos, Jun 1, 2011.

  1. Hoos

    Hoos Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    87
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    87
    18
    18
    SF Bay Area
    I've searched for this problem, but haven't seen it anywhere (or maybe just bad at searching).

    My rooted EVO 4g (stock ROM) has begun automatically turning on wifi, even when there's a strong 3g signal. It never did this before - I needed to manually turn on wifi. And that's how I like it. I rooted several months ago with no problem, so don't think it's related to the rooting.

    Oddly, it only seems to only happen when I'm in a moving vehicle. It's almost as if the wifi network is pushing itself onto the EVO. I can be reading a forum page in the browser (completely loaded, no activity needed) and suddenly it will switch over to wifi from a solid 3g signal. It doesn't do this at home (where there is a wifi network).

    I've deleted all the remembered wifi networks (except my home network) and it still happens.

    It's only been happening the past couple of weeks. So, I've frozen (with Titanium Backup) all of the apps I've installed since then (some of them, I just deleted since they weren't being used). But the problem persists.

    Before doing a wipe/reinstall, I thought I'd check and see if anyone has any ideas on what might be causing this.

    Apps I've installed (and frozen or deleted) in the past couple of weeks:

    Doggcatcher (frozen)
    Adobe Reader and Adobe Flash Player (frozen)
    Tune-in Radio Pro (frozen)
    Several live wallpapers from the Market (deleted)
    Wave Launcher (deleted)
    Flex T9 keyboard (deleted)

    All of them (including the wallpapers) were via either the Android Market or Amazon's market and were all highly-rated with many (over 1,000) good reviews. So I don't think it's malware, but I'm not positive.

    Any thoughts/ideas on tracking this down further? Thanks.
     

    Advertisement

  2. sdrawkcab25

    sdrawkcab25 Android Expert
    Rank:
     #64
    Points:
    423
    Posts:
    5,589
    Joined:
    Aug 5, 2010

    Aug 5, 2010
    5,589
    2,005
    423
    Male
    PA
    Try "alogcat" to see if you can catch anything.
     
    Hoos likes this.
  3. Hoos

    Hoos Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    87
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    87
    18
    18
    SF Bay Area
    Thank you. Had forgotten about that app. Will get it installed and see what shows up. Probably won't have anything until tomorrow, though. If I could find the cause and kill it, that would be great. Better than a clean wipe/reinstall.
     
  4. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    please clarify "connect" vs. "turn on"

    ie do you typically turn off wifi or leave it running at all times and manually connect.

    if so go to menu.settings.wireless and networks.wifi settings and uncheck notify me.

    I personally use auto wifi enabler on my phone which is set to gps coordinates of wifi spots that I use...it automatically "turns on" wifi which is then set to auto "connect" to those spots.

    On my son's phone I use timerriffic AND auto wifi enabler...I have wifi turned off during the ours he is at school..then it "turns on" but doesn't "connect" until he is within the gps coordinates that are set in auto wifi enabler.

    it sounds like you may have flashed a new rom at some point and the "notify me" box is checked by default..if wifi is always on (alot of people leave it on) and that box is checked..you will get a notification any time the wifi radio picks up a wifi signal...
     
  5. Hoos

    Hoos Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    87
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    87
    18
    18
    SF Bay Area
    I leave it off and manually turn it on when I want to connect to wifi.

    Yes, I can turn off the notification. That's not the problem, though. It's automatically connecting to remembered wifi networks even though wifi is turned off and 3g signal is strong and working. I do not want it connecting or switching or anything, unless I manually initiate it.

    As for app suggestions, I appreciate it. But I really don't want to add more apps to a problem that has just begun. I want to track down and stop the phone from automatically turning on wifi.

    No, I did not flash a new ROM. Ever. I rooted and am running rooted stock and have been. The problem does not appear to be with rooting - I rooted months ago and the behavior is more recent than that. I do not leave wifi on, never have - unless I'm actively using it. It's not the notification, it is new behavior where the phone is turning on wifi without it being initiated by me.
     
  6. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    in that case it is extremely odd...

    just to clarify, when you use wifi you manually turn it on using the widget or through the menu, then connect to a remembered network?

    I don't believe I have ever seen this issue at all.

    run the logcat and see what you can find. in the end the reset may be your only option

    feel free to post the logs and I will take a look at them. screen shots would be very helpful as well...like a shot of when it has automatically turned on and whatever is checked in settings while it is on.
     
  7. Hoos

    Hoos Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    87
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    87
    18
    18
    SF Bay Area
    Thanks, Mr. Ed. I appreciate the offer to review the logs. I'll just have to wait for the next time it happens and try and note the time. Should be tomorrow on the bus to work.

    I've always used the Power Settings widget to turn off/on wifi. (The settings bar that lets you turn on/off wifi, bluetooth, syncing, GPS, and brightness.)

    Really, I've not added anything or changed anything beyond what I listed in the OP. It's a real mystery why wifi has just begun automatically turning on and off - a few times today it switched between 3g and wifi several times - either in the stock browser or using Tweetdeck. It just does it in the background.
     
  8. Mr. Ed

    Mr. Ed Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,675
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    6,675
    1,464
    313
    Phones
    Over Yonder
    it is indeed strange ... I know apps can have the permission to disable enable wifi (that is how enabler and timerriffic work) It may just be a matter of narrowing it down OR looking at each app in manage apps to verify what permissions each has
     
  9. Hoos

    Hoos Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    18
    Posts:
    87
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    87
    18
    18
    SF Bay Area
    Well, I owe a thanks to Mr. Ed. While I have not flashed any ROMS, I did download/install ROM Manager when I rooted - just in case. So, I've had that for several months and really didn't consider it as a problem, as I'd had none. But did recall that they went through a spate of updates a while back.

    So, this morning, I froze ROM Manager. The wifi problem did not happen on the way to work this morning: zero events of it turning on. Did the entire bus ride on 3g with no problems.

    This afternoon, for the trip home, I'll unfreeze it and see if the problem recurs. Though, for the life of me, I can't imagine why ROM Manager would need to enable wifi.

    So, at the moment, no log to post as no problems.
     
    Mr. Ed likes this.
Tags:

Share This Page

Loading...