1. Are you ready for the Galaxy S20? Here is everything we know so far!

Apps won't install

Discussion in 'Android Apps & Games' started by peterc9901, Feb 2, 2011.

  1. peterc9901

    peterc9901 Lurker
    Thread Starter

    Not sure if posting in right section but here goes...

    Hi guys, I've a lg gw620 on tmobile uk, everything was going fine until the other day when I went on the market to download a new app and after running the download to 100% and saying installing, i got a little warning triangle saying unable to install:thinking:? It's the same when i try updating other apps as well.

    There is plenty of available memory, and i've tried clearing out the market cache and gtalk, all to no avail:(.

    Anyone got any ideas? Its bugging the hell out of me....:mad:

    1. Download the Forums for Android™ app!


  2. landovr

    landovr Android Enthusiast

    I'm having the same problem. Up until about a week ago everything was working fine and now the apps download but as soon as its done it says installation unsuccessful with little orange triangle. actually tried restoring my phone to factory and started over again and still doesn't work. Its not all apps that are doing this, it seems like i'm only having this problem with new apps.
  3. SukDeezNutz

    SukDeezNutz Member

    When installing those apps unmount the SD card, install the app then mount the SD card. I have had that error too. They say there is a file in the android.secure folder on the SD that if deleted will prevent the error from happening, but i havent checked that out.
  4. landovr

    landovr Android Enthusiast

    I have tried unmounting the sd card and removing it and i still get the error.
  5. SukDeezNutz

    SukDeezNutz Member

  6. landovr

    landovr Android Enthusiast

    No, none of the tricks in that link helped either. All the original apps in the market that were there when i got my phone still download and install fine. it just seems to be the new apps that i am having the problem with.
  7. landovr

    landovr Android Enthusiast

    just tried wiping my phone again and formatting sd card. Still won't work.
  8. landovr

    landovr Android Enthusiast

    Emailed a couple of the developers for some apps that won't install and was told that it is an issue with the market.
  9. RyanB

    RyanB Guest

    1. Have you tried clearing the market DATA? If not, try the instructions in my sig

    2. Are you getting any kind of error code or message?
  10. landovr

    landovr Android Enthusiast

    the only message i get is installation unsuccessful, no error codes. like i said i emailed a couple developers and they said it was a problem with the market. i emailed the market in the help section and they told me to email the developers. just getting the run around. followed your instruction to clear data and i don't seem to have a clear data button, just clear cache. thank you for your interest and help.
  11. parth100

    parth100 Newbie

    You can also try...by changing the SD card...
    just try to install those apps in another Sd card...see if they are working or not...if they are then change your SD card... :D
  12. kenbanks

    kenbanks Lurker

    Just so you know, you're not alone.
    I am experiencing the same problem.
    I have no answers, but simple provide my experience below.
    Running CM6 EXTBLUE DEC-31 on HTC Hero CDMA (Sprint).
    I had not been having this problem, but other performance-related issues.
    So this past weekend I re-flashed this fantastic ROM (clearing both data and cache).
    Google automatically downloaded/re-installed all of my apps.
    Everything had been running perfectly and better than it ever has for nearly two days.
    So yesterday, I decided it would be a good time to do a Nandroid backup with ROM Manager, in order to preserve this wonderful state of my phone.
    After the reboot, most of my apps were no longer there, showing bogus icons for them on the ADWLauncher desktop.
    Sometimes it just takes a while for ADW to initialize itself for finding all the apps that are installed, but this was not the case. They were never going to show up.
    If I examined my sdcard, everything was there where it was supposed to be, it's just that ADW no longer thought the apps were installed.
    I tried "Fixing file permissions" with ROM Manager, rebooting, removing the battery, clearing data and cache for the Market App.
    But no matter what I try, when attmepting to re-install, any app will always downlaod completely and start "Installing...." and this never stops. No errors of any sort.
    I have about 8GB FREE on my sdcard.
    I've tried installing without it mounted.
    I looked in the output of 'adb logcat' but nothing there reveals any problem.

    That's all I have to offer.
    If it's really a problem with the Google Android Market, then wouldn't everyone be raising cane and wouldn't Google acknowledge that they are working on it by now?

    Ken Banks
  13. kenbanks

    kenbanks Lurker

    Let me add that the "Clear Data" button is always enabled for the Market app when I re-enter it's Application Info page and it's always "Computing" storage and cache info.
    I note this, because I suspect when I have pressed the "Clear Data" button that it not really doing anything. If I knew where this data actually resided, then I could confirm this from the 'adb shell'.
    Can anyone tel me exactly where the Application "data" is kept in the file tree?
  14. landovr

    landovr Android Enthusiast

    Ok i have an answer to my problem. The apps won't install because i am using Android OS 1.5 and these apps require 1.6 or later. This is what i was told by market support
  15. peterc9901

    peterc9901 Lurker
    Thread Starter

    Thanks for the help and answers guys, its just unfortunate that I'm running cupcake as well. I can only assume as has the poster above me that this is the issue. CURSE YOU LG!!!:mad:
  16. kenbanks

    kenbanks Lurker

    Ok,I am happy for you.
    However, that's not what is going on with my CM6 on my HTC Hero CDMA.
    I have been running CM6 since August 2010 and using all the same apps since then also.
    Just yesterday they have most all of them gone missing as if they were not installed and now I can't re-install them them.
    Clearing the dalvik cache and the cache partition doesn't help.
    I even used the ROM Manager to replace the Market app with the New Market app from Google: Vending-2.2.7-signed-testkeys.update.zip
    Now I'm running this latest greatest market and it can't progress passed clicking the "Accept Permissions" button when installing a new app. The button changes when I click it, so that it can't be clicked again, but nothing happens after that. The market just sits there and no download is started. Thsi is very frustrating!!!
  17. kenbanks

    kenbanks Lurker

    PROBLEM SOLVED (with NO HELP from Android or the Market app)
    I replaced my 16GB SD card with a spare 2GB sdcard and everything started working normally again. Apps would install again.

    I connected my 16GB card to my Windows system and ran chkdsk which reported two broken chains that it could not repair. I put the 16GB card back into my phone and let ROM Manger repartition and format. It's been running great ever since.

    You mean to tell me Android is incapable of detecting/notifying when the sdcard file system is corrupt?!? No indication whatsoever that this could have been the problem.
    Nothing in logcat.
    But that's not all.....
    Why or how could a corrupt file system on the sdcard effect the behavior of the Market, after I had enabled only installing apps for internal (not to use the sdcard)? But I also went so far as to operate without the sdcard mounted.
    Could the Market App not display a single message to help indicate why it was doing nothing, that maybe there might be a problem with the accessing certain files?!?

    With the sdcard unmounted I also attempted to perform an fsck, but it was not available in the ROM. This would seem to me to be a standard tool. Every Linux I've ever dealt with (and even god-forsaken Windows) performs file system integrity checks and reports when there is a problem. Am I missing something here?
  18. JesMan

    JesMan Lurker

  19. kiddk1

    kiddk1 Android Enthusiast

    deleting the 'smdl2tmp1.asec' file solved my issue thanks
  20. imeshd

    imeshd Lurker

    I have the same problem tried with removing SD card. Did not work.

    Where is this file located 'smdl2tmp1.asec ' ?

Share This Page