1. Are you ready for the Galaxy S20? Here is everything we know so far!

Article and Tutorial Enquiry - Making App with Android Studio and Typescript [WebRTC]

Discussion in 'Android Development' started by Ashbeck Henderson, Jun 3, 2020.

  1. Ashbeck Henderson

    Thread Starter

    Hello everyone,

    Hope you are well! I am making a chat-roulette app (or chatting app) in Android Studio and following the tutorial-link with the following link from WebRTC: https://webrtc.ventures/2018/01/web...t-roulette-clone-using-kotlin-and-typescript/

    I have carried out the typescript steps in the beginning, which worked successfully. But once I start using Android Studio, which is where I am having struggles, I see two ways of carrying out their tutorial:

    1) To import or insert their codes that they have written in the boxes supported byGitHub, where they start to become red-coloured in my Android Studio. So when I run the app, there are errors stating: "requiring top level declaration" or "expecting a qualified name".


    2) Downloading their source code. However, as the whole file is bigger than just the app, it does not allow me to run the app, where the "Run app" button is grey(transparent).

    Additional information: When I tried to follow your steps of creating .ts files, I put them all in the same path directory.

    Could anyone here help me figuring out what the problem are? I look forward to hearing from you. Thanks for having read through my e-mail, and if there are any questions do not hesitate to contact me.

    Yours sincerely,

    Ashbeck Henderson

    1. Download the Forums for Android™ app!


  2. Ashbeck Henderson

    Thread Starter

    Please see attached pictures for references to my own thread:

    - Pic 1 - Errors Shown in Red Colour When Following Steps (approach 1)
    - Pic 2 - Errors Shown in Source Code (approach 2)
    - Pic 3 - Additional Information on My Project Path Directory (additional pic)

    Attached Files:


Share This Page