1. Are you ready for the Galaxy S20? Here is everything we know so far!

(Ask) Rooting Problem After Firmware Update

Discussion in 'Android Devices' started by Brigantine, May 28, 2011.

  1. Brigantine

    Brigantine Lurker
    Thread Starter

    Hi all,

    I used Z4 root (1.1.0) to root my Samsung Galaxy I9000, and proceed to use OCLF from RyanZa. this worked fine and I got the Superuser icon.

    Yesterday, having heard rumor that KIES already release 2.3, I undo the lag fix and without removing the EXT2 tools, I tried to get a firmware update through KIES. It did update my phone but the version is still 2.2

    this is what it looks like after the firmware update

    Model Number
    GT-I9000

    Firmware Version
    2.2

    Baseband version
    I9000DXJPB

    Kernel Version
    2.6.32.9
    root@SE-S604#1

    Build Number
    Froyo.DXJPE

    PDA I9000DXJPE

    CSC I9000OLBJPA

    PHONE I9000DXJPB

    Build Info: 2010. 12

    I then tried to root it again, because I can't stand the lag. I've tried these methods:

    Z4 Root ([APP] z4root - xda-developers) doesn't work

    One Click Root (How to root unroot Samsung Galaxy S i9000 easiest way one click Tool) doesn't work as well

    Copy an update zip (Detailed guide on rooting the Galaxy S - Samsung Galaxy S Forums - Galaxy S II Forum) doesn't work as well.

    For method 2 and 3, I got a message that verification failed.

    Any advice on this will be much appreciated!
     


  2. snapper.fishes

    snapper.fishes Android Expert

    Super One Click should do the job. However, it's quite strange that your phone was updated to 2.2 instead of 2.2.1. Which country do you live in?
     
    Brigantine likes this.
  3. Brigantine

    Brigantine Lurker
    Thread Starter

    Did the root with Super One click, it works fine and I flashed the phone with Darkys 10.1. Thank you for the pointer!

    I live in Singapore, on hindsight I think that they have not even released the 2.2.1 here yet
     

Samsung Galaxy S Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...