1. Download our Official Android App: Forums for Android!

ASUS File manager and SD Card permissions

Discussion in 'Android Lounge' started by AZgl1500, Aug 19, 2017.

  1. AZgl1500

    AZgl1500 Android Expert
    Thread Starter
    Rank:
     #43
    Points:
    618
    Posts:
    6,400
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,400
    3,144
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    I have a S5 Galaxy that has always worked fine, and still does on most things.

    Recently though, the SD card died and I got a new one. The camera finds it, and saves images to DCIM as it should.

    But, with ASUS File Manager, it keeps asking for permission to use the card. When I follow the steps provided in the popup help screen, it shows using the 3 dot menu and 'show ID' card

    but on the S5, it shows "Get SD Card permission steps" and that just brings up the help screens.

    What has been done:

    1) initially formatted and copied the old camera files from a Linux Laptop to the new SD card. S5's camera works okay with it.

    2) Okay, maybe the ASUS FM needs to be updated? after deleting ASUS FM, installed the latest version, powered off/on several times as per the help screens. Still no change.

    3) okay, bit the dirt, and decided to format the SD Card with the S5.
    copied all the images/folders to the SD Card again from the laptop. and again the Camera works just fine. But, ASUS FM is still bitching about needing to get permissions.


    I am a bit irked about this. S5 has Android 6x on it, the latest OTA software updates from Verizon.

    I did a Bug Report to the ASUS forum right from the ASUS FM report link, still waiting to hear back on that. It was to an email address...


    I love ASUS FM because it is sooo easy to use, click on Images, then select the source "Screenshots", Camera, Facebook, Textra, etc.... and you can get to the exact image you want so much faster and easier than other File Managers.... I find ES Explorer a bit convoluted, and not easy to use.

    ASUS copies via WiFi to another device, other FMs can't do that.
    so, after a long diatribe here, anyone made it this far, and have any ideas on what can be done?


    now, there is on thing more that I am considering, is it because when I copied the file folders back to the SD Card, that ASUS FM did not "create the folders" on the new card??

    if I have to, I will format the card again, then use ASUS to create the new folders ( if it will, per the permissions problem ) and then copy the images back to the card again.

    sigh,
    this is getting a bit perplexing.


    hope I can fix this, my phone is a Note 4 and ASUS is very happy on it.
    the S5 is my daughter's phone.
     

    Advertisement

  2. Xavier Black

    Xavier Black Android Enthusiast
    Rank:
     #134
    Points:
    113
    Posts:
    539
    Joined:
    Sep 21, 2015

    Sep 21, 2015
    539
    182
    113
    Male
    The issue could the actual external sd card it self..I'm speaking 'cause I had the same predicament..for some reason my phone doesn't like any other brand but just Samsung..when I putted in a Sanddisk it gave me all kind of fuzz..

    Let me know.
     
  3. AZgl1500

    AZgl1500 Android Expert
    Thread Starter
    Rank:
     #43
    Points:
    618
    Posts:
    6,400
    Joined:
    Feb 3, 2011

    Feb 3, 2011
    6,400
    3,144
    618
    Male
    Retired and loving it.
    Oklahoma grasslands
    I am now convinced the issue is the fact that starting with Android 5.x, Google changed the rules in that only an App that creates a folder is allowed to use that folder with "full permissions".



    my daughter is able to "read" from any of the folders, but can't paste into them, or delete from any of them.



    But, when she created a dupe folder "Folder2" she is now able to write, read, delete any file from that folder.



    The SD card is a high quality brand, forget what, because at Best Buy, they did not have a good Samsung for me to buy "at the time"... I just took the 'PNB' brand.... just remembered the brand....



    in the past, it has served me well with other phones... if she has any further trouble with it, I will make a point of getting her a Samsung card.



    Thank you for your reply and time.



    John
     

Share This Page

Loading...