Asus TF101 Battery won't charge


Android Question

My Asus TF101 with dock accidentally allowed battery to drain completely. Now neither one will take a charge. I have checked the cable.. OK. Charger, not sure if it's giving 15V or not, but have ordered a new one. I was able, somehow, to get 15% into the battery (not sure how), but when I turn it on with the charger connected, it says to connect the charger and that the battery isn't charging. Now it's at 12%.
Will replacing the battery solve this problem (this tablet is about 2 years old) or would I be wasting my money? I have tried other solutions offered, such as freezing the charger, using different chargers, connecting to USB for 12 hours, connect to charger for 10 minutes then off for 1 minute, etc. Nothing has worked. Should I replace this battery or shelf the tablet? Thanks.

El Presidente

Beware The Milky Pirate!
It's never a good idea to let Lithium based batteries drain completely, especially if they are pretty old.

It's up to you, batteries look to be relatively cheap, so if you fancy DIY'ing it, at this moment in time, you've got nothing to lose.


I tried one last move: I connected the tablet to the 3.0 USB of my computer and left it connected overnight. This morning the battery had 37% charge and then continued up to about 50%. I bought a new Asus charger and connected that to the keyboard dock, and it began to charge also. Now, with them docked together, my green light is on and I'm back in business. That was the only thing that seemed to work and I'm thankful for others who suggested that on other posts.