1. Are you ready for the Galaxy S20? Here is everything we know so far!

Asus Transformer won't charge.

Discussion in 'Android Devices' started by Sgtcrispy, May 24, 2011.

  1. Sgtcrispy

    Sgtcrispy Lurker
    Thread Starter

    I recently got an Asus Transformer pad from Best Buy and it doesn't seem to charge. I've tried plugging it in through USB and to different outlets but it doesn't seen to work.

    1. Download the Forums for Android™ app!


  2. whitesnake1

    whitesnake1 Member

    Try to plug the a usb cable and device into the charger and see if it charges it
  3. Sgtcrispy

    Sgtcrispy Lurker
    Thread Starter

    That's what I've been trying. I tried to plug the USB to connect my computer and the device, doesn't work. My computer recognizes the USB but it doesn't charge. I've tried to plug the USB into the plug that it came with and putting it in three different outlets that have worked with other devices and still not working.
  4. rogone

    rogone Member

    I don't know about why your TF won't charge through a regular outlet but when you want to charge using the usb connected to a compter the TF owners manual says the TF has to be turned off (not just a sleep). Have you tried charging through the usb with the TF completly turned off?
  5. whitesnake1

    whitesnake1 Member

    Try using the charger on another device to see if it charges it.

    My boss has an Apple Ipad2 and using his computer says it's not charging, but it is, (trickle charge). So this might be the same issue as far as the computer is concerned..

    Just confirm the charger that came with the unit is working... then you can say to ASUS i have a bad unit or just a charger issue

  6. Sgtcrispy

    Sgtcrispy Lurker
    Thread Starter

    I don't know how I could do that. I don't have another device that the cable would fit into.
  7. Sgtcrispy

    Sgtcrispy Lurker
    Thread Starter

    Okay, I just asked my friend who had the same problem and it turns out I'm just stupid and didn't press the adapter into place hard enough. It's charging now. Thanks for the help anyway guys.
  8. dbpaddler

    dbpaddler Android Expert

    as mentioned in Asus' FAQ, the TF101 can obtain power from USB when connecting to PC, but electric current is not sufficient to charge the battery. Use the power adapter which is provided by us is the only recommendation.

    or the post above... :)
  9. Podivin

    Podivin Android Expert

    MacFett likes this.
  10. Sandroidfan

    Sandroidfan Android Expert

    Looks like some of them are suggesting cold reboot as solution. I'm not having charging problem but sporadic deep sleep problem that it doesn't wake up easily with lock button. Would cold reboot (hard reset) would solve this problem too?
  11. turbohobbit

    turbohobbit Android Enthusiast

    I'm having this problem, the unit not charging via the wall charger. I'll leave it plugged in tonight as I left the unit to run right down so the battery is completely jiggered. If it's still not charged in the morning I'll know the adaptor is on the fritz.
  12. Gardenwife

    Gardenwife Newbie

    So, was it your adapter?

    I just got my Transformer a couple of days ago and am happy with it. The quirks of USB charging being insufficient are something I can deal with since the keyboard dock makes the battery life so long. I'm a little bummed it doesn't charge while powered on - that's my only beef.

    I'm watching this thread, though, in case I see problems with the adapter charging it.

  13. AutobahnSHO

    AutobahnSHO Android Enthusiast

    If you're using the wallcharger and cord it should charge just fine when the tablet is turned on- it just takes a little while longer to charge fully, and even longer if you leave the screen on..
  14. Gardenwife

    Gardenwife Newbie

    Oh, cool - that's great to know. I'm blown away by the awesome battery life with the dock.
  15. AutobahnSHO

    AutobahnSHO Android Enthusiast

    Me too. :D The biggest reason I picked the Transformer and bought it over anything else out there- even my netbook didn't compare.
  16. triplec3

    triplec3 Lurker

    My Transformer is terrible at charging too...

    Right now it's dead and I can't get it to charge through either USB or AC power. Ever since I bought it I've had trouble charging it. Why doesn't it just charge no matter what power source it's plugged into? Why doesn't it charge no matter what power state it's sitting at? It should JUST CHARGE!

    Sorry....it's just so frustrating since I love this device so much while it's working.

    Is there any solution for this? New firmware, OS updates or something?

    Thanks for listening...
  17. AutobahnSHO

    AutobahnSHO Android Enthusiast

    Call ASUS, probably a bad charger or powercord.
    If that doesn't help the tablet might have a loose connection inside somewhere.. :(
  18. sayid

    sayid Lurker

    From the `user manual` included with the dock: "remember to fully charge the battery (8 hours or more) before first use and whenever it is depleted to prolong battery life. The battery reaches its maximum capacity after a few full charging and discharging cycles." -- both for pad and dock, sounds like you should ` train` the battery.
  19. pwndecaf

    pwndecaf Newbie

    I had the same issue with my first TF. I knew it wasn't charging because the wall wart wasn't warm. They took it back and shipped in a new one as it had happened within 2 or 3 weeks of purchase and I have not had a problem since - first bought on July 5, 2011.
  20. Crash27

    Crash27 Android Enthusiast

    I had the same thing happen lastnight, It took me an hour to get it to charge again, I had my TF plugged in for hours and when I booted it up the battery warning popped up, I had no idea what was going on for it was plugged in for hours and should be fully charged, So I tried plugging it in to charge it again and nothing happened, so I fooled around with the cable and charging block and still nothing, I then tried the PC and it connected fine, So I assumed the charging block was no good, I found the articles suggesting the prongs not connecting properly so I tried that and nothing, at this point I was starting to freak out. I then tried the freezer method and still nothing. I cleaned all the connectors with a q-tip to rule that out. I then thought to myself I am always plugging my TF to the front USB Ports, So I tried the rear ones and it connected and then I unplugged it and tried the Charger again and it worked!! I have no idea what happened or if it was just a glitch, for that night I had it plugged in to my front ports to transfer movies, I am wondering if that screwed up the charging sequence somehow?
  21. Eris1981

    Eris1981 Android Enthusiast

    Mine does it once in awhile lately, and mine seems to be the wall charger glitching out.
  22. viffer800

    viffer800 Well-Known Member

    I've experienced that problem and wiggling the cables seems to have worked in the past. Just checked the pins and one of them was a good 1-2mm 'lower' than the other. A bit of careful prising and reconnected the parts of the mains charger. Will see how it performs next time I need to charge it.

    Thanks for the tip

    Update:- Just attached my TF to the mains charger and it connected immediately so I guess this was the solution to my problem.
  23. PerOhlsson

    PerOhlsson Lurker

    Anyone successful with third party charger like Belkin or Apple (iPhone)? Tried Asus Cable with some different wall charger or 12 volt car charger but no luck. Are there any third party charger or do Asus sell extra?
  24. AutobahnSHO

    AutobahnSHO Android Enthusiast

    The ASUS charges from USB 3.0. Most wall adapters are just USB 2.

    Yes, you can buy spares- they're about $30 from amazon and other online websites, comes with the cable and wallcharger.
  25. flexy

    flexy Lurker

    the asus transformer works using usb 3 which is slightly different as i have found out when making a charger for the car as there is nothing on the market so a standard usb charger will not work............................. i would like to add that i brought a usb 3 lead of ebay plug it in to the charger then the unit all worked. as normal then split the cable tested the wires found the 15v wires, got an old phone car charger riped out the existing bits and soldered the wires to the supply terminals and it works a treat charges orange then goes green when charged in the car good if you go far or just want a big sat nav great as i use it for work

ASUS Eee Pad Transformer Forum

The ASUS Eee Pad Transformer release date was April 2011. Features and Specs include a 10.1" inch screen, 5MP camera, 1GB RAM, and Nvidia Tegra 2 T20 processor.

April 2011
Release Date

Share This Page