1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root [AT&T] 4.1.2 update

Discussion in 'Android Devices' started by josborne6, Aug 3, 2013.

  1. josborne6

    josborne6 Well-Known Member
    Thread Starter

    My SGH-i747 isn't showing an update when I connect to Kies. Wasn't the update released yesterday for the ATT S3's? Is it because I'm rooted on stock rom? This didn't affect it for the first update to Jellybean.
     

    Advertisement

  2. lennydude

    lennydude Android Expert

    Hmmmmm Not sure. My i747 did not show an update until I chose to check for it. Then it downloaded and I ran it. My phone was not rooted but was both unlocked and I had LTE shut off due to battery drain. I lost both after the update :(
    It appears my LTE is fixed. I get good speed tests now in places I never could get LTE before?? Also, I really do not care about the carrier unlocking anyway.
    Hope you get a definite answer to your issue. I have heard of some updates breaking root. When I had a Droid X it would not update when you were rooted, not sure about the S3?
     
  3. GTWalling

    GTWalling Android Expert

    Installing a new update or rom will not re-lock the phone. Once a phone is Sim unlocked it is unlocked.
     
  4. lennydude

    lennydude Android Expert

    Your 100% correct GT. I checked my phone and the carrier lock was untouched........still at 0.

    The LTE works so well now that I find myself forgetting to turn on WiFi...lol
     
  5. josborne6

    josborne6 Well-Known Member
    Thread Starter

    So has anyone that is rooted getting the update ota?
     
  6. josborne6

    josborne6 Well-Known Member
    Thread Starter

    Or through Kies for that matter?
     
  7. pdl2mtl90

    pdl2mtl90 Member

    I have tried so many different ways without success. I am on rooted 4.1.1 and have tried ota, unroot and ota, flashing thru stock recovery, flashing thru TWRP. No luck yet.
     
  8. josborne6

    josborne6 Well-Known Member
    Thread Starter

    No luck here either.
     
  9. AKENATON

    AKENATON Member



    Hello everyone,

    I'm new to this forum; having jumped ship from a different carrier.

    I wanted to chime in w/ some info.


    Yesterday@noon my Rooted/Stock ROM and stock everything except for CWMod....... notified there was an update so I decided to risk it and accept this update without being sure if I was going to lose Root.

    I let the phone do its thing. At some point, CWMod tells me:

    Update may load stock recovery. Fix?

    no
    no
    no
    yes ... keep recovery
    no
    no
    --------------------------;;-------;;---

    So I decided to say yes, thinking I was keeping CWM and then it tells me:

    You may loose Root, Fix?

    So I said yes fix, and I still have root after update finished, but no CWM.

    I have tried to use same method and .IMG file provided on this: forum.xda-developers.com/showthread.php?t=2363882 ( to re-install CWM )

    I mean using terminal emulator like I did first time around. But even though the process seems to work just fine when I reboot into recovery I'm being presented w/ stock recovery instead of CWM.

    I suspect that version of CWM is not compatible w/ new Firmware

    》》》 I747UCDMG2 《《《

    I see the double window features and some other bloatware I don't like so the update did go through.

    Does anyone knows if there is a compatible CWM for this: 》》》 I747UCDMG2 《《《 that I can Safely install? Since reliability/stability is very important for me.

    Thanks in advance for your help.



    Cheers! :beer:
     
    josborne6 likes this.
  10. MercilessLTD

    MercilessLTD Member

    I used to use CWM back on my Nexus S. It worked well, and I never had any issues. But I was shown TWRP and tried it. The UI is simpler and easier to use, in my opinion, so I've been using it for several months now.

    I installed TWRP on my S3 when I decided to root it. It has yet to be incompatible with any firmware I've used, be it AT&T or a port from another carrier. Currently I'm running SlimBean Build 8 (which is Android 4.2.2), and both my bootloader and modem have been updated to the UCDMG2. It is running flawlessly.

    There are a few ways to get TWRP. If you already have root, I'm told the easiest way is to go to the play store and download GooManager. This will help install the latest TWRP.

    Personally, I used Odin to flash it. To do so, you run Odin (on Windows), then place your S3 in download mode, and hook up via USB to your PC. Odin should auto-detect it. Then click on the PDA button, and select the "Odin Flashable Tar" you downloaded. Then simply start it!

    You can find the official TWRP page for d2att here (at the bottom is where the Odin Flashable Tar link resides): TeamWin Projects - TWRP 2.6 - Samsung Galaxy S3 (AT&T) | TeamWin

    Odin: Odin307.zip | by mrRobinson for Galaxy S 3

    If you have any more questions, let me know.
     
    AKENATON likes this.
  11. AKENATON

    AKENATON Member


    Thank you for your help.

    Right after my last post I was a bit frustrated that because of my inexperience I had lost CWM so I went bact to Mr. Robinson's tutorial, re-downloaded CWM .img and through terminal emulator reinstalled it after 3 failed attempts. All of them by using:

    _________________________________________
    SU

    dd if=/sdcard/recoveryfilename.img of=/dev/block/mmcblk0p18
    _________________________________________

    After rebooting my phone would only go to stock recovery, but when it finally did install correctly I tried to do a back-up to ext-sdcard and this is what I got:


    [​IMG]

    So now, I don't know what's going on. Is it that I didn't choose the right settings or location ?


    Any ideas?
     
  12. MercilessLTD

    MercilessLTD Member

    That worked. The two error messages are simply stating that it does not see the .android_secure folder on your phone (meaning you probably haven't installed a lot of apps yet), and you don't appear to have an external micro SD card installed.
     
  13. AKENATON

    AKENATON Member







    Thanks for your help, please check your PM .


    Thank you in advance.



    Cheers ! :beer:
     
  14. GTWalling

    GTWalling Android Expert

    To get the update OTA you need Stock Recovery. CWM orTWRP will fail.
     
  15. josborne6

    josborne6 Well-Known Member
    Thread Starter

    Wouldn't it still show up through Kies though?
     
  16. GTWalling

    GTWalling Android Expert

    Yes if it has been posted, it would show up in Kies.
     
  17. josborne6

    josborne6 Well-Known Member
    Thread Starter

    OK gotcha. Thnx.
     
  18. red22

    red22 Lurker

    hello. I have S3 747ucdlk3 unlocked but not rooted. how did you manage to get the new update 4.1.2 . My s3 has ver. 4.1.1 and keep getting error : download interrupted.....
     
Loading...

Share This Page

Loading...