1. Check out our companion app, Forums for Android! Download from Google Play

Root [AT&T] No idea where to turn

Discussion in 'Android Devices' started by Savage Shadows, Feb 7, 2014.

  1. Savage Shadows

    Savage Shadows Well-Known Member
    Thread Starter

    Jun 22, 2012
    Phoenix, AZ
    So, I used to be an avid tinkerer, could get my way around most devices. That was about a year and a half ago. Then I got a Nexus 4, found Paranoid Android, and never had anything to worry about again. Recently, I switched to the HTC One. I got it used, clean numbers and all, nothing to worry about. What I didn't know until I picked it up, is that it was an unlocked AT&T model. It worked great, and then I started to change some things. I have no idea about the kernel, but it had TWRP installed, as well as CM 10.x (I just know that it was still on a Jelly Bean build). I went to flash CWM because that is what I'm used to and comfortable with, then proceeded to flash Paranoid Android 3.99 RC2. After that, it would no longer recognize my sim card, among other problems like not being able to communicate with the camera. I first noticed the sim problem when I went to input the proper APN settings for TMobile.

    Where I'm at now.
    I'm trying to reinstall TWRP because of course I made a backup before doing anything at all. However, I cannot get adb to push it. When the phone is fully booted up, through the command "adb devices" I get,
    Code (Text):
    1. C:\fastboot>adb devices
    2. List of devices attached
    3. HT3A9W904144    offline
    However, when I run "adb devices" while the phone is in fastboot, I get an empty list of devices. Also, when I run "fastboot flash recovery recovery.img", I get
    Code (Text):
    1. C:\fastboot>fastboot flash recovery recovery.img
    2. target reported max download size of 1526722560 bytes
    3. error: cannot load 'recovery.img': No error
    Now, I'm not really as versed in coding languages as I'd like to be, but that makes no sense to me at all since the recovery file is only just over 9MB and it said the max download size is near 1.5GB. Not to mention the "No error" error.

    If it helps anything, here is the information displayed in my bootloader/fastboot pages:
    Code (Text):
    1. *** TAMPERED ***
    2. *** UNLOCKED ***
    4. HBOOT-1.55.0000
    5. RADIO-4T.20.3218.13
    6. OpenDEP-v31.120.274.0617
    7. OS-3.17.502.3
    8. eMMC-boot 2048MB
    9. Oct  4 2013,00:49:44.0

    Now, I need to be able to install TWRP again so I can restore my device to working order. Is there anybody with advice?

    ps: I'm running windows 7 home premium 64bit. For anybody I deem trustworthy, you're welcome to help out through remote desktop by means of teamviewer if that helps. Just ask me first.


  2. clsA

    clsA Well-Known Member

    Apr 8, 2013
    FLA. USA
    what version of TWRP ?
    and did you try and clear the cache ?

    boot to bootloader (power + vol down)
    plug phone into PC
    you should be in fastboot USB
    from your fastboot/adb folder open command prompt and type fastboot devices
    if your s/n shows proceed to
    fastboot getvar all
    fastboot erase cache
    fastboot flash recovery openrecovery-twrp-
    fastboot erase cache
    fastboot reboot-bootloader

    paste the results in your reply

    you can download TWRP here Techerrata Downloads - Browsing m7
    scotty85 likes this.
  3. Savage Shadows

    Savage Shadows Well-Known Member
    Thread Starter

    Jun 22, 2012
    Phoenix, AZ
    Ugh. Complete (and very extended) derp moment on my part. Rebooted the laptop, and communication issues went away. Successfully restored, no issues I can find yet and it's been nearly twenty four hours.

    I can supply any information later (on my way to work right now), but any tips on how to prevent such issues when I try again? I usually take all the regular precautions by habit, so other than mistakes due to lack of experience with carrier unlocked devices, I'm not sure where I went wrong.
    scotty85 likes this.
  4. scotty85

    scotty85 Well-Known Member

    Jul 25, 2010
    wich issues? the comunications errors are part of using windows,wich require prollematic drivers and are sensitive to other programs that attempt to comunicate with the device,espeically with newer versions.

    usb hubs and usb 3.0 are also notoriously prollematic.

    best tip i can think of is dont use windows :p :eek: ;)

    other than that, small errors are just part of it. this is a general windows checklist i throw out whenever folks have connectivity issues(windows 8 and usb 3.0 specific fixes not included):

    troubleshooting connectivity issues:
    *make sure you have changed to your adb/fastboot directory!
    *make sure usb debugging is enabled(checkmarked) to use adb in the OS
    -try a reboot of the PC
    -try different usb cables and ports
    -dont use a usb hub
    -dont use usb 3.0
    -make sure nothing capable of comunicating with the phone is enabled and running. htc sync,pdanet,easy tether,and even itunes have all been known to cause issues.
    -windows 8 has been known to have issues. try a windows 7 or older machine

    failing the above,
    -i use these drivers for fastboot and adb(donwload and run as admin): http://downloads.unrevoked.com/HTCDriver3.0.0.007.exe (mirror)

    failing that,try manually updating the drivers in the following manner:
    -put the phone in fastboot mode(select fastboot from the hboot menu)
    -open device manager on the PC
    -plug in phone,watch for it to pop up in device manager.
    -update drivers with device manager,pointing the wizard to the extracted
    driver download folder from above

    note that you can check the connectivity of the phone,and make sure drivers are working by in the following manner:
    -open cmd window. change to directory containing adb/fastboot utilities

    -adb with the phone in the booted OS,usb debug enabled,enter:
    adb devices in a cmd window

    -fastboot with phone in fastboot(not hboot!),enter:
    fastboot devices in cmd window

    in either case,a properly connected phone with working drivers installed should report back the phones serial number.

    having said all that,i have had pretty good luck with windows 7 32 bit,but after having some issues with newer phone tools and firwewall/antivirus conflicts,i use ubuntu for any "delicate" phone work.

    if youre refering to the issues you had with your paranoid android install,thats a little tougher. biggest thing is to check the integrity of your downloads by comparing md5 sums,and make sure you do a "full wipe" whenever you install a new rom. even when the new rom uses a similar or same base, you never know what issues can arise from not doing a factory reset.
  5. dibblebill

    dibblebill Well-Known Member

    Feb 21, 2012
    Raleigh, NC
    If possible, get yourself a Ubuntu hard drive or partition and use that- much more reliable for ADB/fastboot than Windows.
    scotty85 likes this.

Share This Page