1. Are you ready for the Galaxy S20? Here is everything we know so far!

[AT&T] Please, Urgent Help - not responding after ROM

Discussion in 'Android Devices' started by patpending, Jan 13, 2013.

  1. patpending

    patpending Well-Known Member
    Thread Starter

    Hi all,

    I have a One XL, Telstra, AU. Stock until today.

    Today, I have followed cursed4eva's video instructions on unlocking bootloader / rooting. Brilliant! No problems at all.

    Went into fastboot, recovery.

    Backed up,
    Wiped data / factory reset
    Wiped cache partition
    Cleared delvik cache

    Opened ROM manager

    Chose to flash the Viper ROM.

    Screen went blank, ... and that's all she wrote.

    For the first 20 minutes, I figured it was doing something, only because the computer recognised the USB device when I plugged it in / unplugged it.

    But now, ..... nothing.

    I've tried long pressing power, I've tried plugging in, I've tried long pressing volume down + power, I can't even get into fast boot.

    Any help would be greatly appreciated.

    Thank you.

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    Did you flash the right version of Viper? There's 2 versions, one for the One XL and one for the international One X. Do you have a link to the one you flashed?
    patpending likes this.
  3. HecTiC One X

    HecTiC One X Member

    not being able to fastboot maybe an issue. Can you get into recovery?
  4. scotty85

    scotty85 Extreme Android User

    Seems to me your prollem is Rom manager. Even on phones where recovery can flash the boot image,Rom manager is,IMO,unreliable.

    At this point,likely all you need to do is mnually flash viper roms boot image. :)

    If you plug in,does adb devices get you a reply in cmd? If so,adb reboot bootloader should get you back to fastboot so you can flash the boot image.

    The above reply was asuming you're hung on a splash screen. I just read the comment on the blank screen... Can you confirm.. did the phone shut off? Or is it hung on a splash,or even just a blank black screen?
  5. patpending

    patpending Well-Known Member
    Thread Starter

    I flashed first the 2.6.0.X version from :


    Followed the link from the Viper ROM thread.

    Currently, the phone doesn't respond to anything

    Power button and power + volume down does nothing.

    Plugged into computer, is not recognised as anything

    Plugged into charger, no charge light.

    Plugged into computer, using the fast boot boatloader command, just hangs in CMD saying <waiting for device>.

    So Basically I have a $720 door chock :p lol

    To clarify, after I chose the ROM to flash thru ROM manager, the screen went blank and never came on again - no progress bars, no splash screens, no indicators, not even the backing lights.

    Thanks for the help guys.

    I've got my hands on a new one yesterday, but I'd like to have the other one usable to test ROMs on :D
  6. scotty85

    scotty85 Extreme Android User

    uuuh oh.

    from this comment,looks like you do have a pretty hardcore softbricked phone:
    the partitions are not quite the same,and your phone is currently in a do not boot mode. im surprised device manager does not show it as QHUSB_download

    its possible you can use linux to fix the partition the international one x rom damaged,if you have some experience with it. im off to work,if EP cant provide you some links,ill see what i can dig up for you later.

    sorry for not understanding the prollem more clearly when i first posted... i was on my tablet,and apparetly half asleep :eek:
    patpending likes this.
  7. patpending

    patpending Well-Known Member
    Thread Starter

    Haha,perfectly fine - I work 7 days a week, and after you reply words from previous posts seem to change or more seem to appear you're not looking!

    Not sounding too good at the moment, no access to Linux.....will be very interested to hear what you might be able to dig up :)
    scotty85 likes this.
  8. scotty85

    scotty85 Extreme Android User

    here you go:

    you can use an ubutu live cd if you want to give it a shot. its a lil advanced,but is doable,especially if you have any friends that are proficient in linux.

    its got some good links,and should explain why youre in the situation youre in,as well as how to restore from it. basically,the endeavor rom flashes a couple of important,unwrite protected evita memory blocks

    ive not done it,but i can try and help if you decide to attempt it. :)


    also,i believe,if you dont mind im going to move this thread to the evita forum. it may help some folks over there,as flashing endeavor roms seems to be a somewhat common occurance.
    patpending likes this.
  9. patpending

    patpending Well-Known Member
    Thread Starter

    No worries with the thread moving.

    Just read through that unbricking thread, and all I can say is .... Holy crap on a cracker! A little beyond my current means with system & software requirements, and quite a bit over my head.

    Thanks for the link to the thread - I hope others will get benefit from it!

    I might just have to try my luck at a warranty repair with the fault text, "Phone does not turn on. Phone does not charge."

    I'll report back when I have an update!

    Thanks again.
  10. mrgoodpaul

    mrgoodpaul Member

    OK so what I've found is that none of the ROMs work unless you flash their boot.img . Just boot it into fast boot and wipe everything then flash the boot.IMG then in recovery factory reset then flash the rom

HTC One X Forum

The HTC One X release date was May 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Nvidia Tegra 3 processor, and 1800mAh battery.

May 2012
Release Date

Share This Page