1. Download our Official Android App: Forums for Android!

Support At&T Sim Card in Verizon Galaxy S5

Discussion in 'Android Help' started by areyno8, Jun 19, 2016.

  1. areyno8

    areyno8 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Jun 19, 2016

    Jun 19, 2016
    3
    1
    16
    Male
    Hi,

    A bought a used Samsung Galaxy S5 (Verizon) from a friend of mine to upgrade my older S4. His 2 year contract was up and he upgraded to the Galaxy S7 Edge. I did some research and I thought I could stick my AT&T sim card in the S5 and go about my business. I changed my network mode to GLOBAL and turned on my Global Data Roaming Access.

    I thought everything was working great, but when I traveled to Galveston beach I realized I could only call and text people. Texting only worked about 50% of the time. No applications were working for example google maps, spotify, groupme etc. Everything worked when I was home because of the wifi connection.

    So my question to the forum is can I use the Verizon S5 with my AT&T sim card?
     

    Advertisement

  2. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    If you're not in a Band4 area,it looks like it's 2G/3G only.
    http://willmyphonework.net/

    You may need to manually set the APN :
    App Drawer > Settings > Mobile Network Settings > Access Point Names & insert the following:
    https://www.att.com/esupport/article.html#!/wireless/KM1062162
     
    areyno8, Jfalls63 and lunatic59 like this.
  3. areyno8

    areyno8 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Jun 19, 2016

    Jun 19, 2016
    3
    1
    16
    Male
    I manually set the APN as instructed and I believe that solved the problem. Sometimes I see a 4G LTE logo (weak signal) and other times I see a H or H+. I am assuming the H and H+ is the slower 2G/3G connection?

    Thanks for the help.
     
    KOLIO likes this.
  4. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    Glad to hear things are (apparently) working as they should.

    I believe H/H+ stands for HSPA,which is 4G,not quite as fast as 4G LTE:

    https://www.att.com/esupport/article.html#!/wireless/KM1000812

    BTW @areyno8 ................
    WELCOME TO ANDROID FORUMS! :thumbsupdroid:
     
    areyno8 and Jfalls63 like this.
  5. areyno8

    areyno8 Lurker
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    3
    Joined:
    Jun 19, 2016

    Jun 19, 2016
    3
    1
    16
    Male
    Thanks KOLIO,

    I have another problem and I was hoping you could assist me with. I cannot get group messages or multimedia messages to work. I even did a restore to factory settings and it still does not work. I entered the APN settings as you previously directed and double checked that I did not fat finger any digits. Everyone else works great by the way.

    When I do get a group message or a picture message, it will ask me to download the message. They are all small (1KB), but they never load.

    I stumbled upon a similar thread where you helped the user out. How I knew to come back to you.
     
  6. KOLIO

    KOLIO Guest
    Rank:
    None
    Posts:
    0
    Joined:

    @areyno8

    I use the messaging app Textra:
    https://play.google.com/store/apps/details?id=com.textra&hl=en

    Set the MMS download limit to 1MB & you shouldn't have any problems,pix will show instantly.
    Also,sometimes,in MMS settings,I have to toggle the MMS behavior setting from SYSTEM to LEGACY or vice versa.

    Otherwise,this app is ready out-of-the box,works flawlessly 99.99% of the time & thankfully,the look/feel is customizeable.
     
    Jfalls63 likes this.

Share This Page

Loading...