1. Are you ready for the Galaxy S20? Here is everything we know so far!

attn scary! new funky options in recovery

Discussion in 'Android Devices' started by scotty85, May 22, 2011.

  1. scotty85

    scotty85 Extreme Android User
    Thread Starter

    lately me and BC have both noticed settings to backup and restore "google proprietary system data". i tried to back up,but got the "run via adb" error so im not sure if these options are functional or not.(battey isnt low and a regular nandroid performed fine)

    i am not sure how long its been there. ive messed with recovery images alot with my recent adb,fastboot and hboot shenanigans,so i have no idea where it may have come from.

    BC said his has always been on the test phone.

    both are "trackball optional recovery"

    any thots? :D
     



    1. Download the Forums for Android™ app!


      Download

       
  2. scary alien

    scary alien not really so scary
    VIP Member

    Scotty,

    Sorry, just saw your thread. Had a soccer game tonight when you posted this (just squeezed it in between the thunderstorms, lol ;)), and then got busy with my apps.

    I've seen those options before, but never played with it. Here's the source of the backuptool.sh script that you are having problems with:

    https://github.com/packetlss/amonra_recovery_scripts/blob/alt-a2sd/backuptool.sh

    I'm guessing that its kind of an "old school" option that is no longer needed (maybe a precursor to Titantium Backup functionality perhaps?). This kind of seems like the "Google apps" package (gapps*.zip) that you sometimes have to download / flash on certain ROMs. Maybe the list of files that are listing in the shell script are no longer exactly correct?

    It might be interesting to view the /cache/recovery/log file after this error happens to see what it actually is doing / reporting (since the "run adb" error is useless). You can just adb into your phone while recovery is running and pull the file ("adb pull /cache/recovery/log my-recovery-log.txt") and see if its a missing file or an MD5 checksum issue.

    Dunno. Cheers!
     
    scotty85 likes this.
  3. scotty85

    scotty85 Extreme Android User
    Thread Starter

    thank you mister scary,sir.glad you actually got some time for a soccer game... here in the wonderful miami river valley it seems we have to have 3 weeks of rain for every 2 days of sunshine,lol.

    our main questions were where did they come from? seems alot of folks dont have em,and we were just wondering how/when/why it changed. i run Amon's recovery on my incredible as well,and i just upgraded to his latest,and BAM! there they are on that one,too. dont have these options in clockwork on my TB,and BC doesnt have em on clockwork on his inc. is it something that Amon started adding to his recovery images,so after a certain point,everyone that rooted/installed an Amon_Ra recovery has them?

    on the inc,it did let me back them up. but i have no idea what exactly i backed up,or if i should ever try and restore them :D:p

    so for sh*ts and giggles, i tried to view the cache/recovery long. i put in the command,and all i got was:
    101 kb/s (3010 bytes in 0.029s)
    wich i assume is all i will see...

    so in recovery,i chose the option to move the log to the SD. looking at it,what is says is this:
    Code (Text):
    1. Starting recovery on Mon May 23 11:56:33 2011
    2. can't open /dev/tty0: No such file or directory
    3. framebuffer: fd 3 (320 x 480)
    4. Build : RA-eris-v1.6.2
    5. [trackball optional]
    6. I:Set boot command "boot-recovery"
    7. Command: "/sbin/recovery"
    8.  
    9. ro.secure=0
    10. ro.allow.mock.location=0
    11. ro.debuggable=1
    12. persist.service.adb.enable=1
    13. ro.error.receiver.system.apps=com.android.updater
    14. ro.build.id=ERD79
    15. ro.build.display.id=ERD79
    16. ro.build.version.incremental=134869
    17. ro.build.version.sdk=7
    18. ro.build.version.codename=REL
    19. ro.build.version.release=2.1
    20. ro.build.date=Thu Feb 11 22:36:17 CST 2010
    21. ro.build.date.utc=1265898977
    22. ro.build.type=user
    23. ro.build.user=u70000
    24. ro.build.host=Oven-X04
    25. ro.build.tags=release-keys
    26. ro.product.model=Eris
    27. ro.product.brand=verizon
    28. ro.product.name=htc_desirec
    29. ro.product.device=desirec
    30. ro.product.board=desirec
    31. ro.product.cpu.abi=armeabi
    32. ro.product.cpu.abi2=
    33. ro.product.manufacturer=HTC
    34. ro.product.locale.language=mdpi
    35. ro.product.locale.region=
    36. ro.wifi.channels=
    37. ro.board.platform=msm7k
    38. ro.build.product=desirec
    39. ro.build.description=2.26.605.2 CL134869 release-keys
    40. ro.build.changelist=134869
    41. ro.build.modelid=
    42. ro.product.ua=
    43. ro.build.fingerprint=verizon/htc_desirec/desirec/desirec:2.1/ERD79/134869:user/release-keys
    44. ro.product.version=2.26.605.2
    45. keyguard.no_require_sim=1
    46. rild.libpath=/system/lib/libhtc_ril.so
    47. ro.ril.default.modem-type=2
    48. ro.telephony.default_network=4
    49. wifi.interface=tiwlan0
    50. wifi.supplicant_scan_interval=15
    51. ro.ril.htcmaskw1.bitmask=4294967295
    52. ro.ril.htcmaskw1=268449905
    53. ro.com.android.dataroaming=true
    54. ro.com.google.locationfeatures=1
    55. persist.service.mount.playsnd=0
    56. ro.cdma.data_retry_config=max_retries=infinite,0,0,60000,120000,480000,900000
    57. ro.sf.lcd_density=160
    58. ro.media.enc.file.format=3gp,mp4
    59. ro.media.enc.vid.codec=m4v,h263
    60. ro.media.enc.vid.h263.width=176,352
    61. ro.media.enc.vid.h263.height=144,288
    62. ro.media.enc.vid.h263.bps=64000,800000
    63. ro.media.enc.vid.h263.fps=1,30
    64. ro.media.enc.vid.m4v.width=176,352
    65. ro.media.enc.vid.m4v.height=144,288
    66. ro.media.enc.vid.m4v.bps=64000,800000
    67. ro.media.enc.vid.m4v.fps=1,30
    68. ro.cdma.home.operator.numeric=310012
    69. ro.cdma.home.operator.alpha=Verizon
    70. ro.config.htc.nocheckin=1
    71. ro.url.legal=http://www.google.com/intl/%s/mobile/android/basic/phone-legal.html
    72. ro.url.legal.android_privacy=http://www.google.com/intl/%s/mobile/android/basic/privacy.html
    73. ro.com.google.networklocation=1
    74. ro.setupwizard.mode=DISABLED
    75. ro.config.ringtone=Innovation.mp3
    76. ro.config.notification_sound=Color.mp3
    77. ro.config.alarm_alert=Light.mp3
    78. ro.config.cal_notification=Vector.mp3
    79. ro.config.msg_notification=Ascend.mp3
    80. ro.com.google.clientidbase=android-verizon
    81. ro.com.google.gmsversion=2.1_r1
    82. net.bt.name=Android
    83. net.change=net.bt.name
    84. ro.config.sync=yes
    85. dalvik.vm.stack-trace-file=/data/anr/traces.txt
    86. ro.modversion=RA-eris-v1.6.2
    87. ro.factorytest=0
    88. ro.serialno=HT9CEHG00119
    89. ro.bootmode=recovery
    90. ro.baseband=2.40.00.01.22
    91. ro.carrier=COMMON
    92. ro.bootloader=1.49.2000
    93. ro.hardware=desirec
    94. ro.revision=2
    95. ro.cid=VZW__001
    96. init.svc.recovery=running
    97. init.svc.adbd=running
    98. adb.connected=
    99.  
    100. I:Set boot command ""
    101. I:Set boot command ""
    102.  
    103. Move recovery.log to SD
    104. Press Trackball or END/PWR to confirm,
    105. any other key to abort.
    106.  
    107. Moving : .
    is that first thing(can't open /dev/tty0: No such file or directory) what caused it not to work?:eek:
     
  4. scary alien

    scary alien not really so scary
    VIP Member

    Yeah, its gonna rain on us here in Indy the rest of the week...I'm not too far away from you, I guess :).

    Ah, sorry, I slightly misunderstood what you were asking.

    Simple(-ish) answer:

    Most people, especially the ones that don't have the tweaked trackball recoveries I re-compiled, have the 1.6.2 version of recovery.c (i.e., the desirec branch in the github).

    https://github.com/packetlss/amonra_bootable_recovery/blob/desirec/recovery.c

    This version does not include the special Google backups.

    The first version of my alternate recovery, the "trackball-not-required", was built using the 1.6.2 (desirec branch) and therefore also did not include these options.

    When I discovered (thanks to mhotovec and TheLedge93) that the "trackball-not-required" (1.6.2 recovery.c) did not include the SD card partitioning options, I searched the github again for a version of recovery.c that did have the partition options. I ended-up using the 1.7.1 (mahimahi branch) version of recovery.c to build the "trackball-optional" version that you are using now:

    https://github.com/packetlss/amonra_bootable_recovery/blob/mahimahi/recovery.c

    which includes these new options that you are seeing.

    Simple, eh? :p

    Sorry for the confusion! Cheers!
     
    scotty85 likes this.
  5. scotty85

    scotty85 Extreme Android User
    Thread Starter

    well,that explains it,lol... :D :eek:

    but as usual i like learning about this stuff... so the other question remains,why wouldnt it let me back them up? does my log tell you anything?

    also,yes! you are pretty close,im in dayton,ohio,so i could be at your house in a couple hours if you ever need help with anything :D

    and once again,may thanks for entertaining my whims and curiosities :cool:
     
  6. scary alien

    scary alien not really so scary
    VIP Member

    No, the log doesn't show anything that I can discern (usually the important stuff and error/warning-related stuff is at the end; the bulk of this is just the output of the getprop command (you might want to redact your serial number in there, but it probably doesn't matter anymore since "the man" has other ways of knowing you are rooted, lol)).

    The /dev/tty0 warning seems familiar and probably isn't anything, but I'm a little surprised nothing additional was logged (although I really didn't look at the backuptool.sh script that closely, to see if it even tries to report anything additional (I'll take a second look here in a sec...it was late last night and I was trying to hit the hay)).

    Yeah, Dayton isn't too far from me... Lemme know if bobcat shows up at your house and he can come over and fix my plumbing :eek: while you and I root my new Xoom :D :p ;) [sorry, bobcat, I couldn't resist :)].

    Cheers!
     
  7. scotty85

    scotty85 Extreme Android User
    Thread Starter

    oooh that sounds like a most excellent plan,lol :eek::D:p:cool:
     
  8. scary alien

    scary alien not really so scary
    VIP Member

    Okay, the script is actually pretty simple. Here's what it does:

    1. mount the /cache and /system filesystems

    2. if you are doing a backup, then for every file in the get_files list, invoke the backup_file function for each referenced file in /system

    3. the backup_file routine will copy each given file to the /cache/google directory; this function will only return a non-zero exit code when its asked to check the MD5 sum (which doesn't look likes it used/relevant here)

    4. the restore_file function will copy the file from /cache/google directory back to its location as specified in the get_files list; this function does not return a non-zero exit code

    I don't really see how the script would have failed for you unless it was asked to do something other than "backup" or "restore" and it clearly did not report anything relevant in the /cache/recovery/log file...

    By the way, was the error on the recovery screen this?:

    unable to execute backuptool.sh! [this part may not have shown]
    Error : Run 'backuptools.sh' in adb!

    Not really sure what is going on... You could actually boot into recovery, connect via "adb shell" and execute the "/sbin/backuptool.sh backup" command manually and see what it reports. Right after it returns, do an "echo $?" to see if the exit code is non-zero.

    Cheers!
     
  9. scotty85

    scotty85 Extreme Android User
    Thread Starter

    yup! thats the error message it gave. i just tried it again... then i tried to do it via adb and got a "sbin/sh: /sbin/backuptool.sh: not found" error :eek:
     
  10. Bob Cat

    Bob Cat Careful, They're sharp!!
    VIP Member

  11. scary alien

    scary alien not really so scary
    VIP Member

    Ah, this might be because I used the "original" Amon_RA recovery.img (that was labeled as "1.6.2") as the base for the new versions and it probably did not have that tool (script) included in that somewhat early version.

    Like I said in the big trackball thread, it was/is very confusing re. what actual version of things that RA used when building and packaging-up the recovery. His "1.6.2" label is a little inconsistent with what I've seen in the code and options and what was packaged in the original image.

    You could grab the script from the links above and push it to the phone and run it (or if you really want me to, I can re-pack a version for you with those scripts in it).

    Cheers!
     
  12. scary alien

    scary alien not really so scary
    VIP Member

    lol...just seeing if you were awake over there, BC :) ;) :D.
     
  13. scotty85

    scotty85 Extreme Android User
    Thread Starter

    naw,that wont be neccessary,my curiosities are quite satisfactorily satisfied. you,sir,are a gentleman and a scholar :D

    i was starting to wonder,too,lol. hes been quiet today :eek::p
     
  14. Bob Cat

    Bob Cat Careful, They're sharp!!
    VIP Member


    Oh I've been watching. :D
     

HTC Droid Eris Forum

The HTC Droid Eris release date was November 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7600 processor, and 1300mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...