1. Check out our companion app, Forums for Android! Download from Google Play

auto-rotate not working

Discussion in 'Android Devices' started by DBHALL, Apr 3, 2013.

  1. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    My auto-rotation stopped working stopped working when I was on Midnight ROM, thought when I updated to GB28 it would be fixed. Have read in forums that this is fairly common, but tried many different things to fix, none of which worked? Any suggestions would be greatly appreciated! Midnight didn't cause this. Didn't mean to make it sound like that
     

    Advertisement

  2. christiansoto

    christiansoto Well-Known Member
    38

    Aug 29, 2011
    157
    16
    38
    did you calibrate your device before it happen
     
  3. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    Before and after
     
  4. neo_lithic3k

    neo_lithic3k Active Member
    18

    Feb 16, 2013
    39
    10
    18
    I ran into that issue in one of the roms as well. In that rom there was a checkbox to use calibrated values, or something to that effect. When I unchecked it, auto-rotate started working again. (I did calibrate my phone but for some reason I still had to uncheck it)
     
    DBHALL likes this.
  5. christiansoto

    christiansoto Well-Known Member
    38

    Aug 29, 2011
    157
    16
    38
    It happened to me before so i ordered a replacement
     
  6. BGOszman

    BGOszman Member
    16

    Mar 24, 2013
    10
    1
    16
    Male
    Warehouse Loader for Pepsi
    Florida
    Had the exact same problem. Took a bit of messing with it but I finally figured out that the sensor was reading upside down and at a 45
     
    DBHALL likes this.
  7. bronder

    bronder Member
    16

    Dec 17, 2012
    13
    1
    16
     
  8. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    Calibration is done in settings-motion-sensitivity
     
    TheBritton likes this.
  9. bronder

    bronder Member
    16

    Dec 17, 2012
    13
    1
    16
    thanks, but that did nothing.
     
  10. Prey521

    Prey521 Well-Known Member
    43

    Jul 19, 2011
    466
    40
    43
    I'm having the same problem on Midnight Rom. Calibrating doesn't fix it.
     
  11. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    I ended up having to order a new device as I wasn't sure what exactly caused the problem. Narrowed it to a problem in script, possibly from deodex? Finally gave up! Sorry I'm not able to provide more help.
     
  12. dueltothedeath

    dueltothedeath Well-Known Member
    38

    Oct 7, 2011
    149
    23
    38
    My auto rotate also stopped working.. if anyone finds a fix without having to go back to older version of cm10.1 to calibrate let me know
     
  13. cpk

    cpk Member
    15

    Nov 24, 2012
    11
    0
    15
    I had the some problem. I wiped, cleared, and reinstalled. Autorotate works perfectly now.
     
  14. Prey521

    Prey521 Well-Known Member
    43

    Jul 19, 2011
    466
    40
    43
    Gonna give that a try, thanks
     
  15. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    Try updating your profile: settings-updates-update profile:p
     
  16. bronder

    bronder Member
    16

    Dec 17, 2012
    13
    1
    16
    Tried this, still nothing... thx for the suggestion. Will putting cm10.1 on, and using the calibrate from it help? It seems like this is a fix.
     
  17. Prey521

    Prey521 Well-Known Member
    43

    Jul 19, 2011
    466
    40
    43
    CM10 is a completely diff ROM. So yes, it will fix the auto rotate issue, but you won't be running MidnightRom anymore.
     
  18. DBHALL

    DBHALL Active Member
    Thread Starter
    16

    Nov 16, 2011
    43
    3
    16
    Try *#0*# This is the only option I didn't try before I ordered new phone!
     
  19. Prey521

    Prey521 Well-Known Member
    43

    Jul 19, 2011
    466
    40
    43
    Resolved the issue with the rotation. With the help of an XDA member (dev for Magic Unicorn ROM), he had me flash an old version of CM10 which has the gyro sensor calibration tool. I flashed it, enabled the Use calibration values, calibrated the Gyro, then confirmed that it's working in the apps, then disabled the "Use Calibration Values", factory wiped and flashed the ROM of my choice and voila, rotation is working!
     
  20. steeljack99

    steeljack99 Well-Known Member
    43

    Feb 16, 2012
    186
    28
    43
    Male
    College Student
    Virginia
    good to know incase it happens to us, you may want to post a link to said rom incase it happens to others :D
     
    Prey521 likes this.
  21. Prey521

    Prey521 Well-Known Member
    43

    Jul 19, 2011
    466
    40
    43

Share This Page

Loading...