1. Download our Official Android App: Forums for Android!

Root [Avail] (easy) REAL wifi FIX for "obtaining ip address" loop--found by me

Discussion in 'Android Devices' started by stayboogy, Jul 15, 2012.

  1. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    here is a REAL FIX, NOT WORK-AROUND for the "obtaining ip address" loop without setting static ip address.

    i found this myself, by examining error log dump, logbox, which for me was showing "E/dhcpcd ( 7097): / system/etc/dhcpcd/dhcpcd-run-hooks: Permission denied"

    system/etc/dhcpcd/dhcpcd-run-hooks needs to have permissions fixed to "execute" by "user" "group" and "others" by using your favorite file explorer

    this will fix your "obtaining ip address loop" without having to ever use static ip address

    or at least it did mine.

    http://www.youtube.com/watch?v=O7BDhH2Yt0E&feature=youtu.be
     

    Advertisement

  2. Motorhead1991

    Motorhead1991 Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    831
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    831
    134
    113
    Student, Clearfield Job Corps, Diesel program
    Pasco, WA
    :congrats: :congrats: :congrats: Very nice find! :D
     
  3. originalginger

    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 12, 2012

    Jul 12, 2012
    3
    0
    5



    how can i get to that. Im kind of a noob. But my wifi doesnt even scan it just sits there for like 10sec then turns off.
     
  4. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    this is not for fixing a non-working wifi

    this is for fixing the "obtaining ip address" loop that happens when you put the correct wep key for a network and it refuses to connect without manually setting up a static ip address.

    for this you have to navigate to the above location using any root explorer, i use x-plore, and then long click on the file and make sure the check boxes are checked on the permissions to "execute" for each user group.

    doesn't get any simpler than that.
     
  5. originalginger

    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jul 12, 2012

    Jul 12, 2012
    3
    0
    5
    Do you know a way to fix a non-working wifi?
     
  6. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113

    maybe you should download several of the "fix my wifi" or "wifi fixer" apps from the app store and see if one of them fix your problem

    other than that i have no idea.
     
  7. RainZor

    RainZor Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 22, 2012

    Sep 22, 2012
    2
    0
    5
    Hey. Nice to see someone else has this problem to. The thing is i dont quite get that i am suppose to do with the file"dhcpcd-run-hooks".

    Please respond.

    Best regards
     
  8. Russ71

    Russ71 Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    207
    Joined:
    Jul 20, 2012

    Jul 20, 2012
    207
    24
    58
    logger
    small town, Ohio

    Change the permissions. Check the first execute.
     
  9. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    exactly. change the permissions to "execute" for all users, groups, and others.

    this should fix your problem.

    if not, use catlog to find out what your error is. turn on your wifi, input the correct password, and then try to connect and immediately go to catlog and find what is giving you your error and go from there.
     
    Russ71 likes this.
  10. RainZor

    RainZor Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 22, 2012

    Sep 22, 2012
    2
    0
    5
    This i understood. The thing is that when i am in x-plorer and i am looking at the file. There is really nothing i can do except renmae, delete or show the details. Sorry if im beeing stupid here.
     
  11. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113

    long press the file, then scroll down to the very last option "permissions"

    then make sure every box is checked

    if you don't have all these options when you long press the file: rename, copy, move, create zip, delete, show details, share, open by, hex viewer, edit text, permissions;

    then you need to press the menu button (while in x-plorer), go to configuration, then where the root access is, press it and select "Superuser + mount writable" which is the last option in the program, then you will be able to change permissions.

    if you are still having trouble i don't know how to help you because this is pretty straight forward
     
  12. fredster

    fredster Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 10, 2012

    Oct 10, 2012
    2
    0
    5
    Just discovered this cool fix, but when I change my rights in X-plore as above, I can no longer open the root folder. Any suggestions?
     
  13. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113

    if you've changed your rights in the settings of X-plore to "superuser + mount writable" and can no longer view the phone's root, well then there is something wrong with your su binary, or you aren't really rooted. this what you need to be able to do any editing whatsoever to your phone...

    you could try another explorer and see if that fixes it, but i don't think it has anything to do with X-plore...
     
  14. fredster

    fredster Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Oct 10, 2012

    Oct 10, 2012
    2
    0
    5
    OK, just discovered what "rooted" is all about. Too scary for me - "bricking" the thing and all that! Strangely, running Allshare seems to work most the time. Thanks for your super informative posts.
     
  15. NehaSingh

    NehaSingh Newbie
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    Sep 28, 2012

    Sep 28, 2012
    11
    3
    16
    Female
    Telecommunications Engineer
    India
    I was having similar issue, couple of days back everything was fine, I was enjoying watching YouTube on my Xperia Mini Pro SK17i but after updating couple of Apps when I reconnect WiFi it keeps on obtaining IP address for two days than I realized that if obtaining IP is the issue why don't it put static. I put static IP because router was mine and it worked like charm.
     
  16. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113

    my method FIXES the issue

    what you have done is a work-around, and is practically useless for those who are trying to connect to wifi that is not their own.

    and this work-around is the common, improper way of correcting the problem.

    if you actually want to fix the issue i suggest you try what i posted
     
  17. elyod88

    elyod88 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 22, 2012

    Oct 22, 2012
    1
    0
    5
    hi.. I already tried your method
    but it say "changing permissions was not succesful. please note that some file systems do not allow permission changes"
    I am using galaxy note
    what do I do?
     
  18. kingmt

    kingmt Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    609
    Joined:
    Jul 24, 2012

    Jul 24, 2012
    609
    77
    78
    Male
    IRCop & Dev
    WV
    What file explore are you using?

    I use ES File Explore. I just had to go back in this morning to reset my permissions but before I could I had to reinstall the file explore for root permissions to work. I have no idea what is going on. I had made these changes some time ago & everything was working last night but this morning WiFi was in obtaining IP address.
     
  19. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    you need to have full access to do this. if you're not rooted you can't do it.

    i suggest using x-plore, and in the configuration you need to make sure you have "superuser+mount writable" under the root access setting.
     
  20. vodanhdaisu

    vodanhdaisu Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 26, 2012

    Oct 26, 2012
    1
    0
    5
    Hi there I'm using Galaxy S3 E210K, I managed to do your guide successfully, but it did not work on my phone. Still "Optaining Ip address..." :(
     
  21. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    i never said it was GUARANTEED to fix the problem on other phones, or that it was GUARANTEED that this was the culprit

    just this is the common issue, and this is the best way to fix it

    you also might need to reboot the phone as well

    other than that...

    i suggest you get CatLog app from the store, and follow my post #9 below about how to examine logs and go from there.

    that's how i found my error and fixed it
     
  22. Russ71

    Russ71 Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    207
    Joined:
    Jul 20, 2012

    Jul 20, 2012
    207
    24
    58
    logger
    small town, Ohio
    Stayboogy, I've corrected the permissions and it still won't hook up to anything except open signals- Tim Horton's, McDonald's, Starbucks and the like. I did put in static IP and the other fields, it says its connected but, it won't get online. I've googled this issue and no dice. If you know another fix, lets give it a shot. Thanks, bud.
     
  23. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113
    setting up static ip is not a fix. it's a workaround and a poor one at that.

    but i'm not aware of any other fixes. if you've got the correct permissions on the dhcp hooks file, then there's something else causing your problem

    do the same thing i've mentioned multiple times now

    get CatLog from the app store

    turn on wifi and try to connect and immediately start viewing the logs

    this will show your error and give you ideas of where to look next.
     
    Russ71 likes this.
  24. Crehan

    Crehan Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 21, 2012

    Nov 21, 2012
    1
    0
    5
    How do I get x-plore onto my Nexus seven without having a connection to the Internet?
     
  25. stayboogy

    stayboogy Android Expert
    Thread Starter
    Rank:
    None
    Points:
    113
    Posts:
    867
    Joined:
    Jun 15, 2012

    Jun 15, 2012
    867
    285
    113

    use you head...

    the same way you posted in this thread is the obvious answer...
     
Tags:

Share This Page

Loading...