1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Avail] Need help with Avail rooting/unrooting

Discussion in 'Android Devices' started by daisies5, Jul 12, 2013.

  1. daisies5

    daisies5 Lurker
    Thread Starter

    Hello, I have been working on rooting my ZTE Avail in order to get rid of bloatware. I tried the All Things Root Guide, but I couldn't get the apn horse screen to show up. I had USB debugging on and reinstalled drivers, but apn never saw my device.

    After I was sufficiently frustrated with the apn route, I decided to go the t-card route. I pretty much don't know what a t-card or a ROM is, but I'm starting to get an idea. I am now at build version Z990V1.0.0B14 (was previously at B19), I typed *983*7668# into the dialer and I instantly had root access! I ran Root Checker to confirm and used ROM Toolbox Lite to delete the bloatware with no issues.

    I read up on superuser app and it sounded like something I probably needed. I started with installing Clockworkmod Superuser, but it hung up on startup, so I deleted it and then I downloaded the su file that's posted to the All Things Root Guide and put it in my system/bin folder (where Root Checker said my su file was located). I re-installed the Clockworkmod Superuser app, but it said I needed an updated su file and it gave me an error when it tried to update the file. So, I deleted it again and downloaded ChainsDD Superuser (as you can tell, I have no clue what I'm doing). ChainsDD said I had an outdated su file and when it tried to download an update, there was an error indicating it didn't have access to root. I double checked Root Checker and I no longer have root access. I tried to run the dialer again, but still no root access. I double checked and I'm still at build version B14.

    So, now that I no longer have root access, I guess I have no need for the Superuser app? I didn't try very hard to get root access back, I'm sure it's possible, but my main goal of this whole experience was to be rid of bloatware and get more space on my phone, which I did. The only problem is that I now have this old build version, with no swype or other fancy stuff.
    [FONT=&quot]I did *attempt* to use one of the AA51 ROMs, but after step 1 didn't work for me, I decided I'd better just leave it alone.

    Does anyone have any advice on my next step? Should I just leave the poor phone alone before I brick it, or is there a way to upgrade the build version without major issues?

    Thanks so much for your help!

    [/FONT]
     



    1. Download the Forums for Android™ app!


      Download

       
  2. daisies5

    daisies5 Lurker
    Thread Starter

    After I posted this, I accidentally reflashed the T-card (by pressing home instead of menu to boot into recovery) and decided to try the AA51 ROM again, and it worked!

    Thanks so much for all of the information that's posted on these boards, it has been a great help.

    Michele
     

ZTE Merit Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...