1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Avail] Relocating Dalvik cache to free up space

Discussion in 'Android Devices' started by Motorhead1991, Apr 29, 2012.

  1. SquidlyMcNerd

    SquidlyMcNerd Member

    The Camera ICS app crashes every time I try to use the panoramic feature, or whatever that curvy menu icon represents.

    Also had no connectivity. Phone or data. There was another error but I don't remember it at the moment.
     


  2. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    I get that same error, don't know why. As for the connectivity, have you put the apn settings in?
     
  3. neutrontech

    neutrontech Member

    I just tested mine, and the ICS camera app does not crash in the panoramic mode. Don't have any idea why it is crashing for you, but just so you know, it does work on the Merit.
     
  4. neutrontech

    neutrontech Member

    Just out of curiosity, currently when I use ES explorer and browse to /data/ I see the dalvik-cache directory, and it's full of stuff. Is there a way to tell if I'm looking at the actual dalvik-cache on my phone, or a sym link? I have no idea if my dalvik cache is currently being stored on my phone or the sd card, but I'm trying to figure that out.
     
  5. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    Hold down on it and look at the properties.
     
  6. neutrontech

    neutrontech Member

    Yeah I already did that, but it just says location is /data/dalvik-cache. But I'm not familiar enough with sym links to know if the properties will tell me if it is linked or not.

    It's my understanding that linking something tricks the system into thinking the file is someplace, when in reality it is someplace else. So, I'm unclear if the file browser is also "tricked"; ie. it thinks the files are at /data/, and shows me as such, but in reality it's on the SD card. Or, if it's showing me the truth.

    Am I making sense?

    EDIT: I've done some googleing, and I guess what I'm asking is how to tell if a path is absolute, or symbolic. I've found numerous ways in which to figure this out programatically, but I'm not writing a program. I just want to be able to tell this within ES explorer, which might not have the ability to do so. If ES can't do this, is there a terminal command to tell me?



    EDIT AGAIN:
    To answer part of my own question:
    Does the 'properties' dialog in ES File Explorer indicate if a folder is actually a symbolic link, or not? Doesn't look like it. I looked at the 'properties' of both /mnt/sdcard and /sdcard. Both 'properties' dialogs look exactly the same and provided the same information.

    So, back to my original question: is there a way to tell if a folder (ie. /data/delvik-cache) is actually on the phone, or a symbolic link to a folder on the ext2 partition on my SD card? any ideas?
     
  7. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    ES file explorer should have said /sdcard/dalvik-cache, unless the partition is an extension of the /data.
     
  8. neutrontech

    neutrontech Member

    OK. So my dalvik cache is still on my phones internal memory then.
     
  9. SquidlyMcNerd

    SquidlyMcNerd Member

    Don't know what happened but I tried MH1 again recently and it loaded just fine. The camera app still crashes in pano mode. I had installed Antyhony's new Kernel a few days ago and letting the phone work with it. Had over-clocked to 804mhz or something like that. The MH1 Rom cannot overclock beyond the factory 600mhz, I assume because it contains the old Kernel.

    Can'tfind the Dalvik cache anywhere. Not sure I'm looking in the correct areas.
     
  10. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    Yes, MH-1.0 has the stock kernel. As for the dalvik-cache, it's in /data
     
  11. Buzz2043

    Buzz2043 Newbie

    I am lost in this keep getting message "!/system/bin/sh: not found"
    Not sure if I need something else downloaded or if I am missing something here
     
  12. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    You have to include the hashmark on the first one. In Terminal Emulator, it'd look like this: # #!/system/bin/sh.

    From my view, the script is incomplete, so I'm not sure that will work for you. Eventually, I'll host the script itself.

    Also, using the Dalvik-move script messes with the reboot process, meaning you MUST wipe the cache before rebooting, otherwise you'll be in a loop. I haven't figured out how to automate this yet.
     
  13. Buzz2043

    Buzz2043 Newbie

    Cool will be looking forward to both those the script and the automated Dalvik move
     
  14. Motorhead1991

    Motorhead1991 Android Expert
    Thread Starter

    I'm still working on tge automation, but I have been working on true init.d support.
     
  15. jamespfassett

    jamespfassett Well-Known Member

    Im really looking forward to this, I gave it a shot with the script provided but its a no for launch. What is it about the script that is incomplete?
     

ZTE Merit Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...