1. Download our Official Android App: Forums for Android!

avast! Firewall not working

Discussion in 'Android Apps & Games' started by joaquin65, May 4, 2012.

  1. joaquin65

    joaquin65 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    May 4, 2012

    May 4, 2012
    2
    0
    5
    First of all: Hi! Im new here :D Good day to you!

    Now straight to the point xD:
    I got my first Android device a couple of days ago, and the most unfortunate thing happened to me.
    I got my credit raped by all the apps that connect to the web in the background xD

    So I though, "hmm, lets install some firewall", and I turned to avast! Mobile Security.

    The thing is that when I try to activate de firewall I get some message telling me that my kernel does not admit Netfilter, and to use a custom ROM.

    I was hoping you could lead me in this process.

    My phone is Alcatel OT906.
    Yea, it's rooted. I think... I did it myself some hours ago and it all ended up good.
    I have some knowledge about flashing devices and reinstalling firmware (a PSP some years ago)

    What ROM should I use? Why?
    What is the safest way to to this?

    Thanks in advance!

    Joaqu
     

    Advertisement

  2. amlothi

    amlothi Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,185
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    1,185
    201
    143
    A ROM is not like and app that you just install. It's a whole new operating system for your phone. It will change the look, the feel, the preinstalled applications, the settings, etc.

    Making the decision to put a custom ROM on your phone is not easy, and there is no "best" one. It's a case of user preference.

    Have you tried using DroidWall? I'm guessing it also won't work on your phone, but worth a shot if you just need a firewall app.

    If you decide to search for a ROM, you can read through this thread: [Q] Alcatel OT-980 root and rom development - Page 36 - xda-developers

    However, on a quick search, I'm not finding much for your model phone. It just might not be that popular, and it's possible nobody has developed any custom ROMs specifically for your device.
     
    joaquin65 likes this.
  3. joaquin65

    joaquin65 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    May 4, 2012

    May 4, 2012
    2
    0
    5
    Yes, I tried DroidWall.
    Didn't work either.

    I'll read that article over there, thanks :D
     

Share This Page

Loading...