1. Are you ready for the Galaxy S20? Here is everything we know so far!

Aviator Root

Discussion in 'Android Devices' started by Now534, May 8, 2012.

  1. Now534

    Now534 Newbie
    Thread Starter

    Some have reported that not pulling the battery out that it has affected the odin flash. It is easier to pull the battery to make sure it is completely off.

    To get into download mode i used Volume Down + Home + Power it can probably be done by Volume Down + Power. You could have it rooted in 2 minutes if you already have the files downloaded.

    VoltronMaximus likes this.

    1. Download the Forums for Android™ app!


  2. VoltronMaximus

    VoltronMaximus Android Enthusiast

    Thanks for the response. Will report back later with results.
  3. VoltronMaximus

    VoltronMaximus Android Enthusiast

    Everything worked great. Now we just need a custom rom that supports apps to sd.
  4. Zebulon

    Zebulon Android Enthusiast

    Stock Gingerbread does support apps to SD. Besides, there is 2gb of onboard storage for .apk files, which is a huge amount of space for just apps. Many apps work best on the phone rather than the SD card anyway.

    I'd be a heck of a lot more interested in an ICS-based ROM. I'm hoping that AOKP will get ported over to the Aviator soon.
  5. Now534

    Now534 Newbie
    Thread Starter

    ICS would be nice to have for sure
  6. ron427

    ron427 Lurker

    Used Super One Click method and successfully rooted in less than 5 minutes.
  7. Now534

    Now534 Newbie
    Thread Starter

    This root was so much easier than the Merge root i still had problems attempting to root my friends merge.
  8. alreadyinuse

    alreadyinuse Lurker

    musmagic likes this.
  9. Now534

    Now534 Newbie
    Thread Starter

    I ended up using that as well.

    Sidenote Tegrak now supports the Aviator so we can overclock to 1.2 or 1.3ghz on the free app. I OC'd to 1.3ghz and on Go Powermaster (something like that) It shows i gained about 10 hours of battery life (idle time). So overclocking this phone increases battery life from my test. Seems pretty snappy to doesn't take as long to load some apps up.
    musmagic likes this.
  10. supty617

    supty617 Lurker

    Just wanted to give Now a big thank you and the other guys that have worked hard to share this information! Rooted my Aviator with little trouble! Hopefully it will start becoming a more desirable phone soon!
    Overclocked it to 1.3 Ghz and it runs awesome.
  11. Now534

    Now534 Newbie
    Thread Starter

    Its not a bad phone it has its ups and downs even after overclocking it sometimes seems laggy unlike my Merge that when overclocked it is lag free. The 4g speeds are amazing though.
  12. Zebulon

    Zebulon Android Enthusiast

    Yeah, it's been massively improved by debloating and OCing, but I think I'm going to swap mine out for the GSIII in a couple of months. My wife will be due for an upgrade towards the end of July, and I think she may inherit the Aviator while I get the GSIII.
  13. Now534

    Now534 Newbie
    Thread Starter

    I will be switching over to the GSIII as well but on the verizon network since that is where my brother wants to go through next so he can get a iPhone 5.
  14. dukeofbluz

    dukeofbluz Newbie

    Odin 3 v1.85 (where do i get this? and do I download it to the phone or pc?)

    SuperOneClick (SuperOneClick - Download.com)
    Your Phone

    Download this (http://teamuscellular.com/downloade...iator_root.tar.md5&directory=Samsung Aviator&) onto my PC? or phone?

    Boot phone into Downloader mode (How?)
    Pull battery reinsert hold volume down and plug usb cable in

    Flash the .tar in PDA mode.(please explain this)

    Let it restart (should go into USB Debugging mode if not put in Debugging Mode)

    Open up SuperOneClick and click Root.

    Thank you very much
  15. Google Odin v1.85 and click the first link. Downloads right from XDA developers..SAFE...
    Download it to your CPU

    As for the .Tar link, download that to your CPU as well

    For putting your phone into Downloader mode: Pull Battery - Put Battery back in - Hold Volume 'Down' Botton - Plug USB into phone
    (Two notes: obviously the USB should already be plugged into the CPU at this point, and once in downloader mode you will see a prompt to push Volume up to start mode or down to cancel)

    As to Flahing the .Tar file: Open Odin and you will see a 'PDA' tab. Click on PDA and then it will open your download location on your CPU, find the .Tar you downloaded earlier and select it, then in Odin click on START...Done!!

    Hope this helps!
    dukeofbluz likes this.
  16. dukeofbluz

    dukeofbluz Newbie

    Thank you all, I rooted my phone, removed the amazon crap and over clocked it.
    But what else is out there?

    Thank you,
  17. Zebulon

    Zebulon Android Enthusiast

    At the moment, not much. You can do V6 SuperCharger, or the Auto Killer Memory Optimizer (they seem to do the same thing) but that is about it. There doesn't really seem to be much going on for development on this phone, especially since the GSIII is coming out soon.
  18. drmmrby2k4

    drmmrby2k4 Lurker

  19. penn0kee

    penn0kee Lurker

    can someone help me superoneclick always fails here is the message..
    (also it fails at step#7)

    mount -o rw,remount /dev/block/stl10 /system > /data/local/tmp/output 2>&1

    export TEMPRANDOM=71926

    export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

    mount: Operation not permitted

  20. Now534

    Now534 Newbie
    Thread Starter

    Updated the first post. Thanks
  21. Now534

    Now534 Newbie
    Thread Starter

    Posted on youtube also. Do you have the aviator_root.tar flashed through odin before running superoneclick?
  22. penn0kee

    penn0kee Lurker

    when i flash the file it factory resets my aviator:(
  23. penn0kee

    penn0kee Lurker

    and it doesnt work
  24. niddup

    niddup Lurker

    I'm having the exact same issue as you penn0kee. I hope someone has a fix.
  25. niddup

    niddup Lurker

    Get the aviator_root.tar.md5 from the link, do not use the CR930_USCC_FD02_CL1016569_USER.tar.md5 included with the driver, not sure what it is for but that is what is hosing the process. I finally got it working now, so much faster.

Samsung Galaxy S Aviator Forum

Features and specs are not yet known.

Release Date

Share This Page