1. Download our Official Android App: Forums for Android!

General battery charging issue

Discussion in 'Android Devices' started by uchi, Nov 15, 2010.

  1. uchi

    uchi Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    158
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    158
    2
    36
    i noticed since going to 2.1 my battery wont fully charge. it stays plugged in on average 7 hours while i sleep and each morning its been around 90% full but no more. i know the battery will charge and discharge a little while charging but this one doesnt wanna go any higher. any thoughts?
     

    Advertisement

  2. rogem_kk

    rogem_kk Member
    Rank:
    None
    Points:
    16
    Posts:
    50
    Joined:
    Nov 14, 2010

    Nov 14, 2010
    50
    3
    16
    Edmonton, AB
    Try a hard reboot. Shut down, take out the battery for a few seconds before restarting.
     
  3. Holger_Danske

    Holger_Danske Member
    Rank:
    None
    Points:
    36
    Posts:
    51
    Joined:
    Aug 24, 2010

    Aug 24, 2010
    51
    1
    36
    Got to say I haven't had that. The first day it was gobbling up my battery like nobody's business. But I had live christams tree wallpapers and installing all kinds of stuff.
    Since removing that, using Startup auditor to weed out some of the offenders I recharged my battery during daytime yesterday, got 100% charge about dinner time, and have run so far today (which is now over 24 hours) and have 91% on my battery. Mind you I have a Mugen Power battery, but still, I see no difference in increased drain other than live wallpaper. Turn that feature off my friend, then start squeezing down the next worst one, then the next until you get it to where you want it. I honestly don't have a problem with battery life, in fact it might be about 10% better anecdotally speaking of course.
     
  4. uchi

    uchi Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    158
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    158
    2
    36
    weirdly enough it charged to full this time. i reboot it every day as i find it seems to run better that way. maybe it just needed several battery pulls and a few reboots. other than that it runs great. since were talking battery, my screen seens to drain it, the brightness levels that is. how do i set it so its automatic and not constantly at one level? i like it bright but i think thats whats been draining the battery. unlike with 1.6 i dont see an auto feature on this one
     
  5. allbutlost

    allbutlost Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    177
    Joined:
    Oct 7, 2010

    Oct 7, 2010
    177
    10
    38
    My job is pretty great. You don't work there... th
    Canada.
    As I said in another thread, I experienced this problem with 1.6 frequently. Sometimes it would charge to full, other times it would be at 88% - 90% when I picked it up off the charger. I "solved" it by charging my phone from my work PC, for whatever messed up reason it doesn't happen if I charge it from a PC (my home computer is set to sleep so I never hook it up to that one as it would never charge, but my work PC doesn't sleep so I leave the cord at my office).

    After a bit of surfing on the issue, I've come to realize that it is not an uncommon complaint. I've just been letting it roll off my back though, since I am never short on opportunities to charge the thing during the day. So I'm afraid I haven't really looked into the cause too in-depth; however, the times I did look, no one seemed to have an answer, including SE Answers on twitter. They just told me my charger might be bad -- yeah that's a cop-out answer for "We don't know", lol.

    All I can tell you is that it isn't uncommon. Try charging from a PC, like I said that seems to do it for me.
     
  6. clockwork58

    clockwork58 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    256
    Joined:
    Jul 3, 2010

    Jul 3, 2010
    256
    29
    43
    Toronto
    I noticed this last night as well for the first time since my 2.1 upgrade.
    I got to 90%, and it stopped so i unplugged it (charging via outlet not PC) and replugged it back in and it topped it out to 100%.
     
  7. uchi

    uchi Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    158
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    158
    2
    36
    hah se dicks. my charger is brand new so thats not a valid answer. oh well. thats what rogers warranty is for lol
     
  8. allbutlost

    allbutlost Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    177
    Joined:
    Oct 7, 2010

    Oct 7, 2010
    177
    10
    38
    My job is pretty great. You don't work there... th
    Canada.
    warranty it all you like, you're just going to end up with another phone with a similar (or worse!) problem :p lol

    Oddly enough I'm the opposite on the issue, I had it with 1.6 and it went away with 2.1. Weirdness. Though I'll probably encounter it again.

    My point is that I don't think the problem is with your phone, because I have read MANY other stories that are identical. So returning it is just going to leave you X10-less for awhile until you get another phone that has the same issues. Seems like a waste, but hey, it's your time, you can waste if ya want :D

    Like I said though, try charging it from a (non-sleeping) PC. Watch it carefully as it climbs above the 90% mark, check it periodically and make sure it is charging. Typically I can charge it from the wall after that point no problem, at least for awhlie :p

    Also, don't plug your phone in unless the battery is pretty much dead. I find I had the problem the most when I was charging it every second I had. Now I leave the phone for a couple of days (or how ever long it takes the battery to get down nice and low) before I charge it again and again I haven't seen the problem crop up.
     
  9. uchi

    uchi Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    158
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    158
    2
    36
    the only issue with that is that i go to bed and the battery is below 40%. i use my phone at work all the time and i dont really have much of an option to plug it in at work. so i just plug her in every night. ill see what happens tomorrow, this morning it seemed fine
     
  10. uchi

    uchi Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    158
    Joined:
    Jun 14, 2010

    Jun 14, 2010
    158
    2
    36
    i killed it last night on purpose. well the phone actually shut itself off at 2%. plugged it in to charge, and it was only at 94% by morning, yet the last 2 nights it made it all the way to 100%
     
  11. tase25

    tase25 Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    102
    Joined:
    Mar 2, 2010

    Mar 2, 2010
    102
    4
    36
    I am having the same issue. Goes to 90% only. So annoying...

    I would root this if they could figure out the whole camera issue.
     

Share This Page

Loading...