1. Are you ready for the Galaxy S20? Here is everything we know so far!

Battery drain mystery caused by native Internet app randomly starting

Discussion in 'Android Apps & Games' started by brent22, Jul 18, 2013.

  1. brent22

    brent22 Lurker
    Thread Starter

    I have a Galaxy S III that has worked great for 6 months. Suddenly battery started draining like crazy. It would be dead in about 6 hours with no use.

    I did some troubleshooting on my own and with the help of Watchdog Lite, I discovered an interesting thing:

    What was happening was that the native Internet browser was suddenly launching (on its own) and moving data through the phone. I can
     

    Advertisement

  2. zuben el genub

    zuben el genub Extreme Android User

    Samsung had trouble with Doubletwist doing that for TMO phones. Complaints in TMO forum when that happened. Seems the SGS4G had the problem.

    Since it just started after 6 months, was your phone updated?

    If you have a 3, can't you disable the browser and install another? There's plenty of good ones. Everyone here has used most and there should be plenty of good reviews.
     
  3. brent22

    brent22 Lurker
    Thread Starter

    First, yes, this issue did come along "about" the same time as the last Android update (I'm now using 4.1.2). I think it's related, but not necessarily the primary cause. I suspect a third party app is actually making the call on the Internet app and streaming the data.

    I actually use Chrome and always have. So, I would be HAPPY to completely uninstall the native Internet app -- if I could. But you can't. Which is why I have to manually "force close" it every time it starts up. But it does not stay closed, and therein lies the problem.
     
  4. zuben el genub

    zuben el genub Extreme Android User

    Any new services on your phone since update? Your carrier could have requested custom update or new service from Samsung. Try a Verizon forum and check the qvetching. I use TMO and the minute someone gets throttled there's about 100 posts in a TMO forum complaining. I'd assume Verizon users gripe, too.

    I had Chrome on my Nexus 4 and disabled it through settings. Same with the Nexus S which was a Samsung. I disabled browser on Acer A500 wifi tablet and replaced with my choice. The phones are rooted, the tablet not.

    You would probably have to root to get rid of it.
     
  5. Petrah

    Petrah Psychotic Female

    Brent...

    Go into your phone settings and tap on Data Usage. Scroll down and see if you see the trouble browser on the list. If so, tap it. At the bottom should be an option to restrict background data.

    See if that helps.

    I've tried to search for info on this PopupuiReceiver thing, but I can find nothing except others asking about it (and not getting any answers). :(
     
  6. brent22

    brent22 Lurker
    Thread Starter

    I've been on the phone with Verizon tech support and they are as stumped as I am. I'm sure there's some relationship between either the latest Android update or a third party app that is calling the Internet app, but no one is sure yet.

    I think you may be right that rooting my phone may be my only option, although I'd prefer to find the legit problem. Verizon is still working with me. They've been great actually.
     
  7. brent22

    brent22 Lurker
    Thread Starter

    The Internet app is not listed as one of the "users" of data. I think it would show up if I was actually launching the Internet BROWSER, but all of this is happening in the background, which is maybe why it doesn't show up on the Data Usage list.

    I now don't think this is related to PopupuiReceiver. Still searching for answers.
     
Loading...

Share This Page

Loading...