1. Download our Official Android App: Forums for Android!

Support Battery Info.

Discussion in 'Android Devices' started by clicker, Jul 5, 2010.

  1. clicker

    clicker Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    31
    2
    16
    Im posting this thread to help some guys out there to judge Spica's Battery.

    Games: Drains Very Fast
    Games + WiFi: Faster!
    Music: Half of what Games did
    Camera: Drains VERY slowly (and thats awesome)
    Web Browsing: Drains a little less than Music
    GPS: Drains Slowly


    Pls. post your opinions, and what you experienced. Thanks
     

    Advertisement

    Thomassie likes this.
  2. jipo

    jipo Lurker
    Rank:
    None
    Points:
    6
    Posts:
    6
    Joined:
    Jul 6, 2010

    Jul 6, 2010
    6
    1
    6
    Mine,battery ends in 24hours with 5hours..edge connection 2hours web browsing :mad:
     
  3. Saneo

    Saneo Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    2
    0
    5
  4. Thomassie

    Thomassie Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jul 16, 2010

    Jul 16, 2010
    4
    0
    5
    I thought GPS drained a lot of power ? Thanks!
     
  5. marjan1

    marjan1 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    17
    Joined:
    Jul 18, 2010

    Jul 18, 2010
    17
    0
    15
    My experience is that GPS drains Spica's battery VERY fast.

    Simple test is that when battery is drained very fast back cover of Spica gets hot.
     
  6. clicker

    clicker Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    31
    Joined:
    Jun 22, 2010

    Jun 22, 2010
    31
    2
    16
    I dont know, but its just fine when I use GPS, and the battery does not get hot...but it does get hot when I charge it :(
     
  7. marjan1

    marjan1 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    17
    Joined:
    Jul 18, 2010

    Jul 18, 2010
    17
    0
    15
    That's weird. Mine doesn't get hot when i charge it. I have 2.1 JCE firmware.
     

Share This Page

Loading...