1. Check out our companion app, Forums for Android! Download from Google Play

Support Battery question mark?!?!?!!?

Discussion in 'Android Devices' started by Nick888, Nov 23, 2011.

  1. Nick888

    Nick888 Active Member
    Thread Starter
    16

    May 2, 2011
    25
    1
    16
    i recently turned my phone on while it was plugged in and all i see is a battery with a giant question mark. i tried pulling the battery and i cant find a solution. can anyone help?!
     

    Advertisement

  2. MusicIsTheKey

    MusicIsTheKey Member
    6

    Sep 28, 2011
    7
    2
    6
    On the Verizon website, they asked the same question and one guy suggested:

    "The battery contacts on the phone may be impaired in some way. Check the four copper contacts on the phone for debris, and press them down 3 or 4 times, replace the battery in to the phone and power on. Once fully powered on, try charging again to ensure that it's working."
     
    TheGuitarBoss likes this.
  3. Member MusicIstheKey gave you a great answer. I'd expand it just slightly to take a pencil erasure and rub it gently but firmly on the contacts of the battery itself. A bit of corrosion there will cause issues such as you describe.
     
    TheGuitarBoss likes this.
  4. jsteeleh

    jsteeleh New Member
    15

    Feb 19, 2016
    1
    0
    15
    Male
    I joined just to say MusicIsTheKey's answer saved me from unnecessarily replacing the battery. I took an old gift card and cut a small sliver that could clean around the terminal port, and pulled up a lump of dust bunnyish stuff.

    Conclusion: Dont leave your chargers on the ground, I think it started to collect, and every time I put it in my phone it just deposited all the crud. Works fine now, thanks so much dude.
     

Share This Page

Loading...