1. Check out our companion app, Forums for Android! Download from Google Play

Battery use; Android OS / Android System

Discussion in 'Android Devices' started by francismi, Oct 25, 2010.

  1. francismi

    francismi New Member
    Thread Starter
    5

    Oct 25, 2010
    4
    0
    5
    Hi,

    I have a big problem with my nexus one phone. The battery life of my phone is very bad (only 12 hours, with NO (app) USE! (only text messaging!))
    I think the problem is that when I check "Battery Use", the "Android OS" is getting 70% (and more, up to 93%!) of my battery use...
    What can I do? I've seen other topics with this problem, but there always is a special app that's the problem. I've reseted my phone several times, so no new apps installed, and I still have the problem...

    But sometimes, "Android OS" isn't running in the Battery Use, only the "Android System"... But once Android OS has started, it climbs up to 70-80-90%...

    Thanks!
     

    Advertisement

  2. kgeissler

    kgeissler Well-Known Member
    43

    Apr 28, 2010
    200
    32
    43
    Rowlett, TX
    Are you running your N1 stock or do you have a custom ROM?
     
  3. shttw

    shttw Active Member
    36

    Sep 15, 2010
    36
    2
    36
    Weird, mine is always the screen which hits around 75% (making photons is expensive) OS seems to use about 3% (which is slightly less than the live wallpaper).
     
  4. macprv

    macprv Well-Known Member
    43

    Mar 16, 2010
    337
    47
    43
  5. francismi

    francismi New Member
    Thread Starter
    5

    Oct 25, 2010
    4
    0
    5
    The weird thing is that I've done already 2 resets, and the problem stays, so with no new apps installed...
    I have the normal 2.2.1 version.
     
  6. macprv

    macprv Well-Known Member
    43

    Mar 16, 2010
    337
    47
    43
    did u do it the way he mentions? or just the factory reset from the menu's settings?
     
  7. francismi

    francismi New Member
    Thread Starter
    5

    Oct 25, 2010
    4
    0
    5
    I've did it the way mentioned, power+vol down+home, and again; the problem stays...
     
  8. Rusty

    Rusty Well-Known Member
    143

    Jan 21, 2010
    1,635
    192
    143
    Pompey, UK
    Thing is, it's a %age of use, so if you are doing nothing with the phone, then the OS (which is always running, of course) will always have a high number.

    Anyways, onto the more advanced stuff, dial *#*#4636#*#* and goto Battery history.

    Have a look at the 'Running' % figure. It shouldn't be all that high (mine is currently at 12% for instance), if it is high, change the top drop down box from 'Other usage' to 'Partial wake usage' and see what's stopping the phone from sleeping.

    Ps. The default setting in there is 'since last unplugged' so if it's just come off charge/usb you might want to pick one of the other options.
     
  9. locus

    locus Well-Known Member
    16

    Mar 19, 2010
    61
    4
    16
    EHS Coordinator
    Toronto
    Do the *#*#4636#*#* go into phone information scrol down to Set preferred Network type and select GSM Auto (PRL). It improved my battery
     
  10. francismi

    francismi New Member
    Thread Starter
    5

    Oct 25, 2010
    4
    0
    5
    The only special thing I can see is that in the CPU usage "init" is very very much more than others...
    But what is "init"?
     
Tags:

Share This Page

Loading...