1. Are you ready for the Galaxy S20? Here is everything we know so far!

Battery Weaker Since Upgrading to 2.2

Discussion in 'Android Devices' started by l-money, Aug 7, 2010.

  1. l-money

    l-money Newbie
    Thread Starter

    I updated my phone 2 days ago and like all the changes. Everything is good except my battery. Before the upgrade I was fine with my battery. Everything was good. Since I upgraded to 2.2 my battery has been horrible. Just horrible. I thought this was supposed to improve battery life. Is this just a glitch or something? Someone told me that some people were having problems and there should be a change within 3 or 4 days to fix the problem. Is this correct or is my phone the only one that got worse battery life since the upgrade?

  2. ThatNewAndroidGuy

    ThatNewAndroidGuy Android Enthusiast

    You're probably another one with their Evo's not sleeping. Check the Up Time vs Awake Time in settings.

  3. Oh you can say that again is becoming a nuisance now for me.
  4. l-money

    l-money Newbie
    Thread Starter

    If I check that then what do I do?
  5. ekang

    ekang Member

    I-money, to check your up time and awake time go to settings-about phone-battery and you'll see it there. If the two times are close to one another, say 15 hrs and 17 hrs, your phone is not sleeping. Right now my awake time is 127 hrs to 31 hrs up time.

    If the two times are similar, an app is not allowing your phone to sleep so its draining battery all the time. Check and make sure you're not having your phone sync everything constantly like emails, Facebook, Twitter, etc. Double check even if you had the sync turned off when you had 2.1.

    It takes time and basically going thru all your apps and either signing out of them (google talk), or adjusting sync times. The first few days I did notice more battery drain with froyo, but after some adjustments, its all back to normal. Good luck
  6. novox77

    novox77 Leeeroy Jennnkinnns!

    There's more to it than the awake time issue. I'm seeing this overnight as well. I have setCPU throttling down to 245mhz when screen is off. Overnight, my phone is not "awake," and previously on 2.1, the battery drain was about 4%. Now it's 25%. Battery usage says it's all cell standby and phone idle, just like before. I'm in the same location with same reception levels. I've checked all my "power saving" settings; nothing has changed. Still trying to figure out what's causing the extra drain.

    I'm tempted to blame it on the new radio.

    my awake time was 1 hour. up time was 10 hours (since i went to bed).
  7. brushrop03

    brushrop03 Android Enthusiast

    write down your Up/Awake Time. turn the screen off for 10mins or so. Power the screen back up. The up time should be 10mins ahead of the Awake time. if not then you have issues
  8. sagedil

    sagedil Android Expert

    Hard reset. This topic has been thrashed to death. THAT is the answer. Deal with it. Do it. Will fix this problem like it has fixed everyone who has done it.

    Kinda point of forum you know. People post answers for a reason. Maybe try reading them.
    heavychevy likes this.
  9. ekang

    ekang Member

    Have you recently dl'ed any new apps? a crappy developed app can drain your battery or one that requires other apps or programs to run it. Check your background data too.
  10. l-money

    l-money Newbie
    Thread Starter

    I do sync all my emails and contacts and things like that. That's how I like it. I had it like that before the upgade and I didn't have any battery issues. Now since the upgrade it's a problem. I didn't change anything. All I did was upgrade and now my battery sucks. And I did check my up time and awake time and they are very close to each other, but if i had it like that before the upgrade then it shouldn't be a problem now.
  11. brushrop03

    brushrop03 Android Enthusiast

    Check the Talk App. Make sure it doesn't automatically connect.

    I've only had the Evo for about 3 weeks, but I havent noticed any difference between my battery now and before the update. Still get about the same 10-14hrs.

  12. Not the answer. It did nothing for me except having to spend a whole day resetting everything back on to my handset.
  13. novox77

    novox77 Leeeroy Jennnkinnns!

    agreed. I built 2.2 from a factory wipe and it didn't help.
  14. novox77

    novox77 Leeeroy Jennnkinnns!

    Here's why I think there's a problem with the radio. Take a look at these two battery history charts. The first one was my optimized 2.1 system:


    Note from roughly 12am to 8am, my sleeping hours, the battery drain was pretty much nonexistent. This is with mobile, wifi, and GPS all on.

    Now look at last night:

    I was asleep from around 2am to 8am, and the battery drained about 20%. No CPU usage, and all the same radios on. Phone was in the same place next to my bed. Awake time is correct. I have all my battery-saving settings in place like before. Also notice that from around 8pm to 12am, I didn't use my phone, screen was off, and the battery drained a lot.

    My battery use says it's all from cell standby and phone idle, just like always. So the problem HAS to be with the radio image. Radio doesn't use CPU but is a big drain on the battery. Since my charts show no CPU usage, I have to say that the 2.2 radio is doing something inefficiently.

    I've been monitoring these charts almost every day for a month, so I know what my normal baseline is, and the 2.2 radio is definitely a big culprit to my battery issue. Next step for me is to check my setCPU to see if it's really working. I got the updated version, and I have a perflock-disabled kernel....
  15. ekang

    ekang Member

    I-money...I don't know if you use Facebook but since 2.2, FB has been having some issues for a few people. I would check your settings, and sign out (someone help me here, I have no idea what good this will do) and make sure you SIGN OUT of apps like Talk. Double check to see if things like Stocks and whatever else you don't use aren't in sync mode.

    If nothin works, you might want to dl system panel from the Market and see exactly what apps are running and which one shouldn't be running all the time. Or, turn off background data, 3g, WiFi (basically airplane mode) and see if the battery lasts longer. From there start to narrow it down till you find exactly what is causing your phone to stay awake for so long.
  16. l-money

    l-money Newbie
    Thread Starter

    Thanks for the help. I'll see what is going on. I do use facebook a lot though.
  17. ekang

    ekang Member

    Also, if I were you, I would just remove the Facebook app completely. It seems many are having your problem bc they updated their FB app. Try removing it and see if that's the app that's been giving u trouble

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page