1. Are you ready for the Galaxy S20? Here is everything we know so far!

Battery won't charge past 75%?

Discussion in 'Android Devices' started by cherylinspace, Sep 2, 2011.

  1. cherylinspace

    cherylinspace Lurker
    Thread Starter

    Hi, I am having a problem with my Samsung Mesmerize. I've had this phone since late spring/early summer. I've taken really good care of it (never gotten it wet or dropped it or anything) and I still have and use the original cable that came with the phone to charge it. My battery life used to suck, but I downloaded the Gingerbread update earlier this week and now it rocks. The only issue I have been having is that since I did the update, my phone will no longer charge past 75%-80%. I am wondering what could be causing this? Is anyone else having this issue? I can't get to a U.S. Cellular store until next week. Not sure if they will be able to help me. Thanks in advance for any info anyone may have!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. 2acclaim

    2acclaim Well-Known Member

    are you wall plugging it or USB charging it?

    In either case it sounds like it's not the factory charger. I bought some cheapo's online and the charger won't fully charge the battery so i just use it as a usb charger no problem.
     
  3. LaTuFu

    LaTuFu Android Expert

    Another thing to think about, USCC has free battery exchange. Swap it out, and see if you have the same error after that.
     
    Country_Gravy likes this.
  4. matt88si

    matt88si Android Enthusiast

    As hard as it is to believe, LaTuFu is right. USCC does offer free battery replacement at any store. Just walk in, tell them you need a new battery for your phone, exchange, replace, and walk out. No questions or information asked. :D
     
    Country_Gravy likes this.
  5. cherylinspace

    cherylinspace Lurker
    Thread Starter

    I am wall charging it with the charger I got when I bought the phone. Maybe I should try replacing that?

    I did battery swap and am still not getting it to charge completely, so it is definitely not the battery.

    Thanks!
     
  6. matt88si

    matt88si Android Enthusiast

    Have you tried reattaching the charger after it notified you of a full charge? Or have you tried charging the phone while it was off?
     
  7. LaTuFu

    LaTuFu Android Expert

    Try downloading an app called zdbox. Run that utility and see if it is giving you the same 75% number for your battery level.
     
  8. shortride

    shortride Well-Known Member

Loading...

Share This Page

Loading...