1. Download our Official Android App: Forums for Android!

Tips Before you buy: Check the Android version!

Discussion in 'TV & Video' started by Andrew Cole, Jul 14, 2016.

  1. Andrew Cole

    Andrew Cole Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    108
    Posts:
    463
    Joined:
    Jun 12, 2016

    Jun 12, 2016
    463
    158
    108
    Male
    If you're planning to buy one of the fancy Android TV boxes in the near future and using the device to install KODI for your streaming needs, then listen up...

    Make sure the box that you buy has AT LEAST Android 5.1 (Lollipop) pre-installed.

    Version 17 of KODI (July 2016) won't install on older TV boxes running 4.4 (Kit Kat).

    If you aren't that bothered about upgrading to the latest version of the KODI software then it won't matter...
    ...but some of the new improvements in the new version may affect you.

    The most significant being the ability to stream better quality live feeds.

    Upgrading to a newer version of Android on an existing box is not recommended... and usually not even possible on most boxes.
    These boxes aren't very receptive when it comes to tinkering about with updates and customizations, etc.

    So, you might want to keep this in mind before you order that fancy new gizmo...
     

    Advertisement

    #1 Andrew Cole, Jul 14, 2016
    Last edited: Jul 14, 2016
    mikedt likes this.

Share This Page

Loading...