1. Are you ready for the Galaxy S20? Here is everything we know so far!

Bell Mobility and GPS (read if a bell user please)

Discussion in 'Android Devices' started by ct2020, Aug 14, 2010.

  1. ct2020

    ct2020 Well-Known Member
    Thread Starter

    My saga with GPS continues. I have the 'place me in random places or not get signal at all' problem. Previously I had e-mail bell and they said I would have to call Tech Support. I finally got around to doing that (I hate calling big companies) and they inform me that I need GPS in my service plan from them... This seemed really odd to me so I poked around there site and the only GPS Service offered was for GPS Navigation. As far as I can tell that is a Bell branded app available for most of there phones. Nonetheless I was told that without paying $10 a month I couldn't get GPS to work.

    So, I would like to ask anyone else using Bell (especially anyone who's GPS actually works) if they have to pay for the GPS option.

  2. xoxid

    xoxid Newbie

    I got this app bundled with my phone free for 3 month when I bought it. The GPS was not working. In fact, it never worked, and it currently don't work. I live in Canada/quebec, with bell, and it detect me in the US. Amazing.
    ct2020 likes this.
  3. DaSchmarotzer

    DaSchmarotzer Blame it on me

    I live in Qu
    ct2020 likes this.
  4. nicholas

    nicholas Newbie

    Hi i have the same problem but I'm not on bell I'm on Telenor Serbia my gps never worked so i send it to repair because there wasn't a single sattelite on the radar .And they said the gps is working you just need maps.I said well i have google maps the gps should work whit them.Them:No it's not gonna work whit google maps.Me:Why it works on evrey other android phone, and the phone can't find a single sattelite.Them:You need maps.I just walked away, they don't know anything about android phones.But any way i installed IGO an NDrive the gps still isn't working.I also flashed every baseband version there is.I don't know what to do.(My operator doesn't offer a maps package )
  5. pedror

    pedror Lurker

    Under Settings then Security & Location, confirm that you have Enable GPS satellites checked. You can also have "Use wireless networks" to use wifi/mobile to estimate a location.

    The GPS receiver in the phone does not depend on mobile data or voice plans, it is independent just like an automotive GPS. It helps to have an unobstructed view of the sky to ensure reception of the satellite signals.

    Try the free "GPS Status" app, which will provide detailed information on the satellite signals seen by your phone. I am in Canada with Bell on the Galaxy and GPS seems to perform much better under the Galaxo ROM than what was delivered on the phone.
  6. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Thanks pedror. I have done everything mentioned in your post to no avail. I just want to make absolute sure that I am correct in my thinking that my GPS working should have nothing to do with Bell. I believe I am right on that thought now. Thanks all.
  7. weasel

    weasel Android Enthusiast

    Well, I am not paying anything extra. One thing that has helped some, was going to Google Maps kept starting me off in Quebec until it got a lock on. Wipe and give it a go, can't hurt and the the new galaxo works very well.
  8. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Using Galaxo and still have the problem.
  9. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Here is an e-mail I just sent bell. I'll update with their response.

    "Hello, I have e-mailed in the past with this problem and was directed to call Tech Support, which I did. They, I am sorry to say, did not know what they are talking about. The GPS on my phone doesn't work properly. Sometimes it will place me in Quebec (I am in Alberta), other times it won't find my location at all even though I am in a clear field, and on few occasions, it places me in the city I am in, but a few kilometers away. Pretty useless... The person I talked to in Tech Support told me because I wasn't paying for GPS from Bell it wouldn't work. The problem is anything I can see from bell is for a GPS Nav app. I have an APP (Google Maps) to use. GPS is built into my phone. There is no reason why this shouldn't work. In deed I have confirmation from other Bell users with THE SAME PHONE that GPS works and they don't pay for your $10/month GPS Feature. Between the lack of GPS, the smoke and mirrors of tech support and the fact that my phone is stuck on Android OS 1.5 while the rest of the world moves onto 1.6, 2.0, 2.1, 2.2 and the new features each of these introduce, I am very upset. I hope we can find a mutually acceptable solution."
  10. GreenApple

    GreenApple Lurker

    I have a GT-i7500L from Bell that I unlocked and use on Rogers. I do not have a data plan and I use the GPS with Google Maps. If I load the map over Wi-Fi and add our destination, the GPS works with no other apps or data. I only have to turn on the GPS using "Switcher". This is my first smart phone and I would pay for a GPS app but I have not had time to try some from the market.

    I know this is not related but does anyone have any tips for accessing Wi-Fi at Safeway or Starbucks? I can connect and open the browser to accept their terms but I am not able to get through the next step of the process which seems to be a re-direct of the browser. If there is another post on this topic, please let me know.
  11. DaSchmarotzer

    DaSchmarotzer Blame it on me


    for the starbucks question, I have no idea what the solution might be, I never even tried.

    But I might be able to help you with your GPS issue, as I don't have a data plan either. You can download the free application Andnav 2 and download maps from different sources to the phone, so you can use it on the go (no need to find a wifi hotspot). You won't be able to search or get a route without wifi though (I'm not sure), and downloading maps can be complicated.

    I also heard of the paid application Sygic (they have a website), which I think downloads the maps onto your phone so there's no need for data. I never tried it though, so you might want to verify what I'm saying.
  12. ct2020

    ct2020 Well-Known Member
    Thread Starter

    And here is Bell's Response...

    ood day Mr. Whitney,

    Thank you for using Bell Mobility's Internet Client Care service.

    My name is Chrissy (Emp# 6037143).

    I have read your message and upon review of your handset, I wish to
    inform you that the Samsung Galaxy comes standard with the following

    - Gmail,
    - YouTube,
    - Google Search, and
    - Google Maps.

    However, if you would like to have GPS on your account, you will have to
    subscribe to the $10 per month GPS NAV feature. I invite you to reply
    to this message should you wish to add this feature to your account.

    I would like to thank you, Mr. Whitney, for using our website and for
    choosing Bell Mobility as your wireless communications provider.

    Additional information can be found at www.bell.ca and we can be
    contacted again at www.bell.ca/contactus.

    Kind regards,

    Chrissy (Emp# 6037143)
    Bell Mobility - Online Client Care
  13. informale

    informale Android Enthusiast

    I suppose they want to sell you some sort of subscription-based navigation software of their own.
  14. ct2020

    ct2020 Well-Known Member
    Thread Starter

    That's my guess as well. I sent them another e-mail asking them to tell me exactly what this feature does.
  15. weasel

    weasel Android Enthusiast

    I call bullshit. They don't know what they are talking about. Like I said before,I and many others are using GPs witout any extra monthly fees. Hell even my wife's Omnia II does Google Maps just fine.

    IIRC, the GPS Nav they are talking about was for turn by turn directions on your phone. You might want to explain to them its kind of impossible to use Google Maps. It is clear that you have a problem with your GPS sensor.

    Try and download a few GPS apps. GPS test or something of the sort will help. At least you will know how many satellites and what signal strength you have.
  16. ct2020

    ct2020 Well-Known Member
    Thread Starter

    I have GPS Test and it can find one satellite and doesn't get a location from it.

    It seems pointless to tell Bell this, as they will just say it'll find more satellites by some magic when I give then ten more bucks a month. /sigh
  17. velnaykkar

    velnaykkar Newbie

    For those having issues with GPS loc:
    Settings >> Location >> "Use Wireless Networks" <== is this checked?
  18. ct2020

    ct2020 Well-Known Member
    Thread Starter

    I`ve tested it both ways.
  19. odnaan

    odnaan Lurker

    ct2020... Same problem with me... My GPS doesnt work.
  20. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Have you contacted Bell? What do they say?
  21. dri001

    dri001 Member

    I have a Galaxy GTI7500L as well. The GPS was very bad when I first got the phone. After I upgraded to 1.6 using DaSchmarotzer"s tutorial, I had no problem with it. Android 1.6 came with the updated Google Maps and Navigation included. They work great.
  22. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Are you with Bell Mobility

    Do you pay extra for it
  23. dri001

    dri001 Member

    Yes, I am with Bell Mobility. No I don't pay for it. The updated Google Map application and the Navigation app are part of the 1.6 update. They use your data allowance. There is no charge otherwise.
    ct2020 likes this.
  24. dri001

    dri001 Member

    If you are on Bell Mobility you should be able to access the Wi-Fi through a network called "Bell Hotspot". I was in Starbucks and I latched onto it without a user id or password.
  25. ct2020

    ct2020 Well-Known Member
    Thread Starter

    Thanks for the info. Still waiting on a reply from bell.

Share This Page