1. Are you ready for the Galaxy S20? Here is everything we know so far!

Black Screen of Death?

Discussion in 'Android Devices' started by omgitslian, Aug 8, 2012.

  1. omgitslian

    omgitslian Lurker
    Thread Starter

    Hi, guys. I'm a noob, so please be kind. Harsh words will be met with witty comebacks. :p
    Anywho you're probably going to hate me because I don't actually remember what I did to my poor phone to break it in the first place (it was months ago) and I've only just now become ambitious enough to try and salvage it. I tried to root it and originally had gotten it stuck booting only into recovery (I had CWM at the time). Yesterday I had the bright idea to have another go and now have it stuck in the black screen of death. It plays the cheesy startup sound when you turn it on, but the screen stays black as night. If I boot it into recovery I still can't see anything, but I can access the phone with adb.

    The problem I'm stuck at is "adb shell" gives me "-exec '/system/bin/sh' failed: no such file or directory (2) -

    One solution I tried is "adb push i:\sh /system/bin" which gives "failed to copy 'i:\sh' to '/system/bin': permission denied"

    A solution to that which I've tried is "adb remount" which yields "remount failed: operation not permitted"

    "adb root" works perfectly well, and before the black screen of death "adb shell" worked but su didn't work (don't ask me how, I'm sorry but I don't remember the exact error message).

    I'm sure my procedure is all very circular as I actually know next to nothing about any of this, but all the solutions in these threads seem to bank on yet another capability my phone is currently lacking. Any help would be greatly appreciated.
    Oh, as a side note I managed to wrangle COT onto my phone and I think that's the recovery it's still running now.

    Thanks in advance for all your help.

    1. Download the Forums for Android™ app!


  2. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus

    If your phone's rooted then adb shell should give you a # output. This is normal and expected. If after typing in adb shell it doesn't give you a # output then the next step would be to type in su.

    If you just type su first it won't do anything because you haven't gained access to the root of the phone (adb shell is giving you temp root access, that's why their called shell commands).
    If you you have a terminal emulator on the phone you can requests root access thru the Superuser app by typing in su. The Superuser app manages superuser request by app's installed on the phone

    Makes sense?

    If you have a Hitachi screen and drivers some recovery's and versions of recovery's can cause the black screen. Some of the older ROM's can cause the problem you described as well. Not wiping and formatting everything necessary for a complete clean of all residual data will cause the new ROM to be corrupted.
    With that said:
    1. What screen version do you have (any phone purchased after November of 2011 will probably have the Hitachi screen, any Phone purchased after July 2011 has a 65% chance of having an Hitachi screen)? We are going to assume by the problems you are having that you have a Hitachi screen and drivers.
    2. What recovery, and what version of that recovery did you install?
    3. What ROM and what version or build# of it did you install?
    4. What all did you wipe and format before trying to install the ROM?
    5. What did you use to root your phone?
    6. With your phone plugged into the computer and USB debugging selected on your phone, what output do you get when you type in: adb devices from a command prompt?
  3. omgitslian

    omgitslian Lurker
    Thread Starter

    Sorry, I think I follow you and I'm pretty sure none of that is working for me. Previously, when the phone was stuck in the recovery loop typing 'adb shell' yielded the expected '#.' Now it's giving me the nonsense in my original post. Any subsequent commands I've tried have given me error messages. I'm fairly sure I have the Hitachi screen but I'm not sure how to verify that. The phone is currently running COT recovery (which I got from here: [RECOVERY] Cannibal Open Touch v2.0.1 (latest update: 08/08/2012) - Android Forums at AndroidCentral.com).
    As for #3, 4, and 5 I really don't know. I'm sorry, I know that's completely unhelpful, but I don't remember what I used. I followed a guide, so if I find it I'll post it pronto. Finally, is there a way to enable USB debugging with the phone all comatose, such as it were? When I plug in the phone initially, "adb devices" yields a blank list unless I boot the phone into recovery. Then I get "recovery."
    Thank you so much for your prompt response and specificity. I'm really at a loss, here.
  4. sammyz

    sammyz LG Whiz Kid

    You posted your MEID.......erase it asap.....it's next to where you put A000000000000 recovery.
    omgitslian likes this.
  5. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus

    My bad: Should have specified not to post your actual MEID Hex code.
    You Don't have a ROM installed. The one you tried to install must have been corrupted. That is why it will only see you phone in the recovery partition and not in the system partition.
    As far as not being able to see your recovery screen to be able to flash a Good ROM go here: http://androidforums.com/optimus-v-all-things-root/419080-truth-about-rom-manager.html It has a workaround that should allow you to see your recovery menu on your PC's screen and still work the hard buttons on your phone to allow you to flash a good ROM onto your Phone. From there you can flash a Good recovery from a terminal emulator on the phone.

    Just make sure you put the ROM.zp and the Recovery.img on the root of the sd card (not in a folder, just near the bottom of the list of folders)
    Then read thru this: http://androidforums.com/optimu...eset-your-rooted-phone-3.html#post3263770 don't worry about the title, it's just where my tutorial on how to flash a recovery and ROM happen to take shape.
    omgitslian likes this.
  6. omgitslian

    omgitslian Lurker
    Thread Starter

    Whoops. Thanks.
  7. omgitslian

    omgitslian Lurker
    Thread Starter

    Alrighty, thanks. I'm going to give it a shot tonight.
  8. omgitslian

    omgitslian Lurker
    Thread Starter

    You, sir, should be running this country with your level of sheer genius. I must admit I didn't follow your guide exactly, but with some finagling I managed to wrestle the phone back into working order. Thank you so much!
    AndyOpie150 likes this.
  9. cammykool

    cammykool Android Expert

LG Optimus V Forum

Features and specs are not yet known.

Release Date

Share This Page