1. Are you ready for the Galaxy S20? Here is everything we know so far!

Blank SD Card !

Discussion in 'Android Devices' started by Gunnar, Apr 2, 2010.

  1. Gunnar

    Gunnar Newbie
    Thread Starter

    Hi Folks,

    My Desire has suddenly stopped recognizing my 4GB SD Card today. Just says it's blank and needs formatting !
    When I try to access the card via my PC it just wants to format it...but when I bring up the format window the PC only sees 30MB and a format of FAT. The Properties show it formatted as RAW.
    The Error Notification I get is:
    Blank SD Card - SD Card blank or has unsupported filesystem.
    Is my card fried or is there a way out of this ?



  2. Karolis

    Karolis Member

    So are you concerned about its contents at this point or do you want to just sort out the card? If you don't care about the data, just go ahead and format it. If it doesn't show the full size, then you might want to go into windows disk manager and delete any partitions / unallocated space.
  3. memorito

    memorito Lurker

    Same thing just happened on my G1. I was messing with
    Mobile Defense Beta. I don't really think it is related though.
    I would definitely like advice on how to save the data. Thanks.
  4. Gunnar

    Gunnar Newbie
    Thread Starter

    Hi, I just tried to re-format using Disk Management and also HP Disk Tools...No joy. The SD Card shows as 31MB and no format type. Unable to re-format. Looks like the card is fried 'already' ! :(
    Is there anything else I should check before reporting it to T-Mobile ?

  5. Karolis

    Karolis Member

    Well, I'm using linux, so I'd try to DD it (wipe the card on a very low level), but I'm not sure how to do that on Windows.

    If you think T-Mobile can replace it - you should definitely just get in touch with them.

    Regarding data restoration, PhotoRec (not only for photos) is a great piece of software. But it doesn't preserve folder structure or file names, which might be a problem in most cases (unless you only need to pull photos/videos).
  6. Ten10

    Ten10 Member

  7. Gunnar

    Gunnar Newbie
    Thread Starter

    Thanks Guys.
    I've tried those to no avail...The Panasonic s/w says the car is write protected. Sounds like it's had it.
    I''ve bought a 2GB card and it has been recognised without issues, so hopefully it's just a duff card. I have a 16GB card already winging it's way to me, and will use that one once I'm sure.
  8. Lukehluke

    Lukehluke Android Expert

    It happened to me and I removed it and put it back in and it worked fine.
  9. memorito

    memorito Lurker

    I was able to format it. But before I did, I used PhotoRec. It is a pain to go through the 30,000 files it generates to try and salvage stuff, but I wasn't about to pay 100-150 bucks for something that might or might not preserve filenames and structure. I needed to clean out my phone anyway. :p I wish there was something out there that could repair the partitions that disappeared. PhotoRec pulled the fiels off, but TestDisk coudn't find the partitions. I thought that was weird.
  10. byron_hinson

    byron_hinson Member

    I unmounted mine then rebooted the desire - worked fine after. Didn't even realise it wasn't working properly until the backup came up and said so!
  11. memorito

    memorito Lurker

    It sometimes loses the path somehow, or just needs to be reseated. Then other times the card is corrupted and needs some elbow grease to get past it.
  12. serenity

    serenity Newbie

    Mine has just done the exact same thing apart from the fact that my pc doesnt even recognise it and the phone wont format it.. any ideas
  13. Gunnar

    Gunnar Newbie
    Thread Starter

    Hi, I tried all the suggested ideas and no luck for me. I can't even low level format it because it says it's write protected ! I'm wondering if there was a dodgy batch of 4GB cards.
    Anyway, I got myself a cheapy 2GB card from Tesco, but will be putting in a 16GB card once I'm happy it's not the phone doing the corrupting.
  14. memorito

    memorito Lurker

    Well if the card isn't working at all. Try and do a file recover with TestDisk/PhotoRec or something like that. It's free. I couldn't find anything affordable that had more functionality. It is a command line type interface, so don't freak out. Beyond saving your files, if your phone won't format it, I would avoid trying to rescue the card any further. And a not to EVERYONE, in my experience, DO NOT put your memory card into a reader and connect that to your computer. Use only the "Mount USB" function available from the phone. In this and other phones, as well as cameras, I have always had troubles after trying to use the cards on a reader directly. Hope that all helps and makes sense...

    ...anyone want to invite me to go snorkeling? I might say yes...
    sos4ever, Ebbe and Gunnar like this.
  15. stepheny

    stepheny Lurker

  16. ninjahamster

    ninjahamster Lurker

    I got my Desire a couple of weeks ago and have just had the same problem.

    My 4Gb card that I got with it, spontaniously stopped being recognised by my phone, it gives me the option to format it, but when I click nothing happens.

    I presume it's screwed as the unmount option is greyed out.

    Sounds like there's a dodgy batch of SD cards out there.

    I'll be popping back to CPW tomorrow to see if I can get a replacement.

    luckily I didn't have much saved on there, just a couple of pics.
  17. nx1977

    nx1977 Android Expert

    See what HTC have to say.
  18. PygmyArr

    PygmyArr Newbie

    i've just had this problem occcur, phoned virgin moblie CS up, they said to take it into shop where i bought it as it was still under 28day warrantee.

    lady in the shop said she hasnt got spare replacements in, but as soon as she gets a sd card of 4gb or bigger, she'll call to let me know and i can collect it.

    kinda hoping it is th eduff SD card batch and not something wrong with the handset (ie over volting memcard when phones on charge and card is being accessed).
  19. kave2

    kave2 Lurker

    Happend to me today. I was using my old 8 GB card from HTC Touch HD. So i put back 4GB card which came with phone. I hope it's not phone related problem.
  20. NZtechfreak

    NZtechfreak Android Expert

    I've had on a couple of occasions instances where the phone suddenly doesn't seem to be able to detect my microSD card. Removing the card, reinserting, rebooting fixed it.

    Since then I've had this solution - install SDmount Widget, when the error happens unmount the card in settings, click SDmount Widget, all fixed.
    Vip8888 likes this.
  21. kozjegyzo

    kozjegyzo Newbie


    I've had my Desire for a few weeks now and this same problem came up twice now. A simple reboot fixed the issue, but it's still annoying that this happens at all. I have a 4GB card in my phone that came in the box. I really hope this is a card issue...
  22. brad-short

    brad-short Well-Known Member

    Dont think it is an SD card issue. I've used two cards now, one supplied and one bought, and i get the same issues. It could well be a piece of software or OS. . .we just dont know.
  23. brad-short

    brad-short Well-Known Member

    Well my card became corrput again lat night. Unmounting and mounting had no effect. This was a 16gb card which was formatted fat32. I had recently transferred some mp4 vids to it. Came to watch them later and boom, corrput. Lost everything.

    Have put in the 4gb card that came with the phone to see what happens with this one.

    Annoying issue this . .
  24. bedrock

    bedrock Lurker

    I have just had exactly the same happen to me :(

    Did you find any resolution, or does the sdcard need to go inthe bin? I'm going to try calling T-Mobile and see what they have to say.
  25. brad-short

    brad-short Well-Known Member

    look around guys, deffo summat up here. SD cards being unrecognised and in some cases corrupted. Usually its connected with connecting to a pc or something or transferring of files. . .

    BTW, further to my earlier post, my 4gb has been in 24 hrs and has not failed and that includes me moving files to it from the pc.

Share This Page