1. Download our Official Android App: Forums for Android!

Support BLU Studio X+ MT6582 - Lots of ROM Flashing Issues

Discussion in 'Android Help' started by Android Question, Jul 7, 2016.

  1. Android Question

    Thread Starter
    Rank:
    None
    Posts:
    0
    Joined:

    Hey guys, I'm having issues flashing ROMs I ported to my Studio X+ D770. I'll try to keep it short:

    Porting ROMs for this device is going to be difficult, since there are no other custom ROMs out there that I know of for the D770 Studio X+. As far as I'm aware, I'm the first to try, and let me just say that I have zero prior knowledge to this process, aside from everything I've tried trying to get this to work. I'm well experienced with ROM flashing on other android devices, but this is my first MediaTek device, as well as my first ROM Porting experience.

    When I'm running the 3.4.67 kernel firmware and I try to flash a Resurrection Remix ROM I've ported (I've tried multiple recoveries-TWRP 2.8.2.0, Carliv 2.4.7, CWM 6, all with the same outcome), I get a status 7 error:

    "ApplyParsedPerms: lsetfilecon of /system/lost+found to u:eek:bject_r:system_file:s0 failed: Operation not supported on transport endpoint set_metadata_recursive: some changes failed"

    Looking at the updater-script, it appears the issue resides in this line:

    "set_metadata_recursive("/system", "uid", 0, "gid", 0, "dmode", 0755, "fmode", 0644, "capabilities", "0x0", "selabel", "u:eek:bject_r:system_file:s0");"

    Research makes me believe this is an SELinux issue, as seemingly my recovery is incompatible with SELinux (?), and others who had the problem were told to update their recovery to a newer TWRP. For me, even when I try to flash on TWRP 2.8.2.0, which is the newest recovery I can find in an automated tool, it gives the same exact problem.

    Looking at the ROM page, it says to set SELinux to Permissive and then reboot. I assume this means set it to permissive before flashing, as this notice was put early on in the article. I've supposedly set SELinux to Permissive following these instructions, but even after doing so I get the same issue. Also, keep in mind, when I go to Settings>About Phone on my stock KitKat 4.4.2 firmware, nowhere in that menu does it list an SELinux status, like I've seen on other Android devices running the same firmware. Apparently it's there, but it's also not there...

    I recently tried a patch that allows one to bypass set_metadata_xxx problems, involving the replacement of the update-binary file. When I replace it and repack the ZIP file, it gives me this:

    "mount() expects 4 args, got 5"

    And it exits with a Status 7 error, just like the other one does.

    Now NOT ONLY have I tried flashing a 3.4.67 kernel ROM, I've tried flashing a 3.10.X kernel ROM as well, which gives me its own unique set of problems. I've tried porting this Temasek CM12.1 3.10.X Kernel build to my device, but that doesn't flash either. I don't get the same errors as before though. Unfortunately I can't remember what errors I got, I'll have to reflash stock Lollipop firmware on my phone and try to reflash the ROM so I can post what it said.

    I'm talking about my 3.4.67 and 3.10.X kernel issues because I don't really care what kernel-ROM I can get flashed on this thing, I just want to make SOME SORT OF ROM. Any help would be appreciated.
     

    Advertisement

  2. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #9
    Points:
    2,138
    Posts:
    22,282
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,282
    23,583
    2,138
    Male
    space alien ;)
    Indy
    Hello and welcome to our AndroidForums :).

    I'm not at all familiar with your device or the ROM(s) you're trying to flash.

    I do have the following thoughts (in no particular order) for you:

    1. Your initial error seems nearly identical to what is reported in there XDA post:


    Code (Text):
    1. ApplyParsedPerms: lsetfilecon of /system/lost+found to u:object_r:system_file:s0 failed: Operation not supported on transport endpoint
    2. script aborted: set_metadata_recursive: some changes failed
    3. set_metadata_recursive: some changes failed
    4. E:Error in /sdcard/cm-12-20141130-UNOFFICIAL-DOGE2-ace.zip
    5. (Status 7)
    6. Installation aborted.


    Ignore the name of the ROM being flashed, I'm just trying to verify this looks like the same issue you're seeing (or at least initially reporting).

    The reason for the issue seems to be the recovery being used (i.e., not the lsetfilecon (trying to change the SE Linux symbolic link file context) command.

    2. I don't really think (I could be wrong, though) that changing/setting the SE Linux mode for the flashing operation (i.e., in custom recovery) won't / doesn't make any difference in/for flashing (I'm guessing the mode is already set to permissive in the custom recovery's kernel).

    3. Our good friend @Jaay Dogg might be able to offer some advice, so hopefully this ping will find him (@Jaay Dogg, I never heard back about the subforum you asked me to ask about :( )

    Cheers and best of luck!
     
    El Presidente likes this.

Share This Page

Loading...