1. Are you ready for the Galaxy S20? Here is everything we know so far!

Bluetooth audio stutter... but only with Cambridge Audio Minx Go

Discussion in 'Android Devices' started by Missing_Link, Dec 29, 2013.

  1. Missing_Link

    Missing_Link Member
    Thread Starter

    Hi all,

    All my Bluetooth devices work great with my new Minx Go Bluetooth speaker....except my Nexus 7. It all pairs fine and plays ok, except that any interaction with the touchscreen results in terrible c.one-second or so audible stutter coming through the Minx speaker (sounds like a vocoder in slow motion!).

    This happens regardless of music app used (I have bubbleupnp, meridian, and Google music). Doesn't matter if wifi is on or off, or even if I am streaming from the nexus or my NAS server.

    The Minx works fine with my laptop, HTC Desire (Gen 1), Huawei Ascend P6. My BT headphones and keyboard work fine.

    I have a Nexus 7 2012 running Kitkat.

    This is the first time I've had any BT issues...

    Any ideas please anyone?

    Thanks in advance.

    1. Download the Forums for Android™ app!


  2. John Bean

    John Bean Happy Wanderer

    This sort of BT incompatibility can be very annoying, especially since both devices are probably to blame in some minor way that wouldn't normally be heard but together conspires to make the combination unusable. I've had this in the past (not with a N7 though) and there's often not a lot you can do about it.

    In the case of the N7 it's possible that wifi is interfering with the BT connection, it's worth trying it with wifi disabled and see if that makes a difference. If it is a wifi related problem then changing the channel(s) the router is using may help.
    Missing_Link likes this.
  3. mmoy

    mmoy Well-Known Member

    I use a couple of JayBirds with my Nexus 7 and haven't had any problems with BlueTooth issues listening to music or watching movies with them. There can be a lot of CPU noise on Android which may be causing performance issues. I use the Battery display to see what's running and, if there's something using up excessive CPU, then I try to find the cause as this will use up battery. I've found various Apps or background processes in the past that used up way more CPU cycles than they should have and have disabled or replaced them.
    Missing_Link likes this.
  4. Missing_Link

    Missing_Link Member
    Thread Starter

    Thanks guys for your help and advice.

    I tried turning off the wifi again, and it still had no effect on the BT issue. I will look at the apps running in the background and I'll also try starting the tablet in safe mode to see if that turns up anything. I'll report back my findings in case it helps someone else.

    Happy New Year both :)
  5. Missing_Link

    Missing_Link Member
    Thread Starter

    Hi guys, I FOUND THE ANSWER!

    As it turns out, it's really simple:

    You need to turn off the Touch Sounds and Screen Lock Sounds - then it works fine, regardless of what apps are running (changing the sound to "none" does not work).

    If you have keyboard click sound enabled (I never do) then logically it follows that this would probably also need doing.

    I rebooted into Safe Mode first to ensure minimum apps were running and then killed some to see if there were any issues there, but I'm pleased to say there were not.

    What a great start to the New Year!
    John Bean likes this.
  6. John Bean

    John Bean Happy Wanderer

    Well done, I'd never have thought to try that :)
    Missing_Link likes this.

Share This Page