1. Download our Official Android App: Forums for Android!

Support Bluetooth

Discussion in 'Android Devices' started by Zlanu, Sep 21, 2010.

  1. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    Just got my Xperia X10 today. Really psyched about it. So far so good but just one problem...the bluetooth doesn't seem to work?

    It'll say "turning on..." and then it'll stop immediately without going any further. Anyone got any suggestions?
     

    Advertisement

  2. MrWomble

    MrWomble Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    774
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    774
    51
    78
    Newcastle - UK
    Well the wifes advice wasn't much use - she said leave it switched off and don't use it - hope she doesn't give customers that advice (she works in mobile phone retail store)

    personally update the phone to the newest software on Sony Ericsson Update Service then try again
     
  3. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    It says my phone is on the latest software as well, should I just reinstall?

    I don't really use bluetooth at all so it doesn't really bother me but I will eventually use it one day. Lol.

    Also, a WiFi problem too. I'll have no problem connecting to it the first time, but once it goes into sleep mode, if I try to connect WiFi again, it'll say "Unable to connect" and then that's that. I click again, same thing. I have to switch off and switch on my phone...then it'll work.

    All software issues?
     
  4. MrWomble

    MrWomble Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    774
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    774
    51
    78
    Newcastle - UK
    have had similar issues with wifi - all lately

    dropping into the settings and selecting wireless controls - shows an error connecting, if i click on WiFi settings and click on networ it usually corrects - Bluetooth no idea - if on latest software advise a repair or reinstall - but use backup and restore first to ensure any contacts etc are saved

    doing mine now as last update gone screwy
     
    Zlanu likes this.
  5. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    Well, I'll give it a shot...see what happens.

    My WiFi is even screwier, I can't even do that. I have to turn off then turn on the phone. Lol. Reminds me of my Ipod Touch. >_>
     
  6. MrWomble

    MrWomble Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    774
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    774
    51
    78
    Newcastle - UK
    well hopefully it will work - nothing more annoying than a unexplained disconnect
     
  7. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    Strange...seems like after a few shut downs and boot ups...everything seems to work fine. Had it going through Sony Ericsson update...and then in step 2...it started working. Lol. We'll see how long this lasts.
     
  8. MrWomble

    MrWomble Android Expert
    Rank:
    None
    Points:
    78
    Posts:
    774
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    774
    51
    78
    Newcastle - UK
    well there we have it - wierd but sorted - glad to have helped
     
  9. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    Hmmm. Now it's doing it again. Lulz. Hoping it will be fixed by 2.1 update.

    EDIT: After googling a bit, I noticed that lot of people had this problem...and that they relate it to hardware damage but there are some instances when an update fixed it. Don't know whether I should return my phone or wait for 2.1 and then see what happens from there.
     
  10. Zlanu

    Zlanu Member
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    64
    Joined:
    Jul 14, 2010

    Jul 14, 2010
    64
    0
    15
    So, anyways, little update on this issue.

    Ran service tests after the phone sleeps to test WiFi and bluetooth...it just crashes the phone. Lol.

    Anyone experience this before?
     

Share This Page

Loading...