1. Download our Official Android App: Forums for Android!

Root Boost Mobile - Can't send MMS, but I can receive them

Discussion in 'Android Devices' started by jwwpua, May 10, 2012.

  1. jwwpua

    jwwpua Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 18, 2012

    Apr 18, 2012
    18
    2
    16
    I'm running the latest CTMOD (3.6) for Boost. Everything works great except I can't send MMS. I've also tried the Boost Mobile MMS fix. I tried the .ZIP flash provided in the thread and also manual steps to view/change the MMSC. I've factory reset, wiped cache, etc. Nothing fixes it. Btw, I have already tried Marky Beats V2 for Boost as well, but same problem.

    I have installed Go SMS and tried entering the custom settings in there too, but it's a no-go. Does anyone have suggestions/fixes?

    Thanks!

    P.S. I was able to send/receive MMS on my Marquee stock. Seems to be a CM7 issue, but I'm new to all this. I've tried 3 different CM7 ROMs and have the same issue with them all. It would be awesome if someone finds a fix!
     

    Advertisement

  2. Bloodawn

    Bloodawn Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,176
    Joined:
    Jul 16, 2011

    Jul 16, 2011
    2,176
    2,619
    313
    Male
    Illinois
    The mms fix for ctmod won't work without a factory wipe.

    If it still doesn't work its probably a problem with boost and not your phone.
     
  3. jwwpua

    jwwpua Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 18, 2012

    Apr 18, 2012
    18
    2
    16
    Ok, so I need to factory reset, then flash CTMOD, then reset/wipe, reboot, flash boost fix, reboot, wipe cache, flash kernel?

    Sorry, just wanna make sure I do it right!
     
  4. Bloodawn

    Bloodawn Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,176
    Joined:
    Jul 16, 2011

    Jul 16, 2011
    2,176
    2,619
    313
    Male
    Illinois
    If your flashing the rom too you don't need to do any wipes, its only if you already have ctmod installed and you just want to flash the fix that you need to do a factory wipe.

    If you want to install both the rom and the fix you can do it like this:

    Install ctmod
    Go to advanced in cwm and reboot back to recovery
    Install the fix
    Boot up all the way, boot back to cwm
    Install a kernel of your choice
    And you should be good
     
  5. jwwpua

    jwwpua Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 18, 2012

    Apr 18, 2012
    18
    2
    16
    Ok thanks, I'll give it a shot tonight. Would it be okay to backup/restore SMS messages with Titanium, or would that screw up the patch?

    And will I still need to use Go SMS after using this fix (to send MMS)?
     
  6. Bloodawn

    Bloodawn Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    2,176
    Joined:
    Jul 16, 2011

    Jul 16, 2011
    2,176
    2,619
    313
    Male
    Illinois
    Titanium may cause problems if it backs up the app data. I usually use SMS backup+ which backs up your sms/mms and call log to your gmail but there is other apps that do it too.

    No, you won't need go SMS unless you actually want it.
     
  7. Bionic Chronic

    Bionic Chronic Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    645
    Joined:
    Feb 18, 2012

    Feb 18, 2012
    645
    158
    93
    Michigan
    I normally just uncheck the MMS and MMS Settings apps from TiBU that way they don't overwrite the patch. That should work right?
     
  8. fhekking

    fhekking Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 29, 2012

    Jun 29, 2012
    1
    0
    5
    I just wanted to chime in here and say I have the same issues. My MMS works whenever it wants to (like my ex). I tried everything on these posts and nothing works. I dont want to do a factory reset since I have too much data to lose. But, I did discover that if I send an MMS pic message via "messages" it wont go through. But, if I send the same MMS picture message via "mail" no problem. Which tells me that the issue is on the Verizon network end of things and no matter what you do to the phone.. its just luck to get it working... Am I wrong?
     
  9. wetbiker7

    wetbiker7 Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    7,475
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    7,475
    3,426
    333
    Male
    USN Vet. / Certified Drug and Alcohol Abuse Counse
    So-Cal

    Ya know, I've had an issue with my friends that are on Verizon. When I was using Handcent, I couldn't receive MMS. I had to switch to ChompsSMS and it works fine now. You might want to give that app a shot.

    I know it sounds weird to try a different app but I'm telling you the truth. I've got Handcent setup correctly and it just will not download MMS. Chomps... set up the same way.. will work. Weird as hell man. :thinking:

    EDIT:

    One more thing.... you don't have to worry about losing anything when doing a factory reset. With the right apps, you can save everything to your PC and with Google.
     
  10. kevindroid

    kevindroid Android Expert
    Rank:
     #189
    Points:
    113
    Posts:
    935
    Joined:
    Oct 7, 2010

    Oct 7, 2010
    935
    232
    113
    Male
    electrician
    baltimore
    if chomps doesnt work for you maybe go sms pro will work. you can even delete the stock app and go to important tips and check stock app deleted. ireally hope this helps
     
Tags:

Share This Page

Loading...