1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Boost Mobile] Enable init.d support

Discussion in 'Android Devices' started by Darkrum, May 8, 2012.

  1. Darkrum

    Darkrum Newbie
    Thread Starter

    Spiyder likes this.
  2. dirtyredz

    dirtyredz Well-Known Member

    Don't think this will work because it will get written over@ boot. Though would be cool to get a tutorial on how to add init.d support to my stock rooted b08 ROM. Anyone?
  3. shinru2004

    shinru2004 Android Expert
    Recognized Developer

    The method listed on XDA does work, Shinjitsu Rom versions 1.0 - 1.5b use that method. So i know it works, the other method is to enable it through the init.rc file in the kernel ramdisk. So you would have to tear apart the kernel make the edits then recompile to a boot.img then flash. make sure when you rebuild you use the exact ramdisk that came with the kernel. B08 ramdisk's aren't compatible with B08c and vice versa.
  4. dirtyredz

    dirtyredz Well-Known Member

    I tried the XDA method above with no luck. Anyone who can get this to work successfully please post a tutorial.
  5. shinru2004

    shinru2004 Android Expert
    Recognized Developer

    Check the permissions set on the file and make sure permissions for init.d are correct the phone should be able to read write and execute the scripts
    dirtyredz likes this.
  6. dirtyredz

    dirtyredz Well-Known Member

    OK got it working. Downloaded the zip from the XDA thread unzipped it in root explorer, placed all included files where they were supposed to go( flashing the zip in CWM didn't work for me) next I manually set all the permissions as per the screenshot in the XDA thread, then I created the " install-recovery.sh " and set permissions the same, rebooted ran supercharger script via script manager, rebooted again and ran supercharger again to verify it stuck & it did. so yes adding init.d support to my stock b08 ROM worked.
  7. shinru2004

    shinru2004 Android Expert
    Recognized Developer

    After the last line hit enter, thats what they mean by leave a blank line
    dirtyredz likes this.
  8. dirtyredz

    dirtyredz Well-Known Member

    Now aside from v6 supercharger what scripts do you recommended?
  9. aenoch

    aenoch Android Enthusiast

    What is this
  10. shinru2004

    shinru2004 Android Expert
    Recognized Developer

    Loopy smoothness, DBDefrag, Zipalign, and Read Ahead

    all of which can be found in version 1.5b of my rom :)
  11. mholloway

    mholloway Android Expert

    Are you doing this on phone or pc? I would like to learn, maybe,never mind stupid question
  12. mholloway

    mholloway Android Expert

    I created file install - recovery. Sh long press on it no option to open in text editor? What did I do wrong?
  13. dirtyredz

    dirtyredz Well-Known Member

    Are you rooted & using root explorer?
  14. shinru2004

    shinru2004 Android Expert
    Recognized Developer

    What app are you using? Root explorer has that option, IDK if any other root browsers do.

    Just make the file and put it in the root of your SD Card then open a cmd prompt

    adb shell
    cp /sdcard/install-recovery.sh /system/etc/
    chmod 0755 /system/etc/install-recovery.sh

    that will give the file read/write permissions for root :p
  15. dirtyredz

    dirtyredz Well-Known Member

    Mind posting links to the scripts? Maybe start an init.d script thread. I have loopy and v6 running and think I found the zipalign script( darky's) but can't locate the others.
  16. mholloway

    mholloway Android Expert

    Yes, next to the file is picture of a file not script. After I make file do izip it maybe? Then open to edit
  17. dirtyredz

    dirtyredz Well-Known Member

    Here use this one


    Just remember to set permissions
  18. mholloway

    mholloway Android Expert

  19. mholloway

    mholloway Android Expert

    Ok did everything right, but in data /local /tmp there's no file?
  20. dirtyredz

    dirtyredz Well-Known Member

    Did you flash the XDA zip via CWM? Because I couldn't get it to work that way so I unzipped the XDA zip and placed all the files into my system folders manually and manually set their permissions then rebooted and it worked. I think there is an issue with flashing it in CWM.

    When I have time I'll write up a good tutorial and post all the needed files.
  21. mholloway

    mholloway Android Expert

    No not to sure about that i know how to move files, I don't see init. d file, and iam running hroarks oc kernel, would that matter? Lol if you think of me as an idiot, gave me exact directions i would be very grateful
  22. Darkrum

    Darkrum Newbie
    Thread Starter

    That's what i ended up doing after i gave up on the stupid flash method after realizing it wasn't putting the files but i still couldn't get it to run but when i ran the install-recovery.sh manually it worked so then i decided to look in the init.arthur.rc and found a script it calls during boot called init.goldfish.sh and put the busybox run-parts in there and that worked but i see that you got it to work with just the install-recovery.sh can you elaborate on what you did to it that got it to work?
  23. Can verify this works. I am on bo8c and horaks no oc .7 kernel. Ran v6 script and it sticks on reboot. Gonna try somemore scripts to check further but looks good to me!!

    Sent from my N860 using Tapatalk 2 Beta-5
  24. dirtyredz

    dirtyredz Well-Known Member

    This is how I installed init.d support on my stock rooted w/CWM b08 ROM

    (I attempted to do this via the CWM method HERE with no luck, so wrote this tutorial to show how to do it manually)


    1. Stock b08 ROM (may work on others I don't know for sure)
    2. Root
    3. Busybox
    4. CMW Recovery
    5. Root Explorer


    1. Download the "add_init.d_support.zip"
    and unzip it in a new folder on your SD card.

    2. If you don't already have busybox installed, Reboot into Clockwork Mod Recovery, select install zip from sdcard, locate and install "busybox_v1.19.4-wraithdu-CWM_flashable_install.zip" and reboot once its finished.

    3. Download and install Script Manager


    (won't really need it for this tutorial, but will come in handy when your ready to add scripts like the ones found here; [Script][Guide] V6 Supercharger by Zeppelinrox or how to kill lags in ROMs! U9RC7! - xda-developers & Here; [Script]Loopy Smoothness Tweak[TUT] - xda-developers)



    4. With Root Explorer copy the "install-recovery.sh" and "init.d" folder to /system/etc, and set permissions (also once copied and permissions set open init.d folder and set "99test" permissions)

    5. copy "sysinit" to system/bin and set permissions

    6. copy "run-parts" to system/xbin and set permissions

    7. Reboot and test some scripts, (carefully, backups are a good thing) I'd go with V6 SuperCharger first. :)
    mholloway and Spiyder like this.
  25. mholloway

    mholloway Android Expert

    I think you're download for the script is bad, won't download, I did everything you posted except i made the install - recovery.sh file and it still won't work any ideas? Thank you, well the file that says done isn't there but I installed loopysmoothness and supercharger. What else can i try

ZTE Warp (N860) Forum

The ZTE Warp (N860) release date was October 2011. Features and Specs include a 4.3" inch screen, 5MP camera, 512GB RAM, Snapdragon S2 processor, and 1600mAh battery.

October 2011
Release Date

Share This Page