1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root [Boost Mobile] [MOD] Universal Boost APN fix for D2LTE builds [MOD]

Discussion in 'Android Devices' started by MopedRyder, Apr 9, 2014.

  1. rickpcb

    rickpcb Android Enthusiast

    @MopedRyder - Thanks for the fix. I was looking at yours and Junkie's work to try to write this myself LOL ya beat me to it. I was still trying to figure out everything that needed to be changed. I'm learning from your work, so thanks again! But here's the real question... with unified builds, why do we need this? Is there a reason ROM developers don't include Boost, Virgin, etc? Is it because CM doesn't acknowledge these carriers? Sure would be nice to flash without needing a fix after. Any guidance or ideas would be appreciated. :hmmmm2:
     

    Advertisement

  2. Skinnyjeans21

    Skinnyjeans21 Android Expert

    Perhaps because Boost and Virgin are companies under Sprint anyways?
     
    MopedRyder and steelyus1 like this.
  3. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter

    ^Bingo

    When you install a ROM at first boot it tries to activate the phone. Virgin / Boost phones should skip this step. It will try to activate as a Sprint phone on there network...no workie.

    In order to get LTE / MMS to work you need to identify yourself as Boost / Virgin on the Sprint network...without correct settings and at times credentials. The APN settings actually is a combo of both Sprint and Virgin/Boost settings.

    Also (without checking in an while) I don't believe any (CM / AOKP) has the the correct APN settings and such for sub carriers. Some ROM developers (major) didn't even support some major carriers, so sub carriers are an after thought. See AOKP - we never had an AOKP that wasn't ported...till the new LTE builds. If we couldn't get a big ROM developer like AOKP to build a Sprint ROM, asking for a Boost/ Virgin is not even in the ball park.

    As for checking my work to learn - - fantastic! Use it and adapt it. Maybe make a custom rom adapter, to adjust other things. My fix is not advanced at all, just 'sed' and 'if....then' statements. The work was finding the right APN combos...that was about a hundred+ flashes and hours of work...lol
     
    unotlikeme, bob-st, smith058 and 4 others like this.
  4. bob-st

    bob-st Android Enthusiast

    MopedRyder, I Just flashed the LiquidSmooth 2014-04-13 nightly. This is my first S3 AOSP rom and initially had no mobile data. Did some more reading and flashed your Universal Boost APN fix for D2LTE builds.

    Now I have lte/4G and mms. Life is good.

    I do have one suggestion for the OP. When I first read the op I stupidly clicked on the link to your Virgin Mobile fix and flashed it. Then I re-read the op and flashed the one for Boost Mobile. My suggestion is to take out the VM link in case there are other people as stupid as me :flute:
     
  5. jmfoxx75

    jmfoxx75 Newbie

    I just flashed this. GREAT WORK!
     
  6. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter

    Sounds like a plan
     
    bob-st likes this.
  7. rickpcb

    rickpcb Android Enthusiast

    Just a little bump to help new users find this thread...
     
    steelyus1 likes this.
  8. HiiiPowers

    HiiiPowers Android Enthusiast

    Yep let's bring this back and keep it on top
     
  9. Endofear

    Endofear Newbie

    So I just finished flashing CM and the APN fix as well. But whenever I try, data is not showing up. It flashes for a second, and then it goes away. What are the APN settings for Boost? Is my phone just done, if so, how should I go back?

    EDIT: The APNs are showing up, but I'm still not getting any data, solution?
     
  10. Kreatur3

    Kreatur3 Android Enthusiast

    Do you get data on a TW rom? Might restore TW and update profile. I've flashed the newest cm11 and had data fine.
     
  11. Endofear

    Endofear Newbie

    A TW? Sorry, I'm not familiar?

    EDIT: Sorry for the inconvenience, I reinstalled CM but at first, I didn't install the fix, and then I rebooted and installed the fix, the 3G works, but it is a bit low in strength. But as I am in my house with Wi-Fi, is it normal for that?
     
  12. wetbiker7

    wetbiker7 Extreme Android User

    TW = TouchWiz.
     
    smith058 likes this.
  13. DeathToFlesh

    DeathToFlesh Member

    I want to confirm this working on Moto G XT1031 running C-Rom using hangouts ONLY, not working on stock msging app. Errors with, "APN settings not configured on this device" (or something like that.)
     
  14. Zenwafer

    Zenwafer Well-Known Member

    Just wanted to say that I have successfully sent MMS on my Boost Mobile Moto G thanks to this gem of a zip file. I did however edit a few values or replace a file in order to get it properly on 3g - But it sends & receives perfectly

    Edit: Running CM nightly 20140615 on the G
     
    steelyus1 likes this.
  15. Shockazulu1

    Shockazulu1 Lurker

    Thank you for this quick and easy zip. My phone was fixed with this. I searched everywhere and tried many things. But this is the only thing that worked. It is so easy. Download and it should go right into your download folder. Next reboot into recovery. Select flash file. Select this one. Reboot and its done. Thank you thank you thank you thank you thank you. I will keep this file for the next time I lose my MMS.
     
  16. wetbiker7

    wetbiker7 Extreme Android User

    No doubt about it. Mopedryder definitely hooked us up when he made this for us. :thumbup: :D
     
  17. codezer0

    codezer0 Android Enthusiast

    If it weren't for this masterpiece, I would have never had the nerve to try an AOSP rom on my S3.

    Thank you, sir. :)
     
    MopedRyder likes this.
  18. wyelkins

    wyelkins Android Expert

    No Doubt! There are a lot of folks with other phones that don't have the freedom that we do to try out roms because they don't have this invaluable tool.

    I am not a fan of TouchWiz anymore so I am very grateful for the work that went into this beautiful zip.
     
    steelyus1 likes this.
  19. wetbiker7

    wetbiker7 Extreme Android User


    I agree with you 100%, Wy. This tool is invaluable.

    Speaking of ROMs, what are you running now?
     
  20. wyelkins

    wyelkins Android Expert

    LiquidSmooth. Got an update today that I have not installed yet.

    [​IMG]
     
  21. RoWilJr

    RoWilJr Well-Known Member

    Update if you like to play the numbers game (6/20=4.4.4)
     
    wyelkins likes this.
  22. Skinnyjeans21

    Skinnyjeans21 Android Expert

    Not working in liquid 4.4.4, well pic messaging and it thinks its sprint again. Data works fine though, I have LTE working smoothly.
     
  23. wetbiker7

    wetbiker7 Extreme Android User


    Try using Chompsms and manually set your APN from within the app. ;)
     
  24. cyrus441

    cyrus441 Lurker

    I have kitkat build 4.4.2 on my boost flashed galaxy Mega rooted with cwm its not a custom rom so what im asking is if i reflash rom with a cwm back up and then flash your fix would it work or does it have to be a custom rom. Sprint galaxy megas currently have no custom roms based on kitkat build 4.4.2. Also i have 3g working fine profiles 1 and 2 had to be manually setup but my phone wont HFA so updating profile/prl is not working, from reading this thread your fix should get that to work as hfa on my phone is being read as a sprint phone when it should be read as a boost one and will this work if the donor is only 3g although the mega is a 4g lte capable device.
     
  25. Skinnyjeans21

    Skinnyjeans21 Android Expert

    It seems to work fine on 4.4.4 Liquid and CM11 after reflashing a few times. After that I only have to flash once for ever 4.4.4 rom
     
Loading...

Share This Page

Loading...