1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root [Boost Mobile] [MOD] Universal Boost APN fix for D2LTE builds [MOD]

Discussion in 'Android Devices' started by MopedRyder, Apr 9, 2014.

  1. rickpcb

    rickpcb Android Enthusiast


    Wipe cache in recovery before flashing. You should only need to flash once. Per rom of course...
     

    Advertisement

  2. mydian

    mydian Android Expert

    It's worked fine for me in AOKP and CM11. First flash every time.
     
  3. Skinnyjeans21

    Skinnyjeans21 Android Expert

    I did full wipes every time and it took a couple of tries for me to get it to work. After that it went smoothly so I figure it must've been something unique to me giving me issues.
     
  4. rickpcb

    rickpcb Android Enthusiast

    Sounds like it bro. Glad it's working now.
    Maybe dalvik wasn't done rebuilding and it was over written... Eh. Who knows lol
     
  5. smith058

    smith058 Android Expert

    Just wated to say this fix works for Boost's S5 as well
    Thanks again!
     
    MopedRyder likes this.
  6. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter

    Im looking into this. The binary needs updating and I think I found something.

    On a fresh install try to install the ROM first...let it boot. You may not even get data connection, let it sit, then reboot recovery and flash the fix.

    See if that works
     
  7. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter

    Updated the OP. Changed to version R2. Only change is updating the update-binary in it. So version R1 have the same changes, you just wont get the warning on flashing with R2.

    Also I found that you may want to Flash your ROM then let it boot first before installing the LTE fix. I found it didnt 'take' until I flashed ROM (Gapps), rebooted recovery, flashed fix.
     
  8. wetbiker7

    wetbiker7 Extreme Android User

    Thanks MopedRyder. I'm sure I speak for the entire Boost section when I say we truly appreciate your work. :thumbup::)
     
    steelyus1 and smith058 like this.
  9. Kreatur3

    Kreatur3 Android Enthusiast

    The only time I've found this fix not working is with MIUI roms. No idea why. So I keep this one for everything else and the old fix for MIUI. :)
     
  10. zoolife

    zoolife Newbie

    Just wanted to say thanks it worked great.:)
     
  11. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter


    I could never get a MIUI ROM to even boot on my phone. Whish I could help.

    Point me to the one you tried and I give it a go please ;)
     
  12. Kreatur3

    Kreatur3 Android Enthusiast

    Were you also flashing the kernel they have posted to flash? If you flash that kernel it won't boot. There are two threads on xda for miui. I had no issues with the newest build on the older of the two. I'll try the newest build in the other thread and see if I can get it to boot up.

    This link is a MIUI build I know works. V 4.6.6. It's the one I usually use.

    https://www.androidfilehost.com/?fid=23501681358543969
     
  13. MopedRyder

    MopedRyder Android Enthusiast
    Thread Starter

    From my Virgin Mobile APN post:


    Nice!
     
    HiiiPowers likes this.
  14. wetbiker7

    wetbiker7 Extreme Android User

    Heck yeah! It took them long enough. LOL :D
     
  15. Yea I wiped flashed ROM rebooted flashed APN zip then let it sit for a 5+ mins still no data I wonder will the stock MMS every fixed Hangouts works fine
     
  16. wetbiker7

    wetbiker7 Extreme Android User

    If you are running a TouchWiz ROM, try updating the profile. That can restore data in many cases. If you are running an AOSP ROM like CM11 ,etc, try flashing back to a TouchWiz ROM, update the profile and then flash back to the AOSP ROM.

    Something else you might want to check. Did you flash the Sprint ND8 or the Boost NDC bootloader? The reason I ask is because you must be running a custom kernel for data to work if your baseband doesn't match your bootloader. You must be running a custom kernel to run the NDC baseband with the ND8 bootloader and vice versa (Boost bootloader with Sprint modem).

    Example:

    I flashed the Sprint ND8 bootloader which comes with the ND8 baseband (modem). I can update my profile and it enables data. Most of the time data is working after the ROM flash but occasionally a profile update is needed. Also, If I decide to flash the Boost NDC modem I must be running a custom kernel in order for data to work. Most all of custom ROMs have a custom kernel so flashing between modems is easy and data should work. If not, a profile update should definitely fix it.

    I hope this helps.
     
  17. I have d2lte & i can flash any other ROMS data is working when I flash Nameless ROM I don't have data
     
  18. wetbiker7

    wetbiker7 Extreme Android User

    Hmm, ok then. The issue has to be with the ROM then if you can run other d2lte ROMs and get data working. Sorry but if the APN fix isn't working I don't know what to tell you. The only thing I can recommend now is to check out the Nameless ROM thread or Google + page if they have one and inquire about the data issue there.

    Nameless is one of the few ROMs that I haven't tried. I may do a little research on it when I get a chance and see if I can find anything regarding the data issue. I'll let you know if I find a fix. I'll probably take a look at it tomorrow.
     
  19. ravollmer

    ravollmer Well-Known Member

    I also tried flashing nameless and had the same results. I tried it also with the apn fix with no luck .
     
  20. Thanks I went to back to 9/12 build data is working so what I'm doing is downloading nightly & weekly build to see which build had data stopped working in cause so far from 23-28 no data
     
  21. wetbiker7

    wetbiker7 Extreme Android User

    I just did some reading and users are reporting that the Nameless ROM does indeed have data issues. Some get no data while others can't get LTE.

    If it's an APN problem then this fix should take care of the issues. Looks like it may be a bug in the ROM itself.
     
    astonmartin260 likes this.
  22. Okay so from 9-14 & 28 there's no data
     
  23. no answer to the problem from what you found
     
  24. wetbiker7

    wetbiker7 Extreme Android User

    LOL. Nope. They don't even know what's causing the data issue over in the ROM's main thread. The developer is gonna have to find out what's causing it.

    Someone needs to give him a logcat. That would help him out a lot.
     
  25. feuertier

    feuertier Lurker

    I've been having issues with my phone for days, and I think this thread is related to my issue. I have a Galsxy S3 that was with Sprint, and I moved to Boost. I immediately noticed that my data was not working on Cyanogenmod 10.2.1. I flashed back to stock and stock recovery, and it worked, and I'm working up from there. I tried Cyanogenmod 10.0.0 and the appropriate gapps, simultaneously using TWRP, and data was not working again. I found this thread, and tried loading the Boost APN Fix, but to no avail; I still don't have data. Steps:

    1. Install Cyanogenmod and gapps
    2. Boot into Cyanogenmod; no data
    3. Boot into recovery, and load the Boost APN Fix R2
    4. Boot into Cyanogenmod; still no data

    I'm frustrated, but do not want to stay with stock. Any more thoughts on how I can debug this? I'm going to restore my 10.2.1 install, so I can look at the APNs (can't in 10.0.0), but I feel a bit stuck.
     
Loading...

Share This Page

Loading...