1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Boost Mobile] New PRL

Discussion in 'Android Devices' started by wyelkins, Oct 9, 2013.

  1. smith058

    smith058 Android Expert

    1. Download the Forums for Android™ app!


  2. kevindroid

    kevindroid Android Expert

    lm on the moar rom and prl write comes up with the code
  3. wetbiker7

    wetbiker7 Extreme Android User

    Not showing up for me guys. I'm following the instructions ##DATA#. This is what I see. And no, it's not under OTHER either.


    Here's the good thing. I'm almost positive I can write the prl using CDMA workshop like I did on my Prevail. :D

    Gonna give that a try tonight.
  4. smith058

    smith058 Android Expert

    Hamm don't know what to say... What ROM are you on?
  5. wetbiker7

    wetbiker7 Extreme Android User

    Bro, I tried it on Wicked Sensations and it didn't work so decided to flash my rooted stock backup. Same thing. I'm wondering if it's something about it being one of the newer phones?

    I need to ask Wy to test his and see what his does. He bought his a few weeks before I bought mine. May be one of the new serurity changes they made. Not sure. Still, I'm almost positive I can do it with CDMA workshop. Should be the same steps as with the Prevail.
  6. smith058

    smith058 Android Expert

    Mine is one of the new models... It works for me... If you flash MOAR does it show up?
  7. wetbiker7

    wetbiker7 Extreme Android User

    I just talked with Wy and he's running MOAR. He doesn't have the PRL Write option either.

    Edit: I've got a few more tricks up my sleeve though. :D
  8. smith058

    smith058 Android Expert

    Maybe one of the Roms y'all tried? Might have changed something?
    I deffenently have one of the newer phones with the added security...

    I hope you can figure it out... Stock kies odin maybe?
  9. smith058

    smith058 Android Expert

    Y'all doing it through View right? Not edit... I guess you've tried both ways
  10. smith058

    smith058 Android Expert

    Maybe you have to have the TEST.prl on internal SD first before the option is available... I don't know... Just throwing suggestions out
  11. wetbiker7

    wetbiker7 Extreme Android User

    Nope. I've got it in the root section of my internal. Thanks for your suggestion though. Hope you're feeling better too bro.
  12. smith058

    smith058 Android Expert

    This day I am
  13. Capn069

    Capn069 Well-Known Member

    In order for me to do a prl swap I had to use the scripts for AOSP to get in diag mode because for some reason my phone was being hard headed. I'm on the MD7 stock rooted rom for now and it worked flawlessly for me. I'm back on 31104 and my signal and speed is back to being great. I also don't have the write prl function in my hidden menu.
    smith058 and wetbiker7 like this.
  14. wetbiker7

    wetbiker7 Extreme Android User

    Excellent news. I tried DFS but tried it in download mode. I'll try the scripts or try to find the access code for our DIAG mode.

    Thanks for your help bro. :D
  15. iMaYG

    iMaYG Android Enthusiast

    where did you get that specific prl?
  16. wetbiker7

    wetbiker7 Extreme Android User

    I had to do some digging to find it. LOL

    31104.prl download. :D


    EDIT: Oh, I got it from CDMA Gurus.
    patsfann, smith058 and iMaYG like this.
  17. wetbiker7

    wetbiker7 Extreme Android User

    HE SHOOTS....... HE SCORES!!!!!!!!!

    I used the AOSP method with the GS3 scripts provided in the link while running Wicked Sensations. It worked on my 1st try! I'm now back on 31104 and signal is stronger and 3G is faster!

    Thanks for the kick in the butt Capn069 and getting me to follow ALL the steps in the TUT for AOSP even though I'm running TW. I assumed going into download mode would work and DFS would recognize my phone since CDMA recognizes it on a COM in that mode. NOT! I had to go through the whole process with scripts but it was well worth it. :D
    Thanks again bro!
  18. smith058

    smith058 Android Expert

    I would bet that one of the Roms you both downloaded (probably the one that had issues) changed the file that controls ##data#.... I have no clue though, but I would bet
  19. wetbiker7

    wetbiker7 Extreme Android User

    That's possible. So far 3 of us don't have that option (Me, Wy, and Capn069). I'm not sure what ROMs each of them have tried though. The only 1 that gave me trouble was Vanir.
  20. wetbiker7

    wetbiker7 Extreme Android User

    Look what I found! LMAO :D It's not new either. :eek:

    Look like the last Sprint update disabled the PRL Write function. Possibly some of the Boost phones have this update too? Dunno. Could be as Smith mentioned too. One of the Sprint ROMs we've flashed may have caused this.

    There's a zip fix in this thread but only for modems MA6,MA4, and MB1.

    [MOD][MA4/MA6/MB1] PRL Write Enabler & ##DEBUG# prompt removal - xda-developers

    Just wanted to post this because I thought it was interesting. Either way, whether it be flashing this zip or using the AOSP method, we have a way to change our PRLs . :)
    smith058 likes this.
  21. Capn069

    Capn069 Well-Known Member

    The scripts work just fine along with DFS. I got bored and started playing around with different prls and doing speed tests. So far for me the 31104 prl is the best. I think what screwed me, biker, and Wy is the baseband swap. I swapped to MD4 a month ago. Recently I switched to LJ7 because it gives a better signal but I think the damage was already done by MD4. Did any of you guys switch to MD4 as well and now lose the PRL write function?
  22. wetbiker7

    wetbiker7 Extreme Android User

    I flashed several ROMs that said MD4 but my baseband never changed according to my phone stats. It's always said PAMG2. I never flashed any of the baseband zips.

    Cool that we've got two ways to changed it now. The script is easy man. I've got the shortcuts enabled. Just tap, plug it in and crank up DFS. BAM! Instant prl change. Love it man. Easy as can be be. . :D
  23. wetbiker7

    wetbiker7 Extreme Android User

    Man, you guys aren't gonna believe this crap! LMAO!!!!!!

    I tried accessing PRL Write while on Wicked Sensations. It wasn't there so I had to use the AOSP method to change my PRL. Well, I flashed the MOAR ROM earlier today and finally got it all set up. Just out of curiosity I decided to try ##3424# and it gave me the CDMA MODEM and PDA options. I thought to myself, hmmmm that's cool. Then I thought, well....... if I can access those then I'm gonna try ##DATA# and see if the PRL Write option was there. Lo and behold, there it was right in front of me. PRL WRITE!! Son Of a Biscuit eater! :shot:

    I have no idea if it was the Wicked Sensations ROM, running the AOSP script that unlocked it or what happened but I now have the PRL Write option. Right now I'm sitting here shaking my head wondering WTH is up with that? :banghead:

    Definitely one of those things that make ya go Hmmmmm???:hmmmm2:

    EDIT: Tomorrow I'm going to find out for sure if it was Wicked Sensations that was blocking PRL write. I'm going to flash my TWRP backup of the ROM and see if I can access it. If I can't then I'll know it's the ROM. I would do it tonight but I am in some serious need of some sleep. Definitely gonna report back on this one.
    Capn069, wyelkins and smith058 like this.
  24. wetbiker7

    wetbiker7 Extreme Android User


    Wicked Sensations running the KToonsez kernel does not have the PRL Write option. It is either an issues with the ROM or kernel. It wasn't just a fluke.

    Sooooo. For those of you who choose to run the WS ROM, you will need to use the AOSP method to change your PRL. Either that or switch to MOAR and change it.;)
  25. PS4AndroidHacker

    PS4AndroidHacker Well-Known Member

    I may be a day late and a dollar short here but thought I may be able to help out. I found an app on the android market that may possibly be able to change your prl for you. Its called PRL Helper. Look it up man and good luck!!
    smith058 and wetbiker7 like this.

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date

Share This Page