1. Download our Official Android App: Forums for Android!

Root [Boost Mobile] OTA RootKeeper

Discussion in 'Android Devices' started by godraw, Jan 4, 2012.

  1. godraw

    godraw Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    73
    Posts:
    141
    Joined:
    Nov 24, 2011

    Nov 24, 2011
    141
    27
    73
    Male
    Retired Michigan Gravel Trains Driver
    S.W. Lower Michigan

    Advertisement

  2. freesunshine

    freesunshine Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    192
    Joined:
    Jul 5, 2011

    Jul 5, 2011
    192
    39
    43
    Male
    PortWetland, OR
  3. Frisco

    Frisco =Luceat Lux Vestra=
    Rank:
    None
    Points:
    1,343
    Posts:
    22,478
    Joined:
    Jan 19, 2010

    It has a feature which allows you to temporarily unroot (without removing any apps or su, etc) so that (some) OTAs will be accepted by the operating system.

    I've tested it only on Droid 3, Galaxy Tab 7" and X2. It worked fine for those OTA files, then allowed for simple re-rooting via a one click button. Very nice.

    But we need to hear from users of rooted ZTE Warps. ;)
     
  4. walpow

    walpow Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    106
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    106
    10
    38
    The good news:

    OTA Rootkeeper (by the way, it shows up under V for Voodoo in your apps list) successfully backed up my rooting and temporarily removed it before the OTA process. It then restored it after the OTA.

    The bad:

    The OTA update didn't work. It downloaded the update package (B06 to B08), rebooted, went into "arrow-coming-out-of-box-toward-android-guy" mode, and failed. It happened so fast (I tried several times) that I couldn't see exactly what was going on, but I did see some hex and "update aborted" or something similar.

    I'm wondering if it's doing a checksum on the existing firmware and, because I used Titanium Backup to "integrate updates of system apps into ROM," it failed. Unfortunately, there's no, uh, "disintegrate" option.

    I'd like to try the "storage card updates" option, but I don't know how to get the package and what folder to put it in. I'm not excited enough about updating to use the through-Windows method and reinstall all my apps afterward - especially because I have two Warps to deal with. (Yes, they are backed up to Dropbox.)

    Oh, and I updated the PRL and profile (whatever they are) and they seemed to work.
     
  5. freesunshine

    freesunshine Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    192
    Joined:
    Jul 5, 2011

    Jul 5, 2011
    192
    39
    43
    Male
    PortWetland, OR
    Same exact thing happen to me.
     
  6. walpow

    walpow Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    106
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    106
    10
    38
    freesunshine, did you happen to integrate any app updates with Titanium Backup? Because if you didn't, we can eliminate that as the cause of the failure. Thanks.
     
  7. freesunshine

    freesunshine Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    192
    Joined:
    Jul 5, 2011

    Jul 5, 2011
    192
    39
    43
    Male
    PortWetland, OR
    I don't understand what you mean by this? I did update Ti Backup to most current update, if that's what you mean.

    PS...I'm using free version of the Ti Backup.
     
  8. walpow

    walpow Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    106
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    106
    10
    38
    One of Titanium Backup's capabilities is to integrate updates of system apps into the system ROM. (I don't know if that's included in the free version.) If you're not familiar with it, I'm guessing you didn't do it, which would mean my doing so didn't cause the result we both saw.

    More guinea pigs are needed ...
     
  9. freesunshine

    freesunshine Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    192
    Joined:
    Jul 5, 2011

    Jul 5, 2011
    192
    39
    43
    Male
    PortWetland, OR
    Ok...I think I found the setting for integrate update (Integrate sys Dalvik into Rom...) and you're right, it's not included with the free version. And I'm guessing you have the donated version which means, integrating isn't the issue. Any ideas? :)
     
  10. walpow

    walpow Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    106
    Joined:
    Nov 23, 2011

    Nov 23, 2011
    106
    10
    38
    No ideas at the moment. I guess we'll have to wait and see what else people come up with. Going to B08 isn't a high priority at the moment.

    By the way, I tried it with my wife's phone too. With hers, I unrooted before activating it. Same result.
     

Share This Page

Loading...