1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root [Boost Mobile] [ROM][NDC][STOCK][4.4.2][KITKAT][ROOTED][ODEXED/DEODEXED]- Virgin Mobile/Boost Mobile

Discussion in 'Android Devices' started by jdsingle76, Jun 7, 2014.

  1. lit2n3on

    lit2n3on Newbie

    thanks, i appreciate the response :)
     

    Advertisement

    jdsingle76 likes this.
  2. Thanks for the assist jdsingle76! All your steps worked.
    Altho I have to say the Modem didn't work for me the first time I flash it. had to reboot again & flash it 1 more time. But in the end everything worked out!

    Thanks again!
     
    jdsingle76 likes this.
  3. joelv6

    joelv6 Newbie

    quick question guys so i rooted my gf phone and its still at 4.1.2. the only thing i change was updating the modem. so should change the modem to the original to the firmware and then update to kitkat and the root?
     
  4. jdsingle76

    jdsingle76 Android Enthusiast
    Thread Starter

    When you flash the kk tar, it updates the modem
     
  5. joex

    joex Member

    I have a quick question. I installed the kitkat boost tar and everything is good except the system updates don't work it say there busy so I am unable to updates prl or profile.
    I have reinstalled and its the same.

    Please advise and Thank you.
     
  6. Have you tried dialing ##72786# ?
     
    jdsingle76 likes this.
  7. j61101

    j61101 Well-Known Member

    Have you disabled anything? I had that issue when I used TB to freeze updates so that I wouldn't get a notification. I just had to re-enable it and it worked again.
     
  8. joex

    joex Member

    Thanks guys I went and installed the wicked 7.1 rom. I have no problems with wicked or the Sprint tar only the Boost roms. I flashed the Tar and installed another Boost rom and I try the ##72786#

    THANKS FOR YOUR REPLYS
     
  9. RuutNuBe

    RuutNuBe Newbie

    I have just rooted the boost KK 4.4.2 update that Boost pushed me. Thanks to JD and several others. I'm debloating it now and I want to know if the following KNOX files can be frozen/deleted.
    1. com.sec.knox.eventsmanager
    2. com.sec.enterprise.knox.attestation
    3. KLMS Agent
    4. KNOX Store
    5. KNOX VPN Services
    6. Samsung KNOX (which I don't even recall being there prior to root)
     
  10. jdsingle76

    jdsingle76 Android Enthusiast
    Thread Starter

    Yes
     
    RuutNuBe likes this.
  11. desilynn79

    desilynn79 Newbie

    can you help me with this? having troubles.
    says you need ndc tar but im having trouble loading it...etc.. and im getting confused:thinking:

    could you walk me through in baby steps in non techie terms exactly how and what i need to to do proprely install the kitkat rom on my prevail2 on boost mobile....
    i have a custom stock rom right now made by koumajutsu (thank you :thumbup:)... and custom kernel by orbheromax--- (3.4.orbheromax-g68cfafa-dirtycompsjp@ubuntu #2) thank you also (not sure who gets creds for the kernel)
    its mh5 but still 4.1.2
    want to be kit kat 4.4.x ........

    any and all help great appreciated!:D
     
  12. mydian

    mydian Android Expert

    This is for the S3 not the Prevail 2. Don't flash it!!
     
  13. desilynn79

    desilynn79 Newbie

    im not. i was meaning to askg if anyone knew of a working kitkat rom for the prevail2.

    thank you:)

    i already softbricked and fixed today and im not doing anything else until i can get a working kitkat rom that is for the prevail2/ ring :p

    any help find one would be great as i have searched n searched and i find plenty for everything but mine!!! that sux. maybe im not looking in the proper place even though im google searching.... maybe im not typing th right thing to find what im looking for lol

    again thank you and have a blessed night:D
     
  14. wyelkins

    wyelkins Android Expert

    Awesome job! Thanks!
     
    jdsingle76 likes this.
  15. biffking

    biffking Newbie

    Ok so I'm pretty sure I screwed my phone up. I followed the instructions very carefully. I flashed the NDC tar through odin with no issues. I reflashed Philz. I rebooted to recovery and flashed the stock deodexed and the modem. I ended up with no radio at all. I could not even make a phone call. I reflashed the tar through odin and had phone service, but no 3g-4g. I flashed the kt747 kernel, and had no luck getting data to work. Anyone have any suggestions?
     
  16. The first time I booted the phone after flashing the Modem didn't work. reflash the modem again 1 or 2 more times til it works. If by the 3rd Modem flash it doesn't work, start from scratch.
     
  17. jdsingle76

    jdsingle76 Android Enthusiast
    Thread Starter

    Download the modem again. Might not be a good file. And try again. If that doesn't work, try flashing the modem again by itself after flashing kt kernel
     
  18. LoogyG

    LoogyG Lurker

    Ok, so I have it understood that I need to flash the NDC tar firstly, and the only way to do that is through odin. I'm currently on 4.3 and can't seem to update through the OTA at all, and also my phone's USB port is messed up so it will not connect to a computer but it will charge (basically no odin). My questions is this, if I don't care about tripping KNOX, is there any way I can update without having to go through odin?? If no, will this be possible in the future, to simply flash the NDC tar, or should I just forget about it? Thanks in advance.

    Also, I have an SPH-L710(BOOOST) running ANDROID 4.3
     
  19. mydian

    mydian Android Expert

    Forget about it. You need Odin. Knox can't be removed from the rom therefore you need the NDC boot loader which you can only get by flashing the NDC tar with Odin. If your port is broken and you want Kit Kat your could flash some AOSP roms instead. Liquidsmooth, AOKP, SOKP, CM11, Nameless, Slimkat, there's a lot of them.
     
    jdsingle76 and LoogyG like this.
  20. Zayny

    Zayny Newbie

    Thanks a lot for this! I just did this yesterday and my phone has become way more faster now!
     
    jdsingle76 likes this.
  21. LoogyG

    LoogyG Lurker

    I have another question. I have access to a phone with the 4.4.2 update, and my phone with 4.3 (again, charger port is busted, so no odin). Can I perform a nandroid backup of the 4.4.2 phone and install that backup onto the 4.3 phone?? Or am I just looking at bricking my phone doing that??
     
  22. mydian

    mydian Android Expert

    No that will brick your phone. It needs the correct boot loader which you can only get from using Odin.
     
    LoogyG likes this.
  23. droidagnostic

    droidagnostic Newbie

    Thanks you guys for getting this together. :D

    Managed to get it in the box and working but it was a bit like putting a cat in a pillowcase, it did not go easy.

    Could not get network connection, noticed was getting "Unknown" on Baseband Version, multiple modem flashes did not fix. Checked all MD5 values, downloaded everything 2 times and tried all again, same result. So tried ND8 tar and got connection & baseband version but lost all data and apps, so went back and tried NDC tar again and got connection & baseband version for NDK. Then installed deodexed and modem and lost network again, re-flashed modem 2x's again and finally.

    Also noticed that each time had different number apps when "apps updating" ran, one time was 143, one time was 106, final time was 262.

    Have only one remaining issue (i think), Titanium BU is warning me that the Android ID has been changed and offers me an option to keep the new one or restore the old one. Since installing the update I have noticed some different behavior in some of my apps regarding their ability to access/use the SD card and the TB warning indicates this as a possibility.

    Is there a "right" choice here? Keep new ID or restore old ID?

    Does the ID change have anything to do with the apps new behavior?
     
  24. bob-st

    bob-st Android Enthusiast

    Are you on the ND8 ROM? If so did you flash MopedRyder's Universal LTE APN Fix to "fix" the APNs?
     
  25. droidagnostic

    droidagnostic Newbie

    No, I went back to the NDC once I managed to get a signal on the ND8. The issues (and the fixes) I was having were all covered in this thread and xda thread, I just had ALL the issues.

    Edit: went and checked out that "fix". Not sure that works for/on ND8/NDC, looks like that's for an AOSP ROM. I would ask the smart people on here before I tried that for ND8.
     
Loading...

Share This Page

Loading...