1. Are you ready for the Galaxy S20? Here is everything we know so far!

Boot loop

Discussion in 'Android Devices' started by A Simmons, Jul 3, 2017.

  1. A Simmons

    A Simmons Lurker
    Thread Starter

    My G4 spontaneously rebooted at 2am - the blue boot screen lit up the darkened room. I rolled over and went back to sleep. This morning it was showing no mobile network; the only clue as to why came when I tried sending an SMS and got an error "This might work if you insert a SIM". Powered down, reseated SIM and rebooted. The phone's now stuck in an infinite reboot loop. I've tried holding down power and volume buttons to get the boot menu; neither "recovery mode" or "factory mode" have made any difference.

    A quick Google has found a lot of complaints of the same thing but no suggested fixes except what I've already tried.

    I can't afford to chuck out a six month old device and buy a new one: I just want what I paid for to work. Help!

    EDIT: if it helps, the boot loader text includes the line "Baseband: <not found>" . That would fit the lack of mobile network I guess, but why would it suddenly lose track of a core radio function that's presumably surface mounted on the motherboard?

    To save time -- no, I haven't rooted it or made any other mods apart from installing perhaps a dozen apps, all from the Play store.

    EDIT 2: "recovery mode" gives a graphic of the android mascot on it's back with the chest hatch open with a big red "!" in triangle, and the words "No command". Not helpful.

    #1 A Simmons, Jul 3, 2017
    Last edited: Jul 3, 2017

    1. Download the Forums for Android™ app!


  2. A Simmons

    A Simmons Lurker
    Thread Starter

    Update - discovered the seekrit incantation to make Recovery Mode do something (power down, press Vol up once, release power) - tried erasing cache and then a full data delete / factory reset. Neither made any difference. That would seem to exhaust every on-the-device option for fixing this, as far as I can tell?

    This thing's a brick now, right? I'm pretty hacked off now :mad:
  3. James L

    James L Android Expert

    Use mfastboot and flash the firmware files. If you need to follow someone's guide make sure the file they have listed matches yours.

    6 months old it should be under warranty still. The firmware flash is a 50/50
    Sounds like hardware failure though.
    A Simmons and Jfalls63 like this.
  4. A Simmons

    A Simmons Lurker
    Thread Starter

    Thanks for the suggestions. I'll look into firmware... hmmmm a quick google shows no sign of any official Motorola firmware online, just various highly sketchy looking unofficial sites. I work in infosec, I'd have to hand in my "Captain Paranoia, First Class" badge if I installed some random unsigned binary from "firmware2u.ru" or suchlike.

    Struggling to understand why hardware would fail as it sat sleeping on my bedside table but who knows, cosmic rays are real after all.

    Haven't checked yet but as I don't remember paying extra for a warranty I doubt there is one over the 28 days statutory requirement.
    #4 A Simmons, Jul 3, 2017
    Last edited: Jul 3, 2017
  5. James L

    James L Android Expert

    What's the model number & or carrier?
  6. A Simmons

    A Simmons Lurker
    Thread Starter

    From the invoice, "Motorola Moto G4 Black 5.5 Inch 16GB 4G Unlocked & SIM Free". I'm on EE.

    In the process of arranging to RMA.
  7. James L

    James L Android Expert

    RMA, good choice.

    The firmware is available online though.
    I would have posted it last night, but i was working on several devices at the same time. Nvidia shield tv, a S5, a S7 edge and a few others. Sounds like the issue is taken care of.

Motorola Moto G4 Forum

The Motorola Moto G4 release date was May 2016. Features and Specs include a 5.5" inch screen, 13MP camera, 2GB RAM, Snapdragon 617 processor, and 3000mAh battery.

May 2016
Release Date

Share This Page