1. Are you ready for the Galaxy S20? Here is everything we know so far!

Bootloop 4.0.4 + fastboot unlock impossible

Discussion in 'Android Devices' started by funkyman06, Apr 15, 2012.

  1. funkyman06

    funkyman06 Lurker
    Thread Starter

    Hi Guys,

    I got a big problem yesterday after updating my nexus S. It's having a boot loop and when I tried to unlock it thanks to the "fastboot aem unlock" is saying ... FAILED (remote: Erase Fail)

    Did someone had the same problem before.

    Thanks in advance
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Deleted User

    Deleted User Guest

    We need more info.
    Are you rooted?
    Modified recovery?
    Which ROM are you running if rooted?
    How did you update? OTA or flash file?
    What is the exact process and loop when you turn on the phone?
    Can you get into recovery and wipe data and cache?
     
  3. funkyman06

    funkyman06 Lurker
    Thread Starter

    Hi,

    Thanks for your answer. I bought this phone 2 month ago, I'm not sure if it's rooted or not. When you said OTA it's the official update, then the answer is Yes (I did the update when my Android ask me to do it).

    When I turn on my phone I've got the google logo, then the ICS animation which is running in loop.

    Sorry I forgot to mention that I already wipe data and cache but nothing change.

    Thanks again for your help.
     
  4. Deleted User

    Deleted User Guest

    Then you're not rooted because the OTA official update removes root and resets back to official recovery. As for the loop, how long are you waiting for the funky boot animation? It runs the first time for a good 5 minutes or more. I'd wait at least 15 minutes to see if it boots. If not, then it sounds like your flash didn't work properly which means you will likely need to use Odin to push the update to your phone in Download mode to re-flash the phone. You'll need the USB drivers for your phone model, the Odin software, and the flash files. Unfortunately I've never used Odin so I can't help with the procedure...you'll have to google for a guide or hope someone here posts a reply with details.
     
  5. funkyman06

    funkyman06 Lurker
    Thread Starter

    Hi,

    Thx a lot for your answer.

    I waited more than 20 min for the funky animation and I tried to find some tutorial about Odin but I didn't find anything. Someone knows the procedure? (for the nexus S I9020)

    Thanks in advance.
     
  6. funkyman06

    funkyman06 Lurker
    Thread Starter

  7. Deleted User

    Deleted User Guest

    I haven't used Odin, but a quick google turned up this:

    [ROM] [APP] Odin 1.81 + stock GRH78 firmware - xda-developers

    It discusses Odin and the Nexus S and should get you started. Then google for more info...it's out there, you just need to look. Make sure you flash the correct firmware (I9020a or I9020t) - you've been warned.
    ;)
     
  8. zaherrrr

    zaherrrr Lurker

    any one can help me ?
    i have the same problem
    stop boot loop
    only google logo
    i cant unlock my phone
    faild to mount ...
    omg help me anyone
     
  9. quantumrand

    quantumrand Android Expert

    We need more info before we need more information. Which model do you have, which version of Android, are you rooted?

    Can you get into the recovery menu? If so, have you tried Wiping the cache partition? If that didn't work, have you tried a factory reset?
     
  10. skumarm226

    skumarm226 Lurker

    Hello,

    I am having the same problem, my phone is stuck in boot loop. I did OTA ICS update, it worked fine for a couple of weeks. the phone battery completely drained and after charging, it is in boot loop.

    I tried factory reset, wiping the cache partition, but still no success. I downloaded the official images from google website and i need to unlock the boot loader.

    In order to install the recovery and system images , i tried fast oem unlock first.

    It gives me error and mentions failed.

    Can anyone help me with this. Could this be a software or hardware issue.

    Thank you
     
  11. Deleted User

    Deleted User Guest

    You need to provide a lot more SPECIFIC and DETAILED information, not just "it gives me error". What failed, what software, what is the exact error message? Which procedure did you follow and how?

    We can't help with it's broken type of responses...
     
  12. skumarm226

    skumarm226 Lurker

    @bfksc
    First i tried to install the bootloader image using :
    fastboot flash bootloader bootloader-crespo-i9020xxkl1.img

    I get error that bootloader is locked and to use fastboot oem unlock.

    I tried this command to unlock bootloader
    fastboot oem unlock
    The message i get is
    FAILED (remote: Erase Fail)
    finished. total time: 5.391s
     
  13. quantumrand

    quantumrand Android Expert

    Was your phone booted into Fastboot mode when you tried the Fastboot OEM Unlock command? Then (on your phone) did you select Yes to the Unlock bootloader question?
     
  14. skumarm226

    skumarm226 Lurker

    I did enter the phone in fastboot mode and also selected yes to unlock bootloader.
     
  15. borisj

    borisj Lurker

    I've had this problem since I got the OTA update for 4.0.4 on I9020T (stock, unrooted). In the past I would try booting into fastboot and stock recovery and playing with the wipe options then rebooting from those menus and eventually after a bunch of tries it would randomly boot up normally. Now it's really stuck.

    I have the proper driver installed that came bundled with the SDK.

    From the fastboot screen, using "fastboot oem unlock" I get the error in windows cmd prompt:

    "FAILED (remote: Erase Fail)
    Finished. Total time 2.708s"


    Even though I choose Yes from the unlock prompt screen on the phone, it stays locked and gives me the above error.

    From the stock recovery menu, trying each option in order produces these errors:

    apply update from /sdcard: "E:failed to mount /sdcard (No such file or directory)"

    Wipe data/factory reset: "E:format_volume: make_extf4fs failed on /dev/block/platform/s3c-sdhci.0/by-name/userdata"

    Wipe cache partition: No errors

    Also, the device cannot be found by ADB.

    IF SOMEONE HAS KNOWLEDGE ON HOW TO FIX THIS, PLEASE HELP!
     
  16. satishm

    satishm Lurker

    I have the same exact problem as above - fastboot doesn't unlock.
    C:\>fastboot oem unlock
    ... FAILED (remote: Erase Fail)

    Everything borisj has said above applies to me. adb devices doesn't recognize my Nexus S but fastboot does.

    Please help!
     
  17. quantumrand

    quantumrand Android Expert

    Those having problems with Fastboot probably need to update their Android Debugging Drivers. Use the SDK manager to update your SDK files and then use Device Manager to install the new driver.
     
  18. ralucam

    ralucam Lurker

    I'm experiencing the exact behavior that borisj describes (I9020T). The only difference is that when the OTA update for 4.0.4 failed, I was able to load the stock image using fastboot. Afterwards I locked the phone with 'fastboot oem lock' and use it for 2 months without turning it off. However, I had to turn it off at some point, and now it is once again stuck at the Google logo. I would try to load the stock image as I did before, however, the unlock command fails:

    $ fastboot oem unlock
    ...
    FAILED (remote: Erase Fail)
    finished. total time: 3.668s

    (I get this error after I select 'Yes' on the prompt screen)

    I upgraded my android dev tools and it still fails. I ran out of ideas and I suspect a hardware problem at this point :(. Any suggestions to make it work are welcome.
     
  19. borisj

    borisj Lurker

    UPDATE:

    I just got my phone back from a Samsung repair center and it appears the problem was a hardware issue. The service slip says it was a "BGA FAILURE" and they "REPLACED PBA".

    Here's all I know about BGAs Ball grid array - Wikipedia, the free encyclopedia.

    Some good news is that my phone was outside of the 1 year warranty period and it was fixed for free, and only took a week to get back to me. If you decide to try to get it repaired, make sure you talk to Samsung on the phone (not email or chat) and let them know you've tried a lot of troubleshooting steps.
     
    ralucam likes this.
  20. ralucam

    ralucam Lurker

    Thanks borisj. I will get in contact with Samsung. I am very glad it worked out for you.
     

Nexus S Forum

The Nexus S release date was December 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

December 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...