1. Are you ready for the Galaxy S20? Here is everything we know so far!

Bootloop after Reinstalling & Updating SuperSU

Discussion in 'Android Devices' started by Devon96, Aug 19, 2019.

  1. Devon96

    Devon96 Lurker
    Thread Starter

    Hey Everyone,

    (Device: OnePlus 3
    Android: 8.0.0)

    today i tried to uninstall SuperSU manually (yeah, this was not the right way) to make way for magisk - my banking app isn´t working anymore so i tried to hide the root from it. I read some article on the internet that i have to uninstall supersu before i can use magisk - made sense to me, because you only need one for rooted devices. I did the uninstall, but i wasn´t still able to install magisk. So i reinstalled SuperSU.

    After the Reinstallation the App asked me to update the App and reboot - for sure, lets do this.

    Bootloop.

    the last two hours i tried to figure out how to solve the bootloop. I´m able to get into twrp (3.3.1) and the connection with my PC is stable, i can see all the data. First of all, I installed the Supersu 2.82 zip because i thought its that simple, but it didn´t worked. So i installed the Supersu 2.79 to get back to the start. Bootloop is still there. At last I did the factory reset wipe (data, cache and dalvik) and tried again to install the supersu 2.79 version. Still Bootloop.

    Last chance i see is the mega unbrick guide for OP3 (https://forums.oneplus.com/threads/...vXbYndoY0-3df5FZcf2s-S9nsZ__0Ek-uPTdq4Fs8Oy5s) but i prefer another way, because the device isn´t completly damaged (i think....)

    It would be great to know some way to stop the loop! Thanks in Advance.

    M.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™
    Moderator

    I moved your post to your device forum, for proper exposure and support
     
    ironass and ocnbrze like this.
  3. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    since you have twrp still just either restore a nandroid backup or flash a custom rom......just remember as long as you have access to your custom recovery (twrp) all is not lost,

    hopefully you have made a nandroid backup........that is.
     
    GameTheory and DonB like this.
  4. ironass

    ironass Extreme Android User

    Sorry to hear you are having problems.

    As you have TWRP custom recovery installed, hopefully, you have a nandroid backup you could install in TWRP Restore. Failing that, you could flash the stock OxygenOS firmware using ADB. Alternatively, you can, as you have mentioned, use the OnePlus brick tool which, for some, is easier that flashing via ADB.
     
    GameTheory, ocnbrze and DonB like this.
  5. Devon96

    Devon96 Lurker
    Thread Starter

    Thank you all for the fast response! It really helped me out.

    Unfortunatly i made no backup... but that´s something i won´t miss in the future. So i tried to flash the latest OxygenOS for Android 8.0.0 (5.0.8) and it worked. The Installation took some time and i thought i´m back in the boot loop, but it finally started into the introduction screen - the device has been completly wiped out through the flash. Luckily i saved the most important things before.

    Does somebody know what exactly happened within the phone? I´m just wondering because i don´t think it was the update of SuperSU, i guess it was my unwise decision to uninstall the app and reinstall - that damaged the SU binary... but its just my own explanation.

    Thank you again!
     
    ocnbrze likes this.
  6. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    AWESOME!!!!!!!!Not sure what happened. I would make a nandroid backup as soon as possible.
     

OnePlus 3 Forum

The OnePlus 3 release date was June 2016. Features and Specs include a 5.5" inch screen, 16MP camera, 6GB RAM, Snapdragon 820 processor, and 3000mAh battery.

June 2016
Release Date
0
Reviews
Loading...

Share This Page

Loading...