Bootlooped Huawei Y320 U30 bootloop No root or debugging enabled


Deleted User


I have a Huawei Y320-U30. I tried to factory reset it, then I got splash followed by an infinite flashing Huawei logo. I don't have root permissions and debugging is not enabled.

I downloaded a firmware (there were a lot of different country firmwares for my device I am not sure if it was correct one), and tried to install it with adb sideload. Console loaded it successfully, but when it started to install on device, there was android logo on the screen with a progress bar, when the progress bar reached about 33%, progress bar disappeared and logo changed to android with exclamation mark, it returned to recovery menu.
Now I don't get any splash or flashing logo, it's stuck at huawei logo again, but it isn't flashing. I am not sure about bootloader status, because when executing most fastboot commands in fastboot mode (it detects my device) I get three dots and after some time it says FAILED (status read failed (Too many links)).
No idea what to do now. Just tried several different firmwares but same. I don't have any recoveries installed.

Thank you in advance.