1. Are you ready for the Galaxy S20? Here is everything we know so far!

Bricked HTC One M8 - Help ASAP =(

Discussion in 'Android Devices' started by ExothermOfficial, Feb 21, 2015.

  1. Rich C

    Rich C Newbie

    Thanks, unfortunately nothing is working for me. Not sure if I mentioned this (and excuse my blasphemy of the lingo): my ROM is locked. I cannot get it unlocked despite half a dozen attempts at Unlock_code.bin from HTC. I see this:
    C:\Android>fastboot flash unlocktoken Unlock_code.bin
    target reported max download size of 1826414592 bytes
    sending 'unlocktoken' (0 KB)...
    OKAY [ 0.125s]
    writing 'unlocktoken'...
    (bootloader) unlock token check successfully
    OKAY [ -0.000s]
    finished. total time: 0.141s

    then when the phone reboots I see the HTC logo, then dark, then the AT&T logo, then I am back to the original Decrypt storage screen. As someone who is reasonably IT savvy yet new to these processes, my gut feeling is that somehow AT&T is getting its hands in there and relocking it. I am afraid that's also why the RUU isn't working.

    Any further thoughts? Thanks again!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Your phone has to be locked or the RUU won't work.

    So we're clear - an RUU won't work on an unlocked bootloader and it won't lock it either.

    The point of suggesting the RUU was to clear the phone to a like-new state so you could unlock from there and do whatever else you had in mind.


    AT&T isn't getting in anywhere through some secret path.

    Your phone is in an error state.

    The error has to be cleared before proceeding.

    "Fix error'd phone by unlocking and rooting," is the biggest, undying misconception there is - it never works that way.

    Continuing to beat on it with a failing unlock command is a waste of time.
     
  3. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    And do confirm that the Unlock_code.bin file that you got directly from HTC is in the same folder as fastboot.
     
  4. Rich C

    Rich C Newbie

    Thanks, I appreciate all of your advice trying to help me. Guess I will take it to an AT&T place so they can tell me I need a new one. While still here, I will see whether I can sidestep the USB error when ready to flash by trying to load the RUU via SDcard.

    All I have in mind is to get my 15 month phone working again.
     
  5. Rich C

    Rich C Newbie

    Yes, the files are all in a single directory. I tried a fresh set from what I used yesterday, but no improvement in result:

    C:\Android>dir
    Volume in drive C is OS
    Volume Serial Number is F04D-2260

    Directory of C:\Android

    07/25/2015 12:45 PM <DIR> .
    07/25/2015 12:45 PM <DIR> ..
    06/22/2015 07:35 PM 944,128 adb.exe
    06/22/2015 07:35 PM 96,256 AdbWinApi.dll
    06/22/2015 07:35 PM 60,928 AdbWinUsbApi.dll
    06/22/2015 07:35 PM 318,464 fastboot.exe
    06/22/2015 09:23 PM 132,344 MAF.exe
    07/25/2015 10:08 AM 792,239 minimal_adb_fastboot_v1.3_setup.exe
    07/25/2015 11:01 AM 1,611,939,316 RUU_M8_UL_L50_SENSE60_ATT_MR_Cingular_US_4.28.502.1_Radio_4.0.U605611@50319A_40.45.C33065.00_F_release_426617_signed_2.exe
    07/25/2015 12:43 PM 17,428,480 twrp-2.8.7.0-m8.img
    07/25/2015 10:10 AM 1,010 unins000.dat
    07/25/2015 10:09 AM 717,985 unins000.exe
    07/25/2015 10:04 AM 256 Unlock_code.bin
    11 File(s) 1,632,431,406 bytes
    2 Dir(s) 70,670,700,544 bytes free
     
  6. Rich C

    Rich C Newbie

    I'm pretty determined to exhaust all my do it yourself options. This time, since trying to use the latest RUU in FASTBOOT USB mode with the USB error, I tried to see what would happen if I loaded the RUU onto an SD card and tried booting the phone with that. I had intended to do this with FASTBOOT but something else happened.

    I used 7Zip on RUU_M8_UL_L50_SENSE60_ATT_MR_Cingular_US_4.28.502.1_Radio_4.0.U605611@50319A_40.45.C33065.00_F_release_426617_signed_2.exe to make a ZIP. Then I renamed the ZIP to 0P6BIMG.zip and copied it to the SD card. Put that in the phone and booted while holding down Volume Down and Power. This is what I saw. (I'll be embarrassed if you can't see the pics from the Facebook album):

    I did not see the full HBOOT screen with options for FASTBOOT, RECOVERY, etc - instead it went right to this:
    https://www.facebook.com/photo.php?fbid=956094324431592&l=d6785cf013

    This looked quite promising since it noticed the media. So I waited. And eventually saw this:
    https://www.facebook.com/photo.php?fbid=956094244431600&l=569f2e6662

    Which made me even more hopeful. After the progress indicator on the upper right finished creeping along (just a few minutes to this point) I saw this:
    https://www.facebook.com/photo.php?fbid=956094074431617&l=4da0c90e13

    Which brought me to the moment of truth. Unfortunately, the final result was "no change":
    https://www.facebook.com/photo.php?fbid=956093877764970&l=4eb55d0285

    The last picture was the same screen I saw when I woke up in Vegas that fateful Wednesday morning after charging the phone in my hotel room bathroom. Am I on to anything here? Any p0tential progress in my mission to restore the phone? Or am I just wasting more time? Thanks!
     
  7. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    The RUU exe contains the rom zip.

    The RUU is a cryptographically signed with a security signature (s-on, that's what the s is for, your phone requires it) and contains an installer script and the rom payload.

    You can't just create zips, give them the magic name, and have them work.

    Edit - magic name of course is 0P6BIMG.zip

    During RUU execution, the rom.zip will get extracted to a temporary folder on your pc.

    Look for it by that name, copy it over to a safe place, give it the magic name, put it on your SD card and try booting into FASTBOOT - if anything will work, it's that.

    I think that's only doable on an s-off phone but you want to try everything - that's everything.

    I take it you tried another pc and it didn't work out for you.
     
    #157 EarlyMon, Jul 25, 2015
    Last edited: Jul 25, 2015
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Have you tried entering the wrong thing 30 times?
     
  9. Rich C

    Rich C Newbie

     
  10. Rich C

    Rich C Newbie

    Well, I did get some "action" from the ROM.zip trick. I did find it in my Windows profile local temp folder after launching the RUU installer, yet before it tried to interact with the phone. Put ROM.zip on the SD card and rebooted the phone. Even with Vol Up and Power it went right into the flashing process. I definitely saw some things happening that looked promising, but again, the phone rebooted and went right back to the Decrypt Storage screen. Here's a pic of what I saw before starting the "update."
    https://goo.gl/photos/FaFNagMAXN5TRKkN9

    I had thought to try entering garbage passwords 30 times (given that I don't really know what password it is expecting, except that when I try a password, the message comes up "The password you entered is correct, but unfortunately your data is corrupt..." Ending with a button to "Reset phone," which brings me back to square one again.
    https://goo.gl/photos/PMHF5STowRZKr7rD9

    I wanted to try using FASTBOOT to follow your advice (maybe I am doing so by default) but I have to pop out the SD card first. I tried that on my original attempt with the SD card as well. So I would pop the card tray out, boot using Vol Up and Power, get into FASTBOOT, slide the SD card tray in, then try choosing REBOOT FASTBOOT. Nothing.

    The only other thing I might try is using the "fastboot flash zip rom.zip" (if I have that correct) in FASTBOOT USB mode (even though that's given me problems). I will save that for tomorrow

    EarlyMon, it's been very nice of you to follow this ordeal of mine so responsively. I fear I won't get the time of day from AT&T, but we'll see.. If nothing else I can ask them to redo a "big" SIM card for my older Samsung Captivate Glide (lol) or maybe they can talk me into a new phone. But I'm pretty old school, and hate the idea of trashing a device for which I paid a good bit of money not so long ago.. And then do that again!

    OK, I'm driven ;) I am going to try this using USB but I will await any comment you have before giving up. Thank you again!
     
    EarlyMon likes this.
  11. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    No, fastboot flash zip rom.zip is not going to work unless you can get the phone into RUU flashing mode.

    Which if you could do that, you could run the RUU.

    Trying that by hand is on you.

    You're probably this >< close to turning your phone into a paperweight.
     
    Rich C likes this.
  12. Rich C

    Rich C Newbie

    I suspect it already is/has been a paperweight, though all visual evidence shows that it's no worse off than it was on Wednesday.. :eek: I will post again once I visit AT&T.. I'm torn over whether a company store would be better than an indie..
     
  13. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK try this -

    FASTBOOT USB mode, from command window -

    fastboot erase cache

    fastboot erase data

    fastboot reboot
     
  14. Rich C

    Rich C Newbie

    OK..

    Microsoft Windows [Version 10.0.10162]
    (c) 2015 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>cd\android

    C:\Android>fastboot erase cache
    ******** Did you mean to fastboot format this partition?
    erasing 'cache'...
    OKAY [ 0.016s]
    finished. total time: 0.016s

    C:\Android>fastboot erase data
    erasing 'data'...
    FAILED (remote: not allowed)
    finished. total time: 0.000s

    C:\Android>fastboot reboot
    rebooting...

    finished. total time: 0.016s

    C:\Android>

    It rebooted to the good old "Decrypt Storage" screen.
     
    EarlyMon likes this.
  15. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    And if you go to recovery from HBOOT and try wipe data/factory reset, that doesn't work?

    When you get the decrypt storage screen, can you long press power and get the power menu? If so (probably a big if), long press power, go to safe mode.
     
  16. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    If none of that works, the phone storage is probably corrupted.

    You mentioned that it happened on the charger overnight - could have been a voltage spike.
     
  17. Rich C

    Rich C Newbie

    That was my initial hunch as well - a surge or spike.. I guess with a locked phone there is no good way to wipe it clean or do a filesystem check. Maybe HTC will help me if AT&T can't.
     
  18. Rich C

    Rich C Newbie

    EarlyMon, I didn't see your earlier two posts. It doesn't seem that ANY of the HBOOT menu options did anything for me. The closest I got to action was when I booted the phone with the SD card containing ROM.ZIP. Even then the reboot proved fruitless.

    If I long press power I have had three options: power off, airplane mode on/off (it's on), and restart. Nothing about safe mode, though I have gotten into safe mode accidentally a few times (not sure how). Web sites say to power down, power up, and hold volume down after seeing the HTC logo until safe mode comes up. How could that help me? I'm pretty sure that the times I have done this by accident I had the same Decrypt Storage screen come up.
     
  19. Rich C

    Rich C Newbie

    2nd reply: I gained Safe Mode to confirm that I still get to the Decrypt Storage screen except for seeing Safe Mode in the bottom left corner. I decided to be bold, entered a random but "correct" (l0l) password and stick the SD card with the ZIP back into the tray, then press the Reset phone button on the second screen. Did a normal boot (no finger holds). Nothing happened.

    Well, I am living proof that what happens in Vegas doesn't always stay in Vegas. I wish this had stayed! :/
     
  20. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Yeah, definitely a bummer my friend. :(

    Safe mode - at power menu, hold power choice until safe mode choice appears.

    When the /data partition is absolutely, totally and completely corrupted, it won't mount at all.

    That leads to HBOOT and FASTBOOT errors - and upon system boot, the system can't figure out why it doesn't have a data partition so it runs home to Momma so to speak (a Hunt For Red October movie reference, but I'm talking about a piece of built-in code) - and Momma says that the only way she allows that is if the /data partition is encrypted by you by choosing that from the security settings.

    That leads to the useless decrypt password screen.
     
  21. Rich C

    Rich C Newbie

    Ugh.. Is it possible that the AT&T store or perhaps HTC could do a lower level reimage onto the internal SD? like a "dd" that could restore a stock image? I'm getting that you believe my hardware is OK just that the storage is corrupted beyond "normal" repair. That's how I see my situation.

    I used to have an Ubuntu dual boot laptop but not since Windows 10 (not that I am an *ix wiz at all). I used to use dd to copy TK50 cartridges on a DEC MicroVAX back in the 80s or 90s. There is a dd for windows; do you think I could get a source distro and dd instructions to reload the phone in a raw fashion? For example, on http://uranus.chrysocome.net/linux/rawwrite/

    Thank you again for all the feedback and advice!
     
  22. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    You've got the right idea - and being a compact, real-time Apache/Linux distribution, Android definitely understands the dd command.

    Except the partitions are locked and because of an induced error, you can't unlock the bootloader.

    Catch 22.

    So, I expect that HTC might be able to fix this, don't know about AT&T, the RUU is pretty strong mojo.

    However - one of our compadres - @scotty85 - has some strong hardware tricks too.

    Let me rustle him up for you. Wait for his reply...

    If you need to send him your phone, I'll vouch for him - as will everyone here and at XDA ok.
     
  23. Rich C

    Rich C Newbie

    Thanks - I will wait to hear back.

    Could Sunshine unlock the bootloader for me? (From what I've seen you need to install the APK for it and since my phone is bricked I don't see a path to get an APK installed anyway, which looks like another Catch 22.)
     
  24. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Thought of that already, so yeah - no.
     
    Rich C likes this.
  25. scotty85

    scotty85 Extreme Android User

    I believe that turning s off may help in that a different run may be run. If you'd like to send me the phone,I can do that with the aid of an HTC service card. At that point I can see if there is anything I can do.
     
    Rich C likes this.

HTC One M8 Forum

The HTC One M8 release date was March 2014. Features and Specs include a 5.0" inch screen, 4MP camera, 2GB RAM, Snapdragon 801 processor, and 2600mAh battery.

March 2014
Release Date
0
Reviews
Loading...
Similar Threads - Bricked HTC Help
  1. itsmedude
    Replies:
    10
    Views:
    421
  2. Charan Sai Pedireddi
    Replies:
    16
    Views:
    445
  3. iamashrafulbd
    Replies:
    0
    Views:
    333
  4. gabrieltito234
    Replies:
    14
    Views:
    1,184
  5. App Update
    Replies:
    0
    Views:
    664
  6. NovakCo
    Replies:
    1
    Views:
    328
  7. Rasil1127
    Replies:
    2
    Views:
    883
  8. Hank Harwell
    Replies:
    4
    Views:
    1,793
  9. App Update
    Replies:
    0
    Views:
    442
  10. TobyKaos
    Replies:
    1
    Views:
    599

Share This Page

Loading...