1. Download our Official Android App: Forums for Android!

Root Bricked or can be restored???Please help can't find a solution on various forums

Discussion in 'Android Devices' started by ROHIT345, Sep 18, 2011.

  1. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    Please help experts...have a desire which was S-off and I was running customs ROMs regularly on the same. I used RUU HTC ASIA India 2.13.720.1 everytime to unroot it without any problems.

    Recently I had a camera problem and needed to send my desire for warranty so tried flashing the above RUU and it gave me Error 110 saying file open error. Now I have a desire stuck on black htc screen with four corners having the triangle.Power +volume down shows me the following screen
    Alpha rev CM7 r2
    Bravo PVT4 SHIP S-off
    HBOOT 6.93.1002
    ...
    ...
    RUU

    I can only access the Fastboot thru my comupter(It shows my device under fastboot devices) so i tried fastboot update PB99IMG.zip (extracted it from RUU) it gives error whoops : didnt find expected signature.

    Is there a way out restore my phone....please help
     

    Advertisement

  2. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,306
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Oh for god sake. This is so obvious. If you had read the alpharev site before becoming s-off, you would understand.

    1) cm7 hboot is too small for stock sense Roms

    2) the r2 hboots have downgrade protection so an RUU will not overwritte it.

    Solution
    Boot to fastboot, and fastboot flash the downgrader.img from the alpharev site. After this, run RUU

    Preventative measures
    Don't flash things blindly. Understand what you are flashing before flashing it and know how to reversed it
     
    porter_james likes this.
  3. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    this has happened because you didnt set the hboot to alpharev downgrader hboot.
    because its cm7 the partition sizes are wrong and as such its killed the device.
    you can try fastboot flashing the downgrader from the alpharev website then attempting the RUU again.

    the only time you can flash an ruu without changing the new hboots (6.93 rather than 0.93) is when you are on the standard sizes and even then thats useless for warranty purposes as it keeps the alpharev logo there.

    good luck
    due to cache being so small this might not be reversable as the radio is stored here during flash and if that fails its as good as a full brick

    EDIT: SUroot got there first
     
  4. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    I downloaded the downgrader.img from alpharev site i get a error when i fastboot flash (filename)
    unknow partition '(filename)
    error: cannot determine image filename for filename

    thanks....for your help....
     
  5. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,306
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Fastboot flash hboot c:\downgrader.img

    If its called downgrader.img and on the root of your c drive
     
  6. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    sending hboot (512kb)...okay
    writing hboot ...okay


    tried running the ruu again got stuck at same 50% when writing system with same error 110

    tried a different india ruu also same error reached 57%...

    now my screen says

    Alpharev Unlock
    Bravo PVT4 Ship S-off
    Hboot 6.93.9999
    ....

    RUU
     
  7. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,306
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    Put the PB99IMG.zip on your sd card and boot to hboot
     
  8. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    as i said that option is not available as my phone only shows two screens
    if no usb cable is plugged
    Bravo PVT4 s-off
    HBOOT 0.93.0001
    ...
    ...
    ...
    RUU
    if plug in USB cable Black screen with HTC logo and triangles at corners

    I tried running the India RUU 2.13.720.1 again and now I get the error 140 bootloader version error. Tried running the teppic tool to downgrade bootloader but it doesnt work.

    Tried flashing the RUU WWE 2.29.405.5 i get the CID error.(I dont have a gold card)

    Is there any way out to restore it, i can only access my phone thru fastboot on my computer....

    thanks for your help.
     
  9. SUroot

    SUroot Android Expert
    Rank:
    None
    Points:
    1,123
    Posts:
    23,925
    Joined:
    May 25, 2010

    May 25, 2010
    23,925
    5,306
    1,123
    UK Technical Lead; Desktop Support
    Riddlesden, West Yorkshire, UK
    The downgrade tool will not work because the phone needs to boot.

    What RUU are you using that gets the bootloader error? It's too old. Is it the same as your original software version?

    Why.not just make a goldcard and use the .2.29.405.5?

    Don't stress, this is fixable
     
    ROHIT345 likes this.
  10. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    RUU HTC ASIA INDIA 2.13.720.1 ...very difficult to find India specific latest RUU after this one.
    How to create gold card ? I just tried vorbett utility but since phone cannot execute adb commands i cannot proceed.(Failed to get CID)
     
  11. Rastaman-FB

    Rastaman-FB Android Expert
    Rank:
    None
    Points:
    313
    Posts:
    6,113
    Joined:
    Sep 11, 2009

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    use our guides, you can use a card reader if the phone is not bootable
     
    ROHIT345 likes this.
  12. ROHIT345

    ROHIT345 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    28
    Joined:
    May 1, 2011

    May 1, 2011
    28
    5
    16
    thank you guys used ubuntu to get cid of sd card and create a gold card. Phone is working now and off to HTC for camera repair.
     
    Rastaman-FB likes this.
Tags:

Share This Page

Loading...